LMS 3.0.1 Data Collection constant running state

Unanswered Question
Sep 17th, 2008

Hello all,

I am running LMS 3.0.1 with all the latest patches. About every 10th data collection whether it be done manually or scheduled, CM becomes stuck in a data collection "Running" state. So far I am unable to find a method within CM to stop the data collection from running. I am also unsure why it "hangs" in this state. All other features work when this occurs, however I am unable to add any devices while it is in this state. I have rebooted the Windows server and it appears to temporarily fix this issue. In searching the forum it does not appear that anyone else is experiencing this problem. Please let me know if you have and what solution you implemented to correct this. Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 09/17/2008 - 07:34

You can force Data Collection to stop by restarting the ANIServer daemon. However, that won't tell you why it is hanging. For that, you should check the ani.log for any errors. It may be that debugging will need to be enabled, but the problem might be so severe that an error gets logged without it.

agivens02 Wed, 09/17/2008 - 10:57

I have checked the ani.log and found the scheduled data collection that ran last night at midnight. It has a normal start and end. The strange thing is I do not see the manual data collection that I started this morning that caused it to stay in a constant "running" state. Perhaps it is not severe enough to show up? Are you aware of any known issues with this? I do not mind waiting for the next patch if necessary. Also if I need to turn on debugging, how do I go about that? Will turning that on lead to a possible resolution? Many thanks for your input. LMS is a great tool, but I really am at a loss to correct this issue.

Joe Clarke Wed, 09/17/2008 - 11:06

Assuming you are running Campus Manager 5.0.3, I am not aware of any issues that will cause Data Collection to hang. You can enable core, corex, frontend, and framework debugging under Campus Manager > Administration > Debugging Options > Data Collection. Make sure your file size is large enough so that any problems are caught. When Data Collection hangs again, the ani.log should indicate what it is doing.

agivens02 Fri, 09/19/2008 - 09:05

Ok. I have enabled debugging on all the items you listed. Next time this occurs I will check it out and let you know what I find. I appreciate the tip.


This Discussion