Using Third Parth Compact Flash in a 2811 Router?

Unanswered Question
Sep 17th, 2008

Hello all. I have a 2811 with a Cisco-installed 64MB compact flash card installed. It's not enough to install CallManager Express. We are in a pinch and need a bigger card fast. We tried using a Transcend 256MB compact flash card (not Cicso-approved or anything).

It doesn't work though. As far as we can tell it is formatted just as the 64MB card. Has all the same files on it but it won't boot.

If we boot with the 64MB card and then swap in the 256MB card, the console will display messages saying CompactFlash has been inserted. But "sh flash:" will result in device "flash:" not found.

Please, any ideas?

We should be able to use third-party CF cards if we want to right?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
andrew.butterworth Wed, 09/17/2008 - 13:16

I have just checked and the 2811 should support up to 256MB Compact Flash cards. I have used non Cisco cards before without issues. Did you try formatting the new card from the routers CLI when it was first inserted?



graham.fleming Wed, 09/17/2008 - 13:18

Thanks for the reply.

The trouble is we can't format the card from the router because whenever we do "format flash:" it says "Flash:" not found.

We have formatted it in Windows as FAT.(not FAT32).

andrew.butterworth Wed, 09/17/2008 - 13:29

Hmm... I haven't got a 2811 to hand to have a look at this for you (I have various Compact Flash cards though but that doesn't help...), so I am going to struggle to help any further. Hopefully someone with a 2811 will reply shortly.


mdavis1969 Tue, 12/02/2014 - 16:40

Erase flash is the key then do the format. Had a brand new Cisco flash that exhibited the same symptom and this fixed it.

Mark Yeates Wed, 09/17/2008 - 13:52

There are some third party compact flash cards that will work. You will need one that is NOT high speed or ultra or anything like that. I use a traditional san disk 256Mb CF card and it works great (also used in a 2800). I always carry one in my bag that has all the IOS's for recovery purposes. Here is a link for the one I use.



nmooremvsc Wed, 09/17/2008 - 17:21

I have a 1811 that came with a Cisco 32mb flash card. I was able to install a generic 128mb flash card by plugging in a usb card reader to the routers usb port. Then I was able to format it as usbflash: if I remember correctly.

burleyman Thu, 09/18/2008 - 04:05

Based on your are doing this while the router is still powered on....I have found it does not work when you swap the compact flash with the router powered on. Did you power off then swap the flash and then power back on?



This Discussion