ASA webvpn and Vista

Unanswered Question
Sep 17th, 2008

Hi all. I have setup webvpn on our asa, and I have a link that allows me to click on it and directly RDP to a server. It works well on my XP machine and also a Mac, but a Vista machine it wont work with. It just takes me back to the portal home page. Anyone have any issues with this in the past?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
obeat4cisco Wed, 09/17/2008 - 19:29

I read somewhere that you have to upgrade the ASA to 8.0 to be able to VPN with Vista.


jjoseph01 Wed, 09/17/2008 - 21:28

Yeah, I upgraded to 8.0 already. Ill try the java link and let you know. Thanks.

JORGE RODRIGUEZ Thu, 09/18/2008 - 11:00

Got busy at my end to look for release notes on rdp plug-in to see open caveats if any in previous versions, will do when I get a chance , but do you use in asa latest plug-in release version?, try to see if that helps..


Terminal Service client plugin for ASA 080506 11-AUG-2008 870718

jjoseph01 Thu, 09/18/2008 - 20:24

Well, I think it is, its on my laptop, which Im not at at this moment. Ill check this Friday and verify. Ill let you guys know, thanks.

ari123zzz Thu, 10/30/2008 - 07:44

I have the same problem, and see that a similiar issue is posted all over the internet. Any idea where we can get a comment from Cisco?

I run my WebVPN and RDP plugin on XP and everything works fine on both ActiveX and Java, but with Vista the Active loads and I get a security question asking me to 'Connect', I click connect and nothing happens. I then try the Java version and it loads, but after 1 minute or so I get a Socket Connection Reset error.

This seems to be a Vista Security issue or something. Cisco says this software works for Vista, but I don't see that being the case.

aaoybe Fri, 11/07/2008 - 01:03

Did you add the site to the trusted sites in vista?

sdunkin Fri, 11/07/2008 - 08:24

Based on the SSL VPN Client FAQ doc, this is an issue with the STCIE, or install enabler. It uses ActiveX to download/install the SVC. Vista and/or IE7 treat ActiveX differently so it will not let the install enabler run. Adding to trusted sites does not help, nor does modifying any of the IE security settings.

I am having this same problem with the SVC. WebVPN thin-client works as does Java, but the SVC will never download and install. We are on ASA722 and ASDM522.

Do we just need to upgrade to ASA 8.0?

aaoybe Mon, 12/08/2008 - 05:08

It works on 8.x. So i guess you should upgrade. Had no problems with any of our firewalls after the upgrade.


This Discussion