3750-E License Install Failure

Unanswered Question
Sep 17th, 2008
User Badges:

When installing the license for a 3750-E I get an error that the license doesn't reside on the flash though dir reveals the image in flash. Seen this, know of a resolution?

Thanks!

Matt

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MachadoGB Mon, 07/27/2009 - 07:14
User Badges:

I am having the same (or similar) problem. I do have two Cisco C3750-E switches mounted in on stack configuration.


I am running IOS version: c3750e-universalk9-mz.122-40.SE.

I do have one license for IP advanced running OK, which gives me layer 3 features.

In case I have a power outage the switch comes back and license for layer 3 fails. I have to reload and make the switch 2 master to get the license back.

I have uploaded the license files to Flash1 for apply secondary license into switch01 with name 'license_IP_ADV_2”. But when I try to install the license I go the message:


Command I use: license install flash1:/license_IP_ADV_2

Message I get: “% License installation failed with error: XML parsing failed”


Let me know if you have any guidance at this time.

Thank You.

Gilson


Reza Sharifi Mon, 07/27/2009 - 08:24
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Gilson,


I had the same exact issue with 3 3750-E switches we have. It took us a long time with TAC, our SE and sales rep to get this resolved (what a pain).


1-try adding a forward "/" after flash

and before you add the .llc file.

The correct syntax on the 3750E is:

#license install flash:/CAT1114R0CO_20090526094501582.lic

(NOTE THE "/")


2-If that does not work, make sure when you download the license key use upper case not lower. For some reasons, if the license in the key file is in lower case, it would not work. Because the actual license on the box is in upper case



HTH

Reza


Aaron Woland Wed, 01/06/2010 - 11:30
User Badges:
  • Cisco Employee,

Also:


If the software version is not up-2-date it may fail.


I had a 3750-E and tried to install a license that failed until I updated the IOS to the latest revision!


-Aaron

Andrew Woolman Sun, 05/27/2012 - 17:48
User Badges:

I've been experiencing the same issue and I think I may have the answer. I think the IOS version may have something to do with it. Perhaps a newer version has a different XML schema (I don't know much about XML).


I removed the lines

30YES


from the license file and it installed fine. You can open the .lic file in notepad.


Good luck

Actions

This Discussion