IE3000 image copy

Unanswered Question
Sep 17th, 2008

Hi

I run the archive upload-sw to create tar file on ftp server.

then swap flash card with new one and run dowmload-sw to put image on new flash.

I get

ERROR:Malformed 'info' file

ERROR:Image is not a valid IOS image archive.

I can sh flash ok on both CF cards

Any ideas.

regards

Noel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
noeldrose Wed, 09/17/2008 - 21:37

I used the upload-sw command which creates a tar file on the ftp server which contains all the files in the image folder including those required for the html interface. I assumed the download-sw would unzip the tar file and recreate the image folder on the new CF card. The switch documentation shows the downlod comand as

archive download-sw /leave-old-sw /reload ftp:[[//username[:password]@location]/directory]/image-name.tar

this references a tar file not bin.

nbarodia Wed, 09/17/2008 - 22:03

Thanks for correcting me. The command does accept the tar files.

Is the image filename the same as one you downloaded from CCO?

It does not like any other names.

Can you post the exact upload and download commands you used?

noeldrose Wed, 09/17/2008 - 22:19

Hi

I have just purchased the new IE3000. It comes with a removable CF card. I also purchased a spare Cisco CF card. From the telnet comsole I use

archive upload-sw ftp:////.tar

this creates a tar file on the ftp server.

I then remove the existing CF card and insert the new one. I then run

archive download-sw ftp:////.tar

This attempts to unzip the file. the screen shows information like.

loading /.tar!!!!!!!!!!!!

[ok -11875328/4096 bytes]

examining image..

extracting info (103 bytes)

extracting //info (339 bytes)

extracting //info (341 bytes)

extracting info (103 bytes)

ERROR: Malformed 'info' file

ERROR: Image is not a valid IOS image archive

I don't have access to download files from CCO

regards

Noel

nbarodia Wed, 09/17/2008 - 23:44

Can you mention what you put in the command and the output for 'sh ver | i 122' please ?

noeldrose Thu, 09/18/2008 - 00:01

I initially tried a file name like ie3000.tar then tried a file name the same as the image name. Both gave the same result.

I'm not on site at the moment and won't be back until Monday local time. Can't get to the switch to try the version command. I will respond when I get back.

Thanks for your help.

regards

Noel

noeldrose Sun, 09/21/2008 - 13:20

Hi

Here is the result.

coalhpppcn_ns13#sh ver | i 122

System image file is "flash:/ies-lanbase-mz.122-44.EX1/ies-lanbase-mz.122-44.EX1

.bin"

Motherboard serial number : FOC12241CUF

Actions

This Discussion