Gateway H323, multiple isdn switch types

Unanswered Question
Sep 17th, 2008

We have a H323 Gateway with a Call Manager, with one E1 connected to a PBX through QSIG, and to the PSTN throufh a net4 PRI. When we make a call from an analog phone to the PSTN it fails with the message: "Cause i = 0x829F - Normal, unspecified"

If we made the call from the analog phone to an ip phone it is OK:

It looks like if there is a problem with the two switch types

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
slongewa Thu, 09/18/2008 - 08:18

Is the analog phone hooked up to the gateway, the PBX, or the Call Manager?

mariapenilla Mon, 09/22/2008 - 23:16

Hi,

I have attached the isdn q931 debug, the voice dialpeer debug and, not sure, the voice ccapi inout.

There are more calls in the log, as the system is up and running.

You will see the call finally establishes, because in order to solve it we have configured and alternative way for this call. Instead of the call going through the gateway (dialpeer 5) (from the PBX(E1)-gateway- PSTN(E1)) we have done it through the Call Manager (PBX(E1)-CCM-Gateway-PSTN(E1))

thanks

Attachment: 
CHRIS CHARLEBOIS Wed, 09/24/2008 - 10:02

I beleive the problem here is with the E1 provider. Your gateway doesn't report an error, but does receive the diconnect message with the '31' cause code from the provider's switch. Looking at the q931 debug from both the PBX-PSTN and the CCM-PSTN calls, the difference seems to be the Called Party Number Plan is 'Private' from the PBX and 'Unknown' from the CCM.

You can force the Called Party Number Plan and Type from the seriel interface for the E1. Try this command on the PSTN E1 interface:

isdn map address .* plan unknown type unknown

Thinking about this some more, I think it makes sense. There is probably an option within the PBX to set the outgoing ISDN switch type. It is probably set to something like Tie line or possibly internal, which is why it is specifying a private number plan. The PSTN switch rejects it because it isn't configured to deal with private number plans.

Actions

This Discussion