satish_zanjurne Thu, 09/18/2008 - 01:36
User Badges:
  • Silver, 250 points or more

1.Assuming that Executives & users are in seprate vlan


2.class-map match-all exe-traffic

match access-group 1


class-map match-all user-traffic

match access-group 2


access-list 1 permit exe-vlan

access-list 1 permit any any


access-list 2 permit user-vlan

access-list 2 permit any any


2. Create Policy map & allocate bandwidth

Don't allocate more than 75 percent of total classes


policy-map traffic-policy

class exe-traffic

bandwidth 768

class user-traffic

bandwidth 768


3.Apply policy on WAN interface 2Mbps link


int se0/0

service-policy output traffic-policy



HTH...rate if helpful...

itdsmartnet Thu, 09/18/2008 - 01:59
User Badges:

Thanks for your reply. one thing i would like to ask you that what happens if the traffic exceed than 768 and i want to make sure if the users assigned bandwidth is not used by the users, the executive group will use that bandwidth and if the executives are not using that bandwidth the users will use it.

Thanks


satish_zanjurne Thu, 09/18/2008 - 02:33
User Badges:
  • Silver, 250 points or more


1.During Congestion if the traffic exceeds more than 768, and no bandwidth is available

packets will drop...


2.In your second query, it is YES!!!!


Both class can use unused bandwidth of each other...


HTH..rate if helpful...


itdsmartnet Thu, 09/18/2008 - 02:45
User Badges:

hi,

for the above configuration, what if i want my LAN users to have only 1 MB dedicated and for Executive to have dedicated 1 MB. for any circumstances they should have only one MB each


satish_zanjurne Thu, 09/18/2008 - 03:28
User Badges:
  • Silver, 250 points or more


Hi,


1.You can not allocate the 100 percent bandwidth available.


2.You can only allocate 75 percent of total bandwidth.


3.Remaining 25 percent of bandwidth is used for overhead, including Layer 2 overhead, control traffic, and best-effort traffic.


4.If you need to allocate more than 75 percent ,can use the max-reserved-bandwidth command. The percent argument specifies the maximum percentage of the total interface bandwidth that can be used


5.If you do use the max-reserved-bandwidth command, make sure that not too much bandwidth is taken away from best-effort and control traffic


HTH..rate if helpful..

itdsmartnet Thu, 09/18/2008 - 03:40
User Badges:

hi,

i think you misunderstood. i have configured rate-limiting for LAN users like this:

int gig 0/1

rate-limit input access-group 100 1024000 2048000 2048000 conform-action transmit exceed-action drop

access-list 100 permit ip 10.10.0.0 255.255.0.0 any

will this allow my LAN users having ips 10.10.0.0 to have only 1mb of the avalilable bandwidth ( no matter the remaining bandwidth is free or in use) and remaining will automatically allocated to the Executive users.


Joseph W. Doherty Thu, 09/18/2008 - 05:13
User Badges:
  • Super Bronze, 10000 points or more

Without going into all the reasons, I would recommend you don't separate normal users and executive users as you've planned (or rate limit).


I would suggest treating all flows FQ or WFQ. If certain traffic is clogging the link, define separate class for it, and provide it minimal bandwidth.


e.g.


class-map match-all bandwidthhog

match protocol ftp


policy-map 2mb_link


class bandwidthhog

bandwidth percent 1


class class-default

fair-queue


If you want to allow executives more bandwidth, relative to ordinary users, when there's congestion, set users flows to BE and executive flows to CS1..CS4. WFQ will give the higher marked flows a larger proportion of bandwidth. (This can also be used with the bandwidth minimal allocation for bandwidth hogs, as shown above.)

itdsmartnet Thu, 09/18/2008 - 20:57
User Badges:

Thanks for your reply. Actually the problem is that i have 2 Mb of bandwidth, the task given to me is that reserve 1 MB dedicated to the LAN users and 1 MB dedicated for the VIPs (Executives) please help me how to configure that.

Joseph W. Doherty Fri, 09/19/2008 - 03:18
User Badges:
  • Super Bronze, 10000 points or more

Yes, understood what your original problem is. Satish's response shows how to accomplish that, although in his example believe the ACLs should be terminated with denies.


For just splitting your bandwidth 50/50, you just need to identify one or both user's type traffic and split it into two classes. What's important is that each class has the same bandwidth as the other.


My response was recommending not to do what you intend, the 50/50 split, because I believe what I suggested might deliver more consistent network response to both user types.


Since you've asked how to implement a QoS solution, I'm guessing you might not yet fully understand all QoS considerations. If so, one needs to think about what one is really trying to solve. Misuse of QoS can degrade performance (actually it often intentionally does for some traffic).

Actions

This Discussion