IPM issue

Unanswered Question
Sep 18th, 2008

I try creating a collector under the IPM and I get this error message attached.

Can someone please tell me where I need to check to correct this error.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Thu, 09/18/2008 - 09:05

This looks like CSCsl37260. This bug indicates you did not configure your collector properly. Exactly what did you do to arrive at this error?

sameoj1881 Thu, 09/18/2008 - 09:15


How can I configure the collector in the right way.

Joe Clarke Thu, 09/18/2008 - 09:16

You need to select a source router, target device, and operation from each of the three panes before clicking next. The fix for this bug simply pops up a dialog saying you missed some steps.

Joe Clarke Thu, 09/18/2008 - 09:29

I'd say open a TAC service request, and get on a WebEx or Meeting Place session, and have them watch what you're doing to see if anything is missing. I have tried IPM 4.0.1 here, and it works if I select everything correctly. I select a source router, then select a device from my target list. Finally, I select an IP SLA operation. For my tests, I select DefaultIpEcho.

sameoj1881 Thu, 09/18/2008 - 09:44

Thanks for your reply. Can you please guide me through and let me see where I went wrong. Under source devices, I have options like all devices,device type groups,user defined groups,etc, which should I check? Under target devices, I have options like all devices,device type groups,user defined groups,etc, which option should I check? For the operation you already told me which one I can choose.

Joe Clarke Thu, 09/18/2008 - 09:47

You can choose any device from the All Devices list. You can choose any device under the Target > All Devices or Adhoc Devices lists. The devices you choose should represent the start and end points for the collector you're trying to create. That is, you want to monitor the latency between those two points in the network.

sameoj1881 Thu, 09/18/2008 - 10:08

Thanks for your reply.


Joe Clarke Thu, 09/18/2008 - 10:11

Source devices must be Cisco IOS devices that are present in DCR. They cannot be manually added to IPM. You can, however, manually add target devices (adhoc targets) under IPM > Collector Management > Devices > Add Adhoc Target. A target can be any IP node in the network.

sameoj1881 Thu, 09/18/2008 - 10:18

I have devices on the DCR 266 devices but it`s not seeing it,it sees it as IPSLA not enable under IPM device categorization.

What should I do to ensure that all the devices appear as IPSLA enable?


Joe Clarke Thu, 09/18/2008 - 10:24

The device needs to have SNMP properly configured, and needs to be running a feature set capable of IP SLA. What version of IOS is this device running?

sameoj1881 Thu, 09/18/2008 - 10:29

IOS 12.1,12.3 and 12.4 running on all devices

Are these IOS IP SLA capable?

sameoj1881 Thu, 09/18/2008 - 10:35

I have IP SLA MONITOR RESPONDER command configured on each device as well. Yet the IPM still sees it as IPSLA not enable.

What could be wrong.

sameoj1881 Thu, 09/18/2008 - 10:44

I don`t understand what you meant by feature set, please explain in details, thanks.

sameoj1881 Thu, 09/18/2008 - 11:00

For my device(S)?

Sorry I can`t due to security policy of my coy,what exactly do you want to see as a feature?

Joe Clarke Thu, 09/18/2008 - 11:02

Then please open a TAC service request. Without seeing more information, I cannot help you here.

Joe Clarke Thu, 09/18/2008 - 11:46

The feature sets are fine for IP SLA support. At this point, I would need to see the running configuration from these devices, and I would need to see a screenshot of how they show up in IPM.

Joe Clarke Fri, 09/19/2008 - 08:42

This is most likely your problem:

snmp-server view Subview system excluded

snmp-server view Subview cisco excluded

snmp-server view Subview system.1 included

snmp-server view Subview system.2 included

snmp-server view Subview system.4 included

snmp-server view Subview system.5 included

snmp-server view Subview system.6 included

snmp-server view Subview system.7 included

snmp-server view Subview sysUpTime.0 included

snmp-server view Subview ifEntry excluded

snmp-server view Subview ipAddrEntry excluded

snmp-server community uba123sub*)(/ view Subview RO

You have excluded the cisco branch. That branch must be included if you want to manage Cisco devices in LMS. Without it, just about every application will fail in some way. This assumes, of course, you're using this community string in DCR.

sameoj1881 Mon, 09/22/2008 - 09:04

If I get you right, you`re saying the those commands that I used exclude should be include instead of that word exclude, that will solve the problem right?

Please reply,thanks.

sameoj1881 Mon, 09/22/2008 - 09:11

On a second thought, where do I get to configure this?

Please reply,thanks.

Joe Clarke Mon, 09/22/2008 - 09:24

You will need to include the cisco branch:

snmp-server view Subview cisco included

You will also need to include the ifEntry and ipAddrEntry. It might be better to simply create a new community string for LMS that is less restrictive.

sameoj1881 Mon, 09/22/2008 - 09:55

Thanks for your reply.

Where do I need to include this?

Add it to the configs on my devices that I want LMS IPM to manage or where?

Please reply, thanks alot.

Joe Clarke Mon, 09/22/2008 - 09:58

Yes, you add it to the config on the devices. If you create a new community string, you will need to update DCR as well.

sameoj1881 Mon, 09/22/2008 - 10:06

How do I update the DCR?

Attached is a screen shot of the IPM.

Under devices collector source, the IPM caanot see the devices.

How can I RESOLVE THIS. Please help.

Thanks alot.

Joe Clarke Mon, 09/22/2008 - 10:13

Go to Common Services > Device and Credentials > Device Management, and edit the credentials for the devices in question. Update the read-only and read-write community string fields with the correct values that are configured on the devices.


This Discussion