7937 joining data vlan not voice vlan

Unanswered Question
Sep 18th, 2008

Our company has two 7937 conference phones that have both had this problem at two different locations on our network. Our normal switch port configuration is :

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 5

auto qos voip cisco-phone

spanning-tree portfast

In the above scenario the phone would bounce back and forth between a data and a voice vlan IP address, and the phone would say it couldn't contact the call manager. To fix this i had to remove the data vlan's from the switchport and then the phone acts normally.

The problem with this is that if someone wanted to plug a laptop into this location they cannot get to the data vlan.

Has anyone seen this or have any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Justin Brenton Thu, 09/18/2008 - 16:22

hmmm, you can try this to see if it helps.

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 5

switchport trunk allowed vlan 2,5

auto qos voip cisco-phone

spanning-tree portfast

from this doc: http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a0080891554.shtml

Hope this helps, please rate if so

Regards,

Justin

Justin Brenton Thu, 09/18/2008 - 16:54

if that doesn't work try this

switchport access vlan 2

switchport mode access

switchport voice vlan 5

auto qos voip cisco-phone

spanning-tree portfast

Regards,

Justin

rob.huffman Fri, 09/19/2008 - 17:43

Hi Duane,

This is a known issue with the Cisco 793x Conference phones. The clip below references the 7935 but the info carries over to the 7936 and 7937 as well;

The 7935 IP Conference Phone Receives Data IP Address Instead of Voice IP Address

If the 7935 IP Conference Phone is connected to a switch, the conference phone receives the IP address from the data VLAN. If the 7960 IP Phone is connected on the same switch port as the 7935 IP Conference Phone, the 7960 receives the IP address on the voice VLAN.

This issue is due to the design of the 7935 IP Conference Phones. This conference phone does not have a 10/100 port to connect a PC like other 7900 Series IP Phones have. The concept of voice VLAN or auxiliary VLAN does not directly apply to the 7935 IP Conference Phones

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_example09186a0080722cdb.shtml#ts2

7935 IP Conference Phone Optimal Performance Configuration

http://www.cisco.com/en/US/products/hw/phones/ps379/products_tech_note09186a00802381ab.shtml

Hope this helps!

Rob

egrinkin1 Sat, 09/20/2008 - 11:53

I've deployed 10+ of these. I've never had an issue such as this.

Do you have the most recent firmware for the phone?

egrinkin1 Sat, 09/20/2008 - 11:54

Totally disregard my response. I did not see the wonderful post by Rob.

voxtron1999 Sat, 09/20/2008 - 12:55

the command switchport trunk native vlan2 forced both voice and data to use vlan2.

Just remove all switchport (mode) trunk commands from the interface.

I experience the same yesterday!

gilbert.saupin@... Mon, 10/27/2008 - 05:36

Don't know if you've resolved this problem yet but we had the same requirements at colleges where they wanted to be able to plug the 7937 into any available switch port & work. Perhaps the following solution may apply....

We were lucky to have the 7937 work on some sites but not on others so a bit of wiresharking showed that where it did work there would only be one DHCP Offer via the configured DHCP Relay Agent(where the ip helper-address is configured) BUT where it didn't work there would be two DHCP Offers -[one via the DHCP Relay Agent] BUT one direct supposedly on the Voice VLAN [300] but with a Data Vlan [100] IP Address. [DHCP Discovery & Request packets are issued from the Voice Vlan - CDP confirms that also & 7937 is in the Operational Vlan 300].

All our access ports (on 3560E switches) connecting to servers, PC, & IP Phones have the generic config:

interface GigabitEthernet0/?

switchport access vlan 100

switchport mode access

switchport voice vlan 300

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

spanning-tree portfast

Our Windows 2003 DHCP servers were connected to ports configured the same BUT if we REMOVE the 'switchport voice vlan 300' command line from the server-connected port and reset/reconnect the 7937's - it works.

Haven't begun investigating why the Dell (DHCP) servers seem to be responding direct on the Voice Vlan with a Data Vlan IP address but I'm guessing perhaps the server NIC has some sort of dot1q support enabled so it sees the DHCP Discovery packet direct with a null 'giaddr' so it issues an address from the default (Data) scope

- the 7937 accepts the direct DHCP Offer rather than the 'relayed' DHCP Offer.

BTW, where the 7937 did work prior, the DHCP servers were either connected to dedicated Data Vlan access ports already or there is a routed/tiered network topology (as opposed to flat for smaller campuses) & the Voice Vlan did not extend to the routed core where the DHCP server is situated.

tim_roper Mon, 02/16/2009 - 10:27

Gilbert, that is a great explanation, and you are exactly correct according to my tests as well. Thanks.

Actions

This Discussion