Default route woes

Unanswered Question
Sep 18th, 2008
User Badges:

Hello,


I have an 871W that I am connecting to my service providers modem. Users connecting to the wireless are able to ping the next hop router, but when I attempt to traceroute to an unknown network, none of the packets are forwarded out along the default route and I am not sure why. Here is my conf, thanks for the help!


Current configuration : 1555 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Master

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.2

!

ip dhcp pool Home

network 192.168.1.0 255.255.255.0

domain-name moxxnet.net

dns-server 65.x.x.11 65.24.7.10

default-router 192.168.1.1

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dot11Radio0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

encryption vlan 1 key 1 size 40bit xxx transmit-key

encryption vlan 1 mode wep mandatory

!

ssid NSA

authentication open

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

no ip address

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet4

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

control-plane

!

!

line con 0

password xxx

login

no modem enable

line aux 0

line vty 0 4

password xxx

login

!

scheduler max-task-time 5000

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tdrais Thu, 09/18/2008 - 12:59
User Badges:
  • Blue, 1500 points or more

I suspect the device on the other end of your fast ethernet does not do proxy arp.


When you put in a static route to a interface it will issue a arp for any packet that passes interface. If it gets no response the packet will be dropped. The only way this will work is if the far end that know about the network tells the router to send tha packet to him This is proxy arp but is disabled many times since it is s bad idea.


In general you should not need the default router. I would hope that the DHCP server that is giving you the address on fa 4 would also give you all the other information like default router and dns etc.


If you do not get the default route via DHCP you want to change your static default to point to the real gateway and not the interface. The provider must either provide the default via DHCP or tell you so you can hard code it.



mccann.matt Thu, 09/18/2008 - 13:09
User Badges:

Even with a hard-coded direct route to the next hop router, pings to unknown network still fails.

Richard Burts Thu, 09/18/2008 - 17:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Matthew


As I read through this thread my first reaction is to think that Tim is on the right track in suspecting that it is a problem with proxy arp. I have a different suggestion about how to solve that issue. I suggest that you replace this:

ip route 0.0.0.0 0.0.0.0 FastEthernet4

with this:

ip route 0.0.0.0 0.0.0.0 dhcp


But as I read more deeply I began to think that it was something else. I am especially thinking about your statement that you can ping the next hop router but can not traceroute to an unknown network beyond it. I am not clear whether the traceroute is from the router or from a PC on the wireless. Can you clarify?


If you are attempting traceroute from the router then I wonder if you are attempting traceroute by name or by IP address? I do not see a name server configured for use by the router, which would prevent name resolution if the traceroute were from the router.


If the traceroute is from a PC on the wireless then I wonder if it is really able to resolve the name used to an address?


Perhaps you can clarify these points?


HTH


Rick

mccann.matt Fri, 09/19/2008 - 10:03
User Badges:

I am doing the trace route from either source, getting the same result. Each ping and traceroute is also directed at an IP, no names. I tried changing the default route to receive through dhcp and it is still receiving the same next hop destination that I had hardcoded earlier. I am absolutely perplexed as to why this is happening. Perhaps a call to my ISP is in order...

Actions

This Discussion