Remote connection client-server ani server LMS 3.1

Unanswered Question
Sep 19th, 2008

Hi,

I have upgraded LMS 3.0.1 to 3.1 and I have a problem with connection client- server in Campus Manager.

From LMS 3.1 server, I can connect to topology services normally, but if I want to connect from remote client I obtain the following error: cannont connect to any server: ANIServer6.0-gestion

ANIServer process is "Running with busy flag set".

What happend?

Thanks.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
j.ballesta Wed, 09/24/2008 - 02:08

If I launch Topology Services like client from server, application is launched correctly, but if I launch it like client from remote machine I obtain one error (Error Topology Services.png)

Between client and server don't exist anything to filter traffic, so all ports are opened. I send you output of 'netstat' commnad from server (netstat.txt)

In server, there is not anything UDP port up. All are TCP port.

What can I do?

Joe Clarke Wed, 09/24/2008 - 12:48

Sorry, the port is tcp/42342. Can you telnet to this port from the client? You should get an open connection. If it times out, or you get a connection refused then something is blocking the connection. Do you have any host-based firewall enabled on the server (e.g. Windows Firewall)?

j.ballesta Fri, 09/26/2008 - 01:54

I can telnet to tcp/42342 from client and server. I haven't any firewall between client and server and Windows Firewall is disabled.

From client all is correctly but from remote machine is error.

I have uninstalled all java versions and I launched Topoloy Services. It unloads java version from LMS server and I install it but the error is the same.

Joe Clarke Fri, 09/26/2008 - 06:31

What happens when you click the Details button? Or does that bring up the other pop-up? If you enable the Java Web Start console, the console output may have more useful information.

Joe Clarke Fri, 09/26/2008 - 06:33

Something else you should try is to set the locale of the client to US English. Spanish is not a supported language for LMS, and it could be interfering with Topology Services.

j.ballesta Thu, 10/02/2008 - 04:26

I have same problem as if I set locale of the client to US English as if I set locale to Spanish.

I send you details that the pop up display and the messages logged in java console window.

Attachment: 
Joe Clarke Fri, 10/03/2008 - 08:27

Yes, but now I can fully understand it. This points to bad cache info. Go to your Java Control Panel, click the Temporary Internet Files > Settings button, and delete the cached files. Then try launching Topology.

j.ballesta Wed, 10/08/2008 - 01:55

I have deleted the cached files from Java Control Panel but the result is exactly same that I had before.

dave.bird Wed, 10/08/2008 - 06:44

I thought I would post to say that I am encountering the same problem. On two out of the three 3.1 installations I have done recently, Topology Services will run locally on the server but not remotely from a client on the same LAN. The client can be W2K or XP running IE6/IE7/Firefox but it always fails. Wireshark shows only connections to tcp 1741 before the java error message.

Joe Clarke Wed, 10/08/2008 - 07:53

Please post the NMSROOT\MDC\Apache\logs\error.log and NMSROOT\MDC\Apache\conf\allow_files.conf.

dave.bird Thu, 10/09/2008 - 01:49

allow_files.conf attached.

After restarting the services the only message in error.log seen during the test was the initial one:

[Thu Oct 09 10:41:34 2008] [notice] Initializing etag from e:/cscopx/mdc/apache/logs/etag-state

David

Joe Clarke Thu, 10/09/2008 - 07:11

Your issue may be different from the thread author. Please start a new thread for your problem.

Joe Clarke Fri, 10/10/2008 - 06:54

What is your client's IP address? I'm seeing some interesting errors here, but I'm not sure if they're relevant.

j.ballesta Mon, 10/13/2008 - 06:56

I don't always try to connect to server with the same IP address. In "error.log" file you can see several attempts with several IP address.

The last attempt to connect was "october 10" and errors in this file are:

[Fri Oct 10 09:43:44 2008] [notice] Initializing etag from c:/program files/cscopx/mdc/apache/logs/etag-state

[Fri Oct 10 10:08:44 2008] [error] [client 10.142.78.74] client denied by server configuration: c:/program files/cscopx/htdocs/favicon.ico

[Fri Oct 10 10:08:44 2008] [error] [client 10.142.78.74] client denied by server configuration: c:/program files/cscopx/cgi-bin/error/403.pl

[Fri Oct 10 10:09:35 2008] [error] [client 10.142.78.74] File does not exist: c:/program files/cscopx/htdocs/favicon.ico

These attempts with differents IP address are done from same client machine. Althought also I have tried with several clients

Joe Clarke Mon, 10/13/2008 - 07:08

Try setting SS_CHECKIP to false in NMSROOT/lib/classpath/ss.properties, then restart Daemon Manager. Then see if your remote clients can connect.

Joe Clarke Wed, 10/15/2008 - 20:33

I suggest you open a TAC services request. Remote access may help determine why this problem is happening.

Actions

This Discussion