×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OSPF Issue

Answered Question
Sep 20th, 2008
User Badges:

Hello,


I have service provider between my two sites and ospf doesnt seems to work..


Service-provider confirms that OSPF is enabled on the DATA-link provided between two sites...


Is there a way to check if the ospf is getting blocked at the service provider...



Correct Answer by Marwan ALshawi about 8 years 11 months ago

do u have niehbor or network ospf command configured on the interface level?

is it point to point

or point to multipoint?

have u checked the DLCIs and the frame-relay maps configured correctly?

if u use static map to DLCIs make sure that frame-relay invers arp is disabled



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Marwan ALshawi Sat, 09/20/2008 - 04:13
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

debug ip ospf packet


To display OSPF packet information


debug ip ospf events


To display information regarding OSPF events such as the forming of adjacencies, Hello packets, LSA flooding, Designated Router (DR) selection, and shortest path first (SPF) calculations. If an OSPF neighbor relationship is not being formed between two routers, then this command can be used to determine the problem


if helpful Rate

Correct Answer
Marwan ALshawi Sat, 09/20/2008 - 05:09
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

do u have niehbor or network ospf command configured on the interface level?

is it point to point

or point to multipoint?

have u checked the DLCIs and the frame-relay maps configured correctly?

if u use static map to DLCIs make sure that frame-relay invers arp is disabled



paul.matthews Sat, 09/20/2008 - 06:42
User Badges:
  • Silver, 250 points or more

Ah - have you done anything specific to configure OSPF? FR is non-broadcast as far as OSPF is concerned. That means as defaut no hellos will be sent. You have three choices on how to make it work.


The way I would do it is by configuring the neighbors statically. That will then unicast hellos and away you go.


The next option is to configure under the (sub)interface ip ospf net broad or ip ospf point-to-point. Either will let OSPFsend Hellos to the all OSPF address.


It is always worth confirming you have IP connectivity first!



Richard Burts Sat, 09/20/2008 - 10:06
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Amin


We could give better answers if we knew some things about the topology of your network and if you would post the configuration of the interfaces and of OSPF on both routers.


There are quite a number of things that might keep OSPF from working over this connection. Some of them are frame relay maps that do not include the broadcast parameter, mismatched IP addressing (subnets), mismatched area assignement, problems with authentication, passive interfaces, mismatched area types. If you give us more information to work with we might be able to identify the problem better.


HTH


Rick

lamav Sat, 09/20/2008 - 10:27
User Badges:
  • Blue, 1500 points or more

Paul:


I never quite understood why OSPF does not send Hellos over an NBMA network by default.


Can you explain that?


Thanks


Victor


Marwan ALshawi Sat, 09/20/2008 - 23:39
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi victor

OSPF treats an NBMA network like any other broadcast network such as Ethernet. Because of this, OSPF thinks the network has broadcast capabilities even though it does not. This lack of a broadcast capability necessitates the use of the neighbor command to establish an OSPF neighbor. Prior to the introduction of the ip ospf network interface commands


ip ospf network non-broadcast


OSPF sends Hello packets and other protocol packets as multicast. If the network does not support multicast or you want OSPF to communicate with neighbors using unicast, use this command. The neighbor command is required if the network is configured as non-broadcast


hope this helpful

paul.matthews Mon, 09/22/2008 - 00:06
User Badges:
  • Silver, 250 points or more

Quite simple really. Hellos are used (among other things) for neighbour discovery. That means they need to be broadcast, as the point is the router does not know where to send them.


Networks like Frame relay and X25 are non-broadcast - the network itself does not have a broadcast mechanism/address like ethernet does, so, by default a hello cannot be broadcast. The way it used to work is that you had a simple mapping (statically configured) of this address down that DLCI. Inverse Arp allowed that to be autoconfigured. What also came was the possibility to add "broadcast" to a map, which would allow a packet that would normally be broadcast to be sent according tho that map.


With that present, configuring the OSPF network type as broadcast on an interface let OSPF send broadcasts, and the FR interface to forward them appropriately.

glen.grant Sat, 09/20/2008 - 10:59
User Badges:
  • Purple, 4500 points or more

I think you have to work with the service provider , ask him if he is seeing the ospf routing table at the last hop between the sites , if so then start looking at things at your end . Also make sure your mtu sizes match on each end of the link .

Amin Shaikh Sat, 09/20/2008 - 23:31
User Badges:

Thanks to all for the help...


I have the following input for all of you...


<1> do u have niehbor or network ospf command configured on the interface level? (NO)


<2> point to point? ( YES )


<3>have u checked the DLCIs and the frame-relay maps configured correctly? (YES) - IP reachability is there..

<4> if u use static map to DLCIs make sure that frame-relay invers arp is disabled ( YES )


======

On the interface I have the following config


interface Serial0/0/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type A100a

!

interface Serial0/0/0.1 point-to-point

ip address 172.20.18.10 255.255.255.252

frame-relay interface-dlci 16


Marwan ALshawi Sat, 09/20/2008 - 23:40
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Amin

can give us siomle topolgy of urs and ur router config as well

Amin Shaikh Sun, 09/21/2008 - 00:49
User Badges:

Thanks Marwan for the useful Link...


I will double-check all again.

Amin Shaikh Sun, 09/21/2008 - 05:22
User Badges:

How can I block IP range 192.168.5.0/24 and allow 192.168.1.0/24 on frame-relay interface




lamav Sun, 09/21/2008 - 09:04
User Badges:
  • Blue, 1500 points or more

Amin:


Please post the full router configurations for the routers on both ends. That is what is needed to understand what you need and help you.


Thanks


Victor

Amin Shaikh Sun, 09/21/2008 - 23:33
User Badges:

Thanks to all.


It was DATA Service provider issue, without any changes got it working...



Actions

This Discussion