Unity MWI pending ON/ OFF in failover

Unanswered Question
Sep 21st, 2008
User Badges:

Dear Sir,

I have installed a failover set up of Unity 5.0.1 using the following phases in a POC for upgrade:

Phase1 :Install a Unity 4.2.1 on OS 2003

Phase2 : Put the Back UP from the Live set p to the New server and Upgrade to 5.0.1

Phase3 : Install 5.0 on the Secondary Unity server

Phase4 : Configure failover between the servers

There is an issue with the MWI prompt. At the end of the installation I found that the MWI functioned only when primary was acitve.When I failover to secondary the MWI gave the message PENDING ON.

After making some changes in the configuration of the secondary voice mail ports ont the CCM (5.x) and recreating the integration I the MWI started functioning in the Failover mode (i.e. when secondary was active). But it stopped working for the Primary (i.e. when I failback).

Currently I have the MWI pending on for Primary.

I have already tired restatring the Exchange server as suggested in one of the topics.It did not work

Please point out the probable cause of the error and suggest a solution for the same?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rohan_sahi Sun, 09/21/2008 - 22:14
User Badges:

I also want to point out one more thing.Whever I am recreating integration on any of the server MWI starts working for that particular server and stopes working for the other server.

tim.giles Mon, 09/22/2008 - 03:27
User Badges:
  • Silver, 250 points or more

Hi,


Have you correctly set up the voicemail ports on both the primary and failover server? If you go into the manage integrations page/menu on both servers, make sure the voicemail ports are configured for dialout MWI etc.








Please rate useful posts..

Tray Stoutmeyer Mon, 09/22/2008 - 07:42
User Badges:
  • Cisco Employee,

You might also make sure that you have seperate prefixes between the integrations. In the UTIM on each server, make sure the prefix names are not the same in the Servers tab. On that tab, under CUCM/CCM device name prefix, is the name of the prefix for those set of ports. The default is something like CiscoUM-VI. In failover, they must be different so most people do something like CiscoUM1-VI and CiscoUM2-VI with UM1 being the primary and UM2 being the secondary ports. Maybe that is part of the problem? Please check that.


Tray

rohan_sahi Mon, 09/22/2008 - 19:27
User Badges:

Hi Frnds,

Thanks for your reponses.

I have been able to resolve the issue.The issue was with the integration ID of the integration and not the name of the integration. I found that the integration ID was 5 on the primary server and 1 on the secondary server.

As per Cisco documents it should be same (ideally 2) on both the servers.I made the integration ID same (5 for both) and it worked.


But now I am facing a new issue. As you might have unserstood this whole POC is a migration process from 4.2.1 on OS 2000 to 5.0.1 on OS 2003. There is a migration of Partner Exchnage involved in the process.


Currently the mailboxes of all the users are on the Partner exchange 2003. I have to move tham to Partner exchange 2007. Once I move a mailbox to parnter exchange 2007 I am not able to leave message on that phone.


I checked out one more thing I am not able to send even a simple mail from the User having mailbox on 2007 to user having mailbox on 2003 and vice versa.This denotes that there is no MAPI connection between the Exchange 2003 and Exchange 2007.


Now my questions are :

1. Why was I not able to send message to user having mailbox on Exchnage 2007 (which is currently the partner exchange) due to the above mentioned issue. I there any dependency of exchnage 2003 in sending the message to user on exchnage 2007.


2. When I moved the same account which I moved from 2003 Ex to Ex 2007 the messages started reaching the user. But MWI prompt was not working for that particular user.Even after resynchronising the MWI it did not work.What could be the issue?


Thanks And Regards

Rohan sahi.

rohan_sahi Mon, 09/22/2008 - 19:38
User Badges:

In my second question I intended to put that I moved back the same account to exchange 2003 , than the messages started getting deliverd.


Regards

Rohan Sahi

ranpierce Tue, 09/23/2008 - 06:39
User Badges:
  • Silver, 250 points or more

rohan,


1. after you move subscribers you may have to rerun PW and MSCW. You do have to be partnered with 2007 if there are subscribers on 2007 I think, and you need exchange tools 2003 installed on the Unity server.


Please follow this.

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/5x/installation/guide/umexfo/5xcuigumefo060.html#wp1938941


2. For the MWI issue it is a combination of the above and this post.

http://forums.cisco.com/eforum/servlet/NetProf;jsessionid=A62A075817ADB57C01AFA62CBC7FF6EC.SJ2A?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Unified%20Communications%20Applications&topicID=.ee835d2&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cc1e036/0#selected_message


Hope this helps you.


Randy

arvindkannu Tue, 10/14/2008 - 01:41
User Badges:

Rohan


I also have the same issue as u mentioned but if I try to change the integration id it says the subscriber withthe current integration id will not be moved to the new integration id...how did u go about this.

rohan_sahi Tue, 10/14/2008 - 21:22
User Badges:

Hi Arvind,

The integration ID must be identical to the SQL swicth id. Check the switch id as per the following steps:

By the way, here are the steps to check the SwitchID for all the subscribers:


1, In the Cisco Unity server, choose Start > Programs > Microsoft SQL Server > Enterprise Manager to open the SQL Server Enterprise Manager.

2, Choose Microsoft SQL Servers > SQL Server Group > {local server} > Databases > UnityDb

3, Click Tables to display all the tables in the right pane of the Tables window.

4, Right-click on Subscriber in the right pane of the Tables window and choose Open Table > Return all Rows.


View the column with under the name SwitchID.

Now go to unity manage integration .Click the integration id as to the same number found in the list.

I hope you are trying to chnage the integration id which is a number and not the integration name.

Hope this will resolve your issue.

Regards

Rohan

arvindkannu Wed, 10/15/2008 - 00:20
User Badges:

Rohan


Thanks for your reply...yesterday I did changed the integration ID (not name) to make sure both server has the same number. and gave a reboot to the server and it resolved the issue.

Thank you very much for your help.


Reg

Arvind

Lance Cutler Thu, 10/16/2008 - 08:39
User Badges:

I had the same issue and followed this solution, but have a small issue. When I create new users it creates them in integration ID 2 and not 1. I manually have to move them through UTIM to the correct ID. Is there some place to change this? Registry or .ini?

Bradford Magnani Thu, 10/16/2008 - 08:41
User Badges:
  • Cisco Employee,

In UTIM under Properties, Integration tab there is a button "Modify Integration ID". Have you tried doing it that way?

Lance Cutler Thu, 10/16/2008 - 08:56
User Badges:

That is how I changed it the first time. Yet all my new users are created in ID 2 not in ID1.

Bradford Magnani Thu, 10/16/2008 - 09:45
User Badges:
  • Cisco Employee,

Do you have more than 1 integration configured on Unity? Check the subscriber template you're applying to users and make sure the correct switch is being applied.



Lance Cutler Thu, 10/16/2008 - 11:17
User Badges:

Where would you change this?

I can not find anywhere to specify what integration ID to use.

Lance Cutler Thu, 10/16/2008 - 11:34
User Badges:

Used that doc already. Only 1 integration there. So there is no option for switch. UTIM only lists 1 integration with ID 1. I am using Data Link Explorer... all users are in ID 1. All of the templates are in ID 2.

If I create a new template it is in ID 2. How do I change this?

Actions

This Discussion