ISDN line deactivates when no activity--disables calls out

Unanswered Question
Sep 21st, 2008

I have a 2851 with VIC2-2BRI cards connected to ISDN lines in Spain with a NET-3 European ISDN switch. The lines work fine for incoming calls, however the lines deactivate when there is no activity (which I know is normal). However when an outbound call is attempted to be places the caller just gets a fast-busy. The port appears to be down so the call is not placed. Help!

config:

interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn not-end-to-end 56

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cg100668 Mon, 09/22/2008 - 07:54

Hi, can you please paste the dial peers for outgoing calls for better troubleshooting.

Chandrasen

cg100668 Mon, 09/22/2008 - 08:01

Hi, sorry I forgot to ask you, are you using CCME or CUCM? Has the dial plan properly configured if CUCM is being used? It looks like the BRI ports is not reached when a number is dialed.

Chandrasen

antone.knetter Mon, 09/22/2008 - 22:42

Here are the dial-peers. The dial-peers work fine if a call out is attempted shortly after receiving a call. The ISDN layer 1 stays up a short while and calls out work fine. Then when the layer 1 deactivates due to lack of activity, the calls don't go out.

dial-peer voice 5 pots

preference 4

destination-pattern [0,8,9]........+

port 0/3/1

forward-digits all

dial-peer voice 18 pots

preference 4

destination-pattern [0,8,9]........+

port 0/3/0

forward-digits all

!

dial-peer voice 19 pots

preference 4

destination-pattern [0,8,9]........+

port 0/2/0

forward-digits all

!

dial-peer voice 20 pots

preference 4

destination-pattern [0,8,9]........+

port 0/2/1

forward-digits all

!

dial-peer voice 21 pots

preference 4

destination-pattern [0,8,9]........+

port 0/1/0

forward-digits all

!

dial-peer voice 22 pots

preference 4

destination-pattern [0,8,9]........+

port 0/1/1

forward-digits all

cg100668 Tue, 09/23/2008 - 00:38

Hi. Any reason why all the dial peers are preference 4? Try to change the preferences for each dial peer from 0 to 6. Moreover capture the debug isdn q931 and see which number is being sent out to the PSTN. Third capture debug voip ccapi inout and see which dial peer is being hit. Compare one with a successful call and another with a non successful call. Finally I would change the destination pattern to 9T and see if calls go out.

antone.knetter Tue, 09/23/2008 - 14:37

No reason why all the dial peers are 4. At the moment I didn't have any preference for port to use. I will capture the debug later. The dialpeers work when the layer 1 isdn is up. When an incoming call enters, the isdn circuit activates and the call enters fine. Then, I am able to place calls with the existing dialpeers. After the ISDN line deactivates due to no activity...then no dialpeers match to route calls out. How do I get the outgoing dialpeers to "wake-up" the ISDN circuit?

cg100668 Tue, 09/23/2008 - 22:59

Hi,

Is it possile to paste "sh isdn status" please. Can you post "debug isdn q931" for a successful call and for an unsuccessful call.

Chandrasen

mvanterve Wed, 09/24/2008 - 00:08

Hi,

I experienced the same thing with an BRI port.

I found that the dial-peers were in a "down" state, because of the ISDN status is down.

You can use the following command to solve this.

"no dial-peer outbound status-check pots"

Kind Regards,

Mario

antone.knetter Wed, 09/24/2008 - 00:42

Thank you very much. That was exactly what I needed and everything is working now.

Similar to telling a modem not to wait for a dial-tone.

cg100668 Thu, 09/25/2008 - 01:20

Thanks, there is always something new to learn.

Chandrasen

Actions

This Discussion