interface Broadcasts on serial link

Answered Question
Sep 22nd, 2008
User Badges:

Hi all,


i see slowness in network.

see packet drops.

check the serial link

Serial0/0/0 is up, line protocol is up

Hardware is GT96K Serial


MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 73/255, rxload 48/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 1007, LMI stat recvd 1007, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

FR SVC disabled, LAPF state down

Broadcast queue 0/64, broadcasts sent/dropped 2355/0, interface broadcasts 2188

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 02:47:55

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/86/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 295000 bits/sec, 56 packets/sec

5 minute output rate 444000 bits/sec, 64 packets/sec

618921 packets input, 471611347 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 1 giants, 0 throttles

151 input errors, 151 CRC, 128 frame, 107 overrun, 0 ignored, 82 abort

723009 packets output, 525070248 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up


Serial0/0/0.1 is up, line protocol is up

Hardware is GT96K Serial

Internet address is 161.245.75.220/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 73/255, rxload 48/255

Encapsulation FRAME-RELAY IETF

Last clearing of "show interface" counters never


i clear the counters.

can some one explain me about

Broadcast queue 0/64, broadcasts sent/dropped 2355/0, interface broadcasts 2188

many thanks


Correct Answer by Richard Burts about 8 years 8 months ago

mahesh


Let me try to explain it this way:

- EIGRP sends multicast packets for hello messages and for update messages.

- when you have a network statement under EIGRP that matches a serial interface then EIGRP begins to send hello messages and update messages over the serial interface.

- so you are sending and receiving multicast packets on the serial/frame relay interfaces.

- I believe that the multicast EIGRP packets are being counted in the interface broadcast counter.


Perhaps the name they give the counter is not as specific as it should be. I believe that it counts more than just "broadcast" packets. We frequently treat multicast and broadcast as if they are different things, but in some sense broadcast is a special case of multicast.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
John Blakley Mon, 09/22/2008 - 11:00
User Badges:
  • Purple, 4500 points or more

Can you run a sh ip protocols and post it here?

mahesh18 Mon, 09/22/2008 - 11:05
User Badges:

Here u go


#sh ip protocols

Routing Protocol is "eigrp 305"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: eigrp 305

EIGRP NSF-aware route hold timer is 240s

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

161.245.0.0

172.23.0.0

172.24.0.0

Routing Information Sources:

Gateway Distance Last Update

161.245.75.221 90 00:21:57

Distance: internal 90 external 170


thanks

Mahesh

John Blakley Mon, 09/22/2008 - 11:15
User Badges:
  • Purple, 4500 points or more

is the 161.245.0.0 a public subnet? Can you post your interface configs and eigrp config?


--John

mahesh18 Mon, 09/22/2008 - 11:22
User Badges:

urrent configuration : 11009 bytes

!

! Last configuration change at 09:56:23 MDT Tue Sep 16 2008 by istardc

! NVRAM config last updated at 14:45:18 MDT Tue Sep 16 2008 by istardc

!

version 12.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service linenumber

!

hostname idpodr1

!

boot-start-marker

boot-end-marker

!

logging buffered 4097 debugging

logging console warnings

enable secret 5 $1$IiqQ$ncRPJmMtBCZTLq6gcxDW/0

!

aaa new-model

!

!

aaa authentication login default group tacacs+ line

aaa authentication login noaaa none

aaa authentication enable default group tacacs+ enable

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization commands 1 default group tacacs+ if-authenticated

aaa authorization commands 15 default group tacacs+ if-authenticated

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

aaa session-id common

!

resource policy

!

clock timezone MST -7

clock summer-time MDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00

no ip subnet-zero

no ip source-route

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface



ip name-server 161.245.25.60

ip name-server 172.31.99.20

ip name-server 192.168.6.100


Ccrypto pki trustpoint TP-self-signed-280346003

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-280346003

revocation-check none

rsakeypair TP-self-signed-280346003

!

!

crypto pki certificate chain TP-self-signed-280346003

certificate self-signed 01

3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 32383033 34363030 33301E17 0D303531 31303932 30303531

305A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3238 30333436

30303330 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

9790CDA9 8FB264AE C4515AD8 8D415F1E C45F0AF2 BA355EC4 588F4A90 86EBB7E6

4810278C 48A8E9AD E29FA2CD 688F5F66 C0A95F7F 45AAC3AA 9E3DCB9B F5510505

E30E2D29 EBB10D16 6D07FFA4 F08829D6 1BF752E9 232D4D4E B0629AEC D3864057

85395AB7 F829BA1D 18AFA6DA 2B9AAE86 2442844B D95494CA CB4A3511 C2A447BD

02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D

11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F

0603551D 23041830 168014DD E6BBD6FA 54A6574C 39E34ACC 7ED23387 78881930

1D060355 1D0E0416 0414DDE6 BBD6FA54 A6574C39 E34ACC7E D2338778 8819300D

06092A86 4886F70D 01010405 00038181 0047DBC3 F3995B95 B82BE989 7B524C31

787CCDA8 BE665E38 B4653AC7 3DDBDDC3 FE56270D 568D674C 09EDB369 71985AEA

C986F1C5 9005E53A 400191BC 103FE054 02653D8C FD7E5FB7 A3DE7A2A 7616CC59

BCDD1769 80A02B34 582429AC F430EF1B 233D496D 202F2096 D71CD71B C4B06A75

B3F5B15A 239CA766 C07670D5 D2B2767F AF

quit

!

!

!

!

!

interface Loopback0

ip address 161.245.9.88 255.255.255.255

!

interface GigabitEthernet0/0

description - SCADA LAN

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

description - Business LAN

ip address 161.245.76.220 255.255.255.128

ip helper-address 161.245.25.60

ip helper-address 192.168.250.10

ip helper-address 172.31.99.20

no ip unreachables

duplex auto

speed auto

!

interface Serial0/0/0


no ip address

encapsulation frame-relay IETF

!

interface Serial0/0/0.1 point-to-point

ip address 161.245.75.220 255.255.255.0

frame-relay interface-dlci 114 IETF

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

!


!


mahesh18 Mon, 09/22/2008 - 11:24
User Badges:

router eigrp 305

network 161.245.0.0

network 172.23.0.0

network 172.24.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip default-gateway 161.245.75.221

ip classless

ip route 0.0.0.0 0.0.0.0 161.245.9.1

ip route 0.0.0.0 0.0.0.0 161.245.9.2 4

ip route 161.245.0.0 255.255.0.0 0.0.0.0

!

no ip http server

no ip http secure-server

ip tacacs source-interface Loopback0



^C

!

line con 0

password 7 123E5547165F1945

line aux 0

exec-timeout 9 0

password 7 071B24415E

modem Dialin

transport input all

stopbits 1

line vty 0 4

access-class 100 in

privilege level 15

password 7 0477580B022842494D

transport input ssh

line vty 5 9

access-class 100 in

privilege level 15

password 7 072372414300170253

transport input ssh

line vty 10 15

access-class 100 in

privilege level 15

password 7 153E5801092325236C

transport input ssh

!

scheduler allocate 20000 1000

ntp clock-period 17180303

ntp server 192.168.9.1

ntp server 192.168.9.2

!

end


John Blakley Mon, 09/22/2008 - 11:52
User Badges:
  • Purple, 4500 points or more

The only thing that jumps out at me, and perhaps others can help, is that you're ip helper address is pointing to somewhere outside of your LAN. That would send broadcasts out since that's how DHCP works. When your workstations come up and traffic is sent to that VLAN, they're being directed to these addresses. By chance, are the 192 or the 172.31 addresses on the other side of your point-to-point?


John


pls rate if helpful :-)

mahesh18 Mon, 09/22/2008 - 12:31
User Badges:

Hi,


thanks for reply yes ip 192 and 168 are on other side of point to point link

Richard Burts Mon, 09/22/2008 - 12:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

mahesh


John has slightly confused the operation of DHCP and helper addresses. He is correct that the original request from the client is a broadcast. But that is received on the LAN interface. The router does not forward the broadcast request to the DHCP server but uses the address specified in the helper-address command to send a unicast packet to the server.


I believe that there is another explanation for what you are seeing. Even though it is labled as interface broadcasts I believe that it counts multicast in that category also. And since you are running EIGRP on the interface I believe that you are receiving EIGRP multicast hello packets that that is what is being counted in the interface broadcast counter.


HTH


Rick

mahesh18 Tue, 09/23/2008 - 06:25
User Badges:

Hi Rick,

Can u explain me in more detail interface broadcasts on serial link.

i do not understand this part



believe that there is another explanation for what you are seeing. Even though it is labled as interface broadcasts I believe that it counts multicast in that category also. And since you are running EIGRP on the interface I believe that you are receiving EIGRP multicast hello packets that that is what is being counted in the interface broadcast counter

thanks

Correct Answer
Richard Burts Tue, 09/23/2008 - 07:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

mahesh


Let me try to explain it this way:

- EIGRP sends multicast packets for hello messages and for update messages.

- when you have a network statement under EIGRP that matches a serial interface then EIGRP begins to send hello messages and update messages over the serial interface.

- so you are sending and receiving multicast packets on the serial/frame relay interfaces.

- I believe that the multicast EIGRP packets are being counted in the interface broadcast counter.


Perhaps the name they give the counter is not as specific as it should be. I believe that it counts more than just "broadcast" packets. We frequently treat multicast and broadcast as if they are different things, but in some sense broadcast is a special case of multicast.


HTH


Rick

Actions

This Discussion