applying QoS policy to multilink interface

Unanswered Question
Sep 23rd, 2008

I have a 7206 router that has a multilink interface with x6 T1 bundled together.

When trying to apply a Q0S policy to the interface I get an error:

7206VXR-01(config-if)# service-policy output QoS

I/f Multilink123 class VOICE requested bandwidth 1544 (kbps), available only 45 (kbps)

Here is the ploicy I am trying to apply:

policy-map QoS

class VOICE

priority 1544

set ip dscp ef

class PRIORITY-DATA

bandwidth 128

random-detect

set ip dscp af31

class Secondary-DATA

set ip precedence 0

police cir 384000

conform-action transmit

exceed-action drop

class class-default

set ip precedence 0

Here is the interface:

Multilink123 is up, line protocol is up

Hardware is multilink group interface

Description: MCI MPLS Circuit

Internet address is 1.2.1.30/30

MTU 1500 bytes, BW 9216 Kbit, DLY 100000 usec,

reliability 255/255, txload 7/255, rxload 4/255

Encapsulation PPP, LCP Open, multilink Open

Do I need to set the Bandwidth on the multilink to reflect the 9.0M(x6 T1)?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
satish_zanjurne Tue, 09/23/2008 - 05:29

No you don't have to set the bandwidth on multilink interface.

Instead use "bandwidth-percent 15" command instead of "priority 1544" & then add only "priority" command.

See how it behaves..

HTH..rate if helpful..

wilson_1234_2 Tue, 09/23/2008 - 05:47

But,

Why did I get this error?

And it looks like the policy thinks there is only 45K on the interface.

Joseph W. Doherty Tue, 09/23/2008 - 06:38

It might help to define a bandwidth for your Secondary-DATA class. Unsure what the policy assumes without it.

Have any configured "max-reserved-bandwidth" on the interfaces, both the serial and/or multilink?

What IOS version are you using?

PS:

I think it's a good idea to use the bandwidth statement on the multilink, but unsure it's necessary since the multilink sees itself as "BW 9216 Kbit". Shouldn't hurt to try especially since policy maps can be sensitive to the bandwidth setting. I do suspect the lack of a bandwidth statement in Secondary-DATA class, as noted above.

wilson_1234_2 Tue, 09/23/2008 - 10:07

Joseph,

I am running 12.4(21) on the 7206.

This router is the hub for 5 branches that each have anywhere from 15-30 users all with Cisco Ip Phones.

Each one of the remote site routers has a ser interface with QoS applied and I am seeing some things I do not understand.

If you are up for the questions, I will follow up, if not I understand.

wilson_1234_2 Tue, 09/23/2008 - 10:51

Joseph,

I am running 12.4(21) on the 7206.

This router is the hub for 5 branches that each have anywhere from 15-30 users all with Cisco Ip Phones.

Each one of the remote site routers has a ser interface with QoS applied and I am seeing some things I do not understand.

If you are up for the questions, I will follow up, if not I understand.

Updated:

I see one thing:

I had tried to apply the policy map to the serial interface on a new branch router and it would not let me becuae the " frame-relay traffic-shaping" had been applied.

I then noticed that a "map-class" had been created and applied under the DLCI.

This must be the QoS for frame-relay?

Also, what bandwidth would you recommend under the Secondary-Data class? would it be anything that is left?

Joseph W. Doherty Tue, 09/23/2008 - 11:39

With regard to frame-relay, you can use CBWFQ, but you can run into config conflicts if not done as it wants. I used to do it with subinterface defined for PVC. Not sure about whether it's supported with PVC mapped via frame-relay map. If you use subinterface, CBWFQ will likely require "knowing" bandwidth. This might require either a GTS (generic traffic shaper) and/or hierarchal CBWFQ policy.

e.g.

policy-map shapeAvg1500cir256

class class-default

shape average 1450000 11600 11600

shape adaptive 256000

shape fecn-adapt

queue-limit 256

fair-queue

interface Serial6/0/3

bandwidth 1544

no ip address

ip access-group 199 in

ip flow egress

encapsulation frame-relay

no ip mroute-cache

load-interval 30

serial restart-delay 0

no fair-queue

frame-relay lmi-type cisco

frame-relay broadcast-queue 128 8000 64

!

interface Serial6/0/3.100 point-to-point

ip address 10.1.252.101 255.255.255.252

ip access-group 111 in

ip flow egress

no arp frame-relay

frame-relay interface-dlci 100

service-policy output shapeAvg1500cir256

With regard to bandwidth setting for your secondary-data class, I would set it to be no more than the policed valued but you could set it to be less.

wilson_1234_2 Tue, 09/23/2008 - 12:00

Thanks joseph,

The remote branches are configured as such below, which looks like:

1. Class is applied under DLCI

2. Class is identifying the available bandwith and calls the service policy

3. Service policy is setting the QoS

I can see traffic matching under "sh policy-map int"

Is the above correct?

Is the below a correct way to implement?

interface Serial0/2/0:0.400 point-to-point

ip address 1.1.2.62 255.255.255.252

ip nbar protocol-discovery

ip flow ingress

ip flow egress

frame-relay interface-dlci 400 IETF

class P-class

crypto map P_Crypt

class-map match-all DATA-Priority

match access-group 111

class-map match-all VOICE

match access-group 110

!

!

policy-map P-QoS

class VOICE

priority 385

class DATA-Priority

bandwidth 256

class class-default

set dscp default

fair-queue

random-detect

map-class frame-relay P-class

frame-relay cir 1536000

service-policy output PEFCU-QoS

Joseph W. Doherty Tue, 09/23/2008 - 15:31

I've never configured CBWFQ as you're doing, so can't confirm it;s correct. However, it looks reasonable and if you're seeing stat results, you're probably good.

Actions

This Discussion