Power Controller reports power Imax error detected

Unanswered Question
Sep 23rd, 2008

Hi,

My 3560 switch w/ IOS 12.2(35)SE have below message last night. Would anyone know what happen?

Sep 23 18:54:58.468 UTC: %ILPOWER-7-DETECT: Interface Fa0/10: Power Device dete

ted: IEEE PD

Sep 23 18:54:58.468 UTC: %ILPOWER-5-INVALID_IEEE_CLASS: Interface Fa0/10: has d

tected invalid IEEE class: 7 device. Power denied

Sep 23 18:57:37.542 UTC: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error,

Interface Fa0/12: Power Controller reports power Imax error detected

Sep 23 18:57:44.580 UTC: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no lon

er detected on port Fa0/12, port set to untrusted.

Sep 23 18:57:48.674 UTC: %ILPOWER-7-DETECT: Interface Fa0/12: Power Device deteted: Cisco PD

Sep 23 18:57:48.741 UTC: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Fa0/12: Power Controller reports power Tstart error detected

Thanks and Regards

Ernest

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
prkrishn Tue, 09/23/2008 - 19:27

I am suspecting this has to do something with the IP phone on this port since it is requesting invalid class power. Did the phone come back up fine? If not, you might want to see if the same phone works on a different port or a switch to see if you just have a bad phone

danny.cintron@a... Fri, 09/21/2012 - 16:47

We have a 2960 at one of our sites and we got notifications that all phones became unregistered.  I looked at the logs and saw

Sep 21 22:25:12.970 GMT: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Fa0/8: Power Controller reports power Imax error detected

Sep 21 22:25:13.675 GMT: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Fa0/15: Power Controller reports power Imax error detected

this appears to be affecting all our ports on that switch

amuthaia Sat, 09/22/2012 - 00:10

Hi,

This error indicates that PD is drawing over-current more than allowed/supported per IEEE 802.3af standard.

Log:

Sep 21 22:25:13.675 GMT: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Fa0/15: Power Controller reports power Imax error detected

  • What type of the device are connected to interfaces where you are seeing this error?
  • Do you use any kind of POE splitter on the interface?

This issue is looks like it is matching with known bug CSCsw18530

CSCsw18530 - Power Imax / Tstart errors may be reported with some third party PDs

Symptoms:

Power Imax / Tstart errors may be reported with some third party PDs

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Power Controller reports power Imax error detected

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi1/0/35: Power Controller reports power Tstart error detected

Conditions:

Seen with some of the 3750,3750G,3750-E,3560-E, 3750-X, 3560-X, 3560-C, 2960S, 2960,2960C switches

Workaround:

Longer cable (>50ft) seems to fix the issue in most cases.


Solution

This issue is fixed in 12.2(55)SE3 , 12.2(58)SE1 and later releases. The following  interface configuration commands have to be applied to resolve the issue,

Switch(config)# int x/y
Switch(config-if)# power inline port 2x-mode
Switch(config-if)# shut
Switch(config-if)# no shut

The fix is present in the following platforms only :

3750-E, 3560-E, 3750-X, 3560-X, 3560-C, 2960S, 2960,2960C. The other platforms do not support 2X power mode and the workaround would be to use a longer cable.

Regards,

Aru

*** Please rate if the post is useful ***

danny.cintron@a... Mon, 09/24/2012 - 16:56

Both ports had 7942 phones connected.  The switch is using IOS 12.2(58)SE2.  The ports are all in an up/up state now.  If the issue reoccurs I will try your suggestions.  On the same switch we do have two Meraki MR16 PoE WAP's connected also.  Is it possible they could be drawing too much power?  We'll keep monitoring.

amuthaia Tue, 09/25/2012 - 03:36

Hi Danny,

Please make sure that those two Meraki MR16 PoE WAP's are complaint to to 8023af standard. If this meets this standard, it will work without any trouble,

If you see any abnormal behavior on PoW, use the show inline power and show inline power detail privileged EXEC commands to compare the number of connected powered devices against the switch power budget (available PoE). Verify that switch power budget can power the device.

Note:

If the switch power budget is depleted, additional powered devices will not power-on when connected to a PoE port. CDP (Cisco Discovery Protocol) helps identify Cisco devices and correctly establish the switch power budget.

Refer:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/troubleshooting/g_power_over_ethernet.html#wp1018190

Regards,

Aru

*** Please rate if the post is useful ***

smogra Mon, 03/04/2013 - 06:26

Yes, looks like you are hitting this bug (CSCsw18530) and why this IMAX power error popup on Cisco switch:

After a PD (connected to one of our ports) is turned on, the hardware keeps on monitoring the current drawn by the PD so if the current drawn by a PD exceeds the pre-configured cutoff current (ICUT) for a limited time (TCUT) then the power controller will shut it down and informs the software about the fault. The software upon hearing about this fault, will print out the "IMAX error" message, remove the power and start a timer to start detecting the PD after the expiry of that timer. So if the device is continuously misbehaving (i.e. drawing more than ICUT current even after TCUT time) then we will keep on powering it up and then shutting it down.

Please try to connect longer cable (<50) and let me know if it's fix this issue or not.

Regards,

Sweta

boucherandre Tue, 02/26/2013 - 18:47

Hi, 

We are at the begining of a wireless deployment in an hospital here, and at this  time I have 2 Aruba AP105 that stop working this week with this error log:

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi1/0/19: Power Controller reports power Imax error detected

I try the workaround and the solution with the  "power inline port 2x-mode" command on a  2960s POE+ 12.2 55(se5), but still the same problem.  I also upgrade the firmware of the wireless controllers to the latest.

Someone can help?

thanks!

Leo Laohoo Tue, 02/26/2013 - 19:12

Try this ...

1.  Command:  test cable tdr int G1/0/19;

2.  Wait for 5 to 7 seconds;

3.  Command:  sh cable tdr int G1/0/19; and

4.  Post the output to #3.

boucherandre Wed, 02/27/2013 - 15:10

Here is the output:

TDR test last run on: February 27 23:06:23

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- ---------------

Gi1/0/19  auto  Pair A     91   +/- 0  meters N/A         Normal

                Pair B     87   +/- 0  meters N/A         Normal

                Pair C     90   +/- 0  meters N/A         Normal

                Pair D     88   +/- 0  meters N/A         Normal

Leo Laohoo Wed, 02/27/2013 - 15:31

Entire length of the cable looks good.

What's the IOS of your switch?

boucherandre Wed, 02/27/2013 - 17:00

IOS of my switch is:

Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE5, RELEASE SOFTWARE (fc1)

Here is some tests I had just done:

I replace 1 fail AP with a new one and it work just fine (like 40 others without the

"power inline port 2x-mode")

I test the fail AP in a HP POE switch and it work instantly...let it completly boot and connect with the controller

I put it back in my 2960 and fail again, I add the "power inline port 2x-mode" and this time it worked

I delete the 2x-mode and I'm back to the "power Imax error detected",put the 2x-mode again and it stop spamming me the error

Now, I'm absolutly sure I don't understand what's this mean...Is these 2 AP will fail again?  Do I need to add the 2x-mode on every AP of this kind? Is the 2x-mode overheat the AP or its just my mind that tricks me when I touched the device?

power inline port 2x-mode

I'm done with tests tonight, just monitoring the AP and see if something strange happens.

thanks!

power inline port 2x-mod

power inline port 2x-mod

Leo Laohoo Wed, 02/27/2013 - 17:09
power inline port 2x-mode

I've got 2960S and 3750X and I must humbly admint, I've never used this command line before.

Did you connect the AP directly to the switch port?

Hmmmm ... May I see the config of the offending port?  I've got a strange feeling that you have a command line that shouldn't be there. 

boucherandre Wed, 02/27/2013 - 17:51

yes I got the same problem when connecting the AP directly in the switch port and any port.

Here is the port config (same on all port, except the 2x-mode that others identicals AP dont need :S)

description AP-ARUBA

switchport access vlan 204

switchport mode access

switchport priority extend trust

power inline port 2x-mode

srr-queue bandwidth share 5 15 30 50

srr-queue bandwidth shape 0 0 0 0

priority-queue out

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input reclass-cos

thanks

Leo Laohoo Wed, 02/27/2013 - 18:04

Odd.

Try this:

conf t

default interface

interface

switchport mode access

switchport access vlan 204

spanning-tree portf

spanning-tree bpduguard enable

Try the interface commands above and let me know.

boucherandre Mon, 03/04/2013 - 05:41

OK, now these 2 AP are working with or without the 2x-mode.  They are probably failed and unstable and the HP switch are less sensible to their hardware failure then the csico switch? Anyway, I will open a case at Aruba for a RMA on those AP.

thanks guys!

Leo Laohoo Mon, 03/04/2013 - 14:04

TDR test last run on: February 27 23:06:23

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- ---------------

Gi1/0/19  auto  Pair A     91   +/- 0  meters N/A         Normal

Pair B     87   +/- 0  meters N/A         Normal

Pair C     90   +/- 0  meters N/A         Normal

Pair D     88   +/- 0  meters N/A         Norma

Andre,

I reviewed your TDR output and I believe you have a cable issue 90 metres along the cable run.

Yes, the "status" shows NORMAL but look at the "Remote Pair" readings.  They are "N/A". 

Actions

Login or Register to take actions

This Discussion

Posted September 23, 2008 at 7:17 PM
Stats:
Replies:16 Avg. Rating:
Views:18031 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
69
65
55