Callmanager Express SIP Trunk to service provider DTMF issue

Unanswered Question
Sep 24th, 2008

we have cisco call manager express with a sip trunk to a service provider.

all calls work

dtmf internal to internal works

dtmf external to internal works

dtmf internal to extenal does not work.

has anyone done anything like this and is it possible on express?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbarcena Wed, 09/24/2008 - 08:42

What type of dtmf are you using on your dial-peer?

Could you please upload your show run?

cmelbourne Wed, 09/24/2008 - 11:40

see config below.

voice-card 0

no dspfarm

!

!

voice call carrier capacity active

service pots

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

redirect ip2ip

fax protocol pass-through g711alaw

h323

h225 signal overlap

modem passthrough nse codec g711ulaw

sip

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

voice register global

mode cme

max-dn 144

max-pool 36

date-format D/M/Y

call-forward system redirecting-expanded

create profile sync 0087542630484407

!

voice register dn 1

interface FastEthernet0/0

ip address 10.17.49.4 255.255.255.0

ip nat inside

!

interface Service-Engine0/0

ip unnumbered FastEthernet0/0

service-module ip address 10.17.49.5 255.255.255.0

service-module ip default-gateway 10.17.49.4

!

interface FastEthernet0/1

ip address x.x.x.x

ip nat outside

!

ip http server

ip http secure-server

ip http path flash:/gui

ip nat inside source list 100 interface FastEthernet0/1 overload

!

access-list 100 permit ip any any

access-list 100 permit tcp any any

access-list 100 permit udp any any

access-list 100 permit icmp any any

access-list 100 permit esp any any

access-list 100 permit gre any any

!

!

voice-port 0/0/0

!

voice-port 0/0/1

disconnect-ack

compand-type a-law

cptone GB

--More-- station-id name "MODEM"

station-id number 2288

!

voice-port 0/0/2

!

voice-port 0/0/3

!

!

mgcp

mgcp dtmf-relay voip codec all mode out-of-band

mgcp package-capability fm-package

!

!

!

dial-peer voice 40 voip

description *AUTOATTENDANT*

destination-pattern xxxxxxx

redirect ip2ip

b2bua

voice-class codec 1

session protocol sipv2

session target ipv4:10.17.49.5

dtmf-relay rtp-nte

--More-- no vad

!

dial-peer voice 41 voip

description *PromptMGM*

destination-pattern 2199

session protocol sipv2

session target ipv4:10.17.49.5

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

dial-peer voice 3001 pots

answer-address 2288

destination-pattern 2288

fax rate disable

port 0/0/1

!

dial-peer voice 1001 voip

description SIP TRUNK

--More-- translation-profile incoming prefix

translation-profile outgoing out

destination-pattern .T

redirect ip2ip

b2bua

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:x.x.x.x:5060

session transport udp

dtmf-relay rtp-nte

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

ip qos dscp cs5 media

ip qos dscp cs4 signaling

Actions

This Discussion