configuring a VWIC2-1MFT-T1/E1 for Data

Answered Question
Sep 24th, 2008
User Badges:

All,


This is our first time to configure a VWIC2-1MFT-T1/E1 as we normally use the WIC-1DSU-T1-V2 here in the states but this in Mexico. So far we have used the following to start the configuration but are now stuck. This interface will be used to support a full E1 link back to an MPLS cloud. Some of the details at the moment are simply a guess because we are waiting on the details from the provider. I just want to make sure I have all the pieces in the right place for the complete config. So far I have found very little in the way of a config sample on CCO. All seems to be designed to support voice.


card type e1 0 0

controller E1 0/0/0

framing crc4

linecode ami

clock cource line

channel-group 1 timeslots 1-24 speed 56

This much has given me interface Serial0/0/0:1 which I think is a good sign. Do I now use this to create the point-to-point for the rest of the link details? i.e. IP address, pvc number and other details? It looks like it is following the IMA config I have used in the past. Does anyone know where I can find a sample config or maybe a doc that looks more at a data connection instead of voice?


Thanks in advance


Brent

Correct Answer by wilson_1234_2 about 8 years 9 months ago

Brent,


Below is a working config of a remote 1861 router on a Frame-Relay point-to-point to our HQ site.


The HQ side serial interface is 5.1.1.61 255.255.255.252:


card type t1 0 2



controller T1 0/2/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

description Link to MPLS



interface Serial0/2/0:0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type cisco

hold-queue 256 in

hold-queue 256 out

!

interface Serial0/2/0:0.400 point-to-point

description MPLS Circuit

ip address 5.1.1.62 255.255.255.252

ip nbar protocol-discovery

ip flow ingress

ip flow egress

frame-relay interface-dlci 400 IETF

Correct Answer by Richard Burts about 8 years 9 months ago

Brent


You will know the real answers when you receive information from the provider. But in making guesses for the configuration parameters I would think that the line code would more likely be hdb3 rather than ami. And I would think that the channel-group timeslots would be 1-31 rather than 1-24. And I would think that the speed was 64 rather than 56.


Yes you are right that what you have configured does give you the serial interface and that is where you will configure the normal interface parameters such as encapsulation, address, pvc, etc.


HTH


Rick

Correct Answer by Calin Chiorean about 8 years 9 months ago

Hello!


Below you have a sample config that worked when I had to connect to provider MPLS cloud, and then p2p connection. This is frame-relay config, but you can also use ppp. For the framing you have to wait the provider to confirm that it is crc4 or no-crc4. Other details should be provided as well


card type e1 0 0

controller E1 0/0/0

framing CRC4 --> OR NO-CRC4

channel-group 0 timeslots 1-31

description connection_to_MPLS_cloud


* the "channel-group ..." command above will give you interface serial 0/0/0:0



int s0/0/0:0

no ip address

encapsulation frame-relay

no arp frame-relay


int s0/0/0:0.1 point-to-point

ip address x.x.x.x 255.255.255.252

frame-relay interface-dlci xyz


this should give you a p2p connection with provider MPLS cloud. Of course the config above does not apply in all situation. The dlci xyz will have to be communicated by provider...in any case it has to be the same on both ends.

Best would be if you have time to read this for Frame-Relay:

http://www.cisco.com/en/US/tech/tk713/tk237/technologies_tech_note09186a008014f8a7.shtml

or this for PPP back-to-back:

http://www.cisco.com/warp/public/116/ppp_back.html


The E1 controller is easy to configure after you have the information from provider. The rest is depending on your topology there.


Good luck and let us know if is working or if you need more details.


Cheers,

Calin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Calin Chiorean Wed, 09/24/2008 - 11:37
User Badges:
  • Silver, 250 points or more

Hello!


Below you have a sample config that worked when I had to connect to provider MPLS cloud, and then p2p connection. This is frame-relay config, but you can also use ppp. For the framing you have to wait the provider to confirm that it is crc4 or no-crc4. Other details should be provided as well


card type e1 0 0

controller E1 0/0/0

framing CRC4 --> OR NO-CRC4

channel-group 0 timeslots 1-31

description connection_to_MPLS_cloud


* the "channel-group ..." command above will give you interface serial 0/0/0:0



int s0/0/0:0

no ip address

encapsulation frame-relay

no arp frame-relay


int s0/0/0:0.1 point-to-point

ip address x.x.x.x 255.255.255.252

frame-relay interface-dlci xyz


this should give you a p2p connection with provider MPLS cloud. Of course the config above does not apply in all situation. The dlci xyz will have to be communicated by provider...in any case it has to be the same on both ends.

Best would be if you have time to read this for Frame-Relay:

http://www.cisco.com/en/US/tech/tk713/tk237/technologies_tech_note09186a008014f8a7.shtml

or this for PPP back-to-back:

http://www.cisco.com/warp/public/116/ppp_back.html


The E1 controller is easy to configure after you have the information from provider. The rest is depending on your topology there.


Good luck and let us know if is working or if you need more details.


Cheers,

Calin

Correct Answer
Richard Burts Wed, 09/24/2008 - 11:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Brent


You will know the real answers when you receive information from the provider. But in making guesses for the configuration parameters I would think that the line code would more likely be hdb3 rather than ami. And I would think that the channel-group timeslots would be 1-31 rather than 1-24. And I would think that the speed was 64 rather than 56.


Yes you are right that what you have configured does give you the serial interface and that is where you will configure the normal interface parameters such as encapsulation, address, pvc, etc.


HTH


Rick

Correct Answer
wilson_1234_2 Wed, 09/24/2008 - 12:41
User Badges:

Brent,


Below is a working config of a remote 1861 router on a Frame-Relay point-to-point to our HQ site.


The HQ side serial interface is 5.1.1.61 255.255.255.252:


card type t1 0 2



controller T1 0/2/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

description Link to MPLS



interface Serial0/2/0:0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type cisco

hold-queue 256 in

hold-queue 256 out

!

interface Serial0/2/0:0.400 point-to-point

description MPLS Circuit

ip address 5.1.1.62 255.255.255.252

ip nbar protocol-discovery

ip flow ingress

ip flow egress

frame-relay interface-dlci 400 IETF

bberry Thu, 09/25/2008 - 05:24
User Badges:

Hey,


Thanks all. These all look like what we have in place. Once we get the details from the provider we will tweek the config and should be good to go.


Brent

Actions

This Discussion