CUPC - Contacts show offline.

Unanswered Question
Sep 24th, 2008

I am running into a problem that all contacts in my CUPC (Unified Personal Communicator) will show as offline after about 30+ minutes or so. I have to exit out and log back into CUPC to see the actual contacts current status. Have anyone seen this issue and how to fix it.

Here are some info on the environment:

CUCM 6.1.2, Unified Presence 6.0, Unified Personal Communicator 7.0, Unity 5.0

Thanks.

Dat Pham

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
Jonathan Schulenberg Thu, 09/25/2008 - 04:46

Is there a NAT, PAT, or other stateful firewall in the path? I've seen contacts show offline with some NAT/PAT. In that case it was power-users on Linux workstations running VMware Workstation to have a Windows desktop. CUPC would only work fully if the VM was in bridged and not NAT mode. Odly enough phone control kept working but IM/presence stopped. I suspected that the SIP NOTIFY messages weren't making it across the NAT but I never dug that deep into it.

phamvinhdat Thu, 09/25/2008 - 09:49

I have checked with network admin and there is no NAT, PAT or firewall in the path. As for VMware, the servers are set with bridge mode. And all CUPC clients are running on Windows XP and MAC.

Thanks.

Dat Pham

MEB-PR Fri, 09/26/2008 - 06:31

I have same problems (read post below), even that I don't use any NAT/PAT!!!

Unified Communications Applications: CUPC 7.0

Posted by: MEB-PR - Sep 18, 2008, 2:58am PST

Hi there,

I have up and running the CUPS 6.0.4 and two days ago I installed CUPC 7.0

When I restart CUPC software everything seems to work OK (I can make and accept calls, see the status of other contacts, IM, switch between phone modes etc.)

After couple of minute's inactivity of cupc then the problems gets started: contacts are grayed out, their status is offline even that they are online, I can't change the phone mode but I can make and receive calls!!!

If I restart again the software everything is coming back to normality, again everything OK for another couple of minutes.

I changed the timers for IDLE status at preferences but it's not helping!

Any ideas?

Regards,

phamvinhdat Mon, 09/29/2008 - 13:13

Here is what I did and it seems to help in my case.

I set the Media Resource Group List for CUPS-SIP-Trunk to the same as phone device. It was default to none.

DP

aBARBASSAT Fri, 10/03/2008 - 04:31

Hi,

I have the same problem.

I'm running CUP 6.0.4, CUPC 7.0 and CUCM 6.1.2. But, when i run CUPC 2.1.4 i didn't have the problem.

And the Media Resource Group List for CUPS-SIP-Trunk is the same as phone device.

Regards,

Aurelie

Actions

This Discussion