Layer 3 connection to the core from access layer

Unanswered Question
Sep 25th, 2008


I want to connect my access layer switch to the core via layer 3. I did configure one of the physical port as routed port and the other end on the core. My users are coming from specific vlan like 200. I need some help on how to configure this? Apreciate your help

Here is my config:

Routed Interface config:

interface GigabitEthernet2/0/24

description "Connection to the Core"

no switchport

ip address x.x.x.x

no cdp enable

Switchport config:

interface GigabitEthernet2/0/2

switchport access vlan 200

ip route GigabitEthernet2/0/24

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Collin Clark Thu, 09/25/2008 - 13:13

VLAN 200 would need an IP address. Let's say /24. That will be the default gateway for your user VLAN. Next you will need a static route in your Core for pointing to the IP on Gi2/0/24.

If you role this out on a larger scale, you might want to look at using a routing protocol like EIGRP and make the switch an EIGRP stub.

Hope that helps.

mrahman0302 Thu, 09/25/2008 - 13:36

Hi Collin,

Thanks for your reply. I tried that but I can not reach other network. VLAN 200 status is up but line protocol is down. I have addedd the VLAN 200 in the databse and then created SVI 200. I am using (C3750E-UNIVERSAL-M), Version 12.2(44)SE1. Any idea on that?

Jon Marshall Thu, 09/25/2008 - 14:02

You must have a port in vlan 200 that is up/up for the vlan 200 interface to show up/up.



This Discussion