Doubt about SNA and DLSW

Unanswered Question
Sep 25th, 2008
User Badges:

Dear Mister


I have the next problem . We have a three routers connected to Token ring networks making DLSW . This is the configuration local to this routers :


source-bridge ring-group 150

dlsw local-peer peer-id 167.28.168.211 cost 4 promiscuous


interface TokenRing1/2

description Anillo 1480

no ip address

ring-speed 16

source-bridge 1088 3 150

source-bridge spanning


Well , I must to connect another equipment , 7200 too , and I put the next configuration , for the ring :


source-bridge ring-group 200

dlsw local-peer peer-id 167.28.190.111

dlsw remote-peer 0 tcp 10.69.1.46


interface TokenRing1/0

description "Conexion a Anillo 1088"

no ip address

load-interval 30

ring-speed 16

source-bridge 1088 10 200

source-bridge spanning


In the new routers , we have another equipments and another connection ( another carrier ) .


Well , both equipment are using the same roing . The first is in the promiscuos mode , the second is with static configuration . The question is :


When I put the second equipment , the connection to the first equipment start to down .


What is the reason for this ??? The configuration is bad ???


I am new in this .


Best Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
carenas123 Wed, 10/01/2008 - 14:44
User Badges:
  • Silver, 250 points or more

Make sure whether the dlsw peer connection level is ok.

You can debug through sh dlsw peer

Below Document describes how to configure a router and a mainframe computer to use Systems Network Architecture Switching Services (SNASw) over Data-Link Switching (DLSw). I hope it may help you

http://www.cisco.com/en/US/tech/tk331/tk336/technologies_configuration_example09186a0080093d90.shtml#configs



mbinzer Wed, 10/01/2008 - 21:40
User Badges:
  • Cisco Employee,

Hi,


you are saying you have 3 routers connected to tokenring networks.

I assume you are saying 1 in the branch and 2 at the headend.


Can you clearify when you say "the first equipment start to down". Is this the dlsw peer or the dlsw circuits?


If my understanding is correct it should be the dlsw circuits. When you have a configuration like i think you have than you must configure on the headend the same virtual ring-group on both routers. you are using 150 on the promiscuous one and 200 on the other one.

In that case if both are connected to the same branch you will create problems in the dlsw reachability cache. A test frame from the branch will come to the first one, get's put on the tokenring and then forwarded back out to the branch via the second router, since they use different virtual-ring numbers they can not detect that this is not what should happen. As such the dlsw reachability cache learns the remote mac addresses local and remote and from then on you have a problem.


Try to configure i.e. 150 as virtual ring group in both. So chang the second router to


source-bridge ring-group 150

dlsw local-peer peer-id 167.28.190.111

dlsw remote-peer 0 tcp 10.69.1.46


interface TokenRing 1/0

..

..

..

source-bridge 1088 10 150

soruce-bridge spanning


If you configure multiple routers on the same physical ring with the same ring-group number than you MUST make sure that you configure different bridge numbers in the source-bridge statement to make the rif strings unique.


In your case:


first router:


source-bridge 1088 3 150


second one


source-bridge 1088 10 150


Ok. If your problem is that the dlsw peer goes down to the first router when you enable the second one, than this is a different discussion.


Than it needs to be looked at what causes the peer to fail.

I would suggest to open a tac Service Request so that the issue can be propperly documented and worked to a solution.



thanks...


Matthias

Actions

This Discussion