Cisco 2811 w/SRST

Answered Question
Sep 26th, 2008

I am in the middle of testing our SRST. I believe i have everything configured correctly. When i kill the uplink on my switch, the phones swaps to CM Callback Service. I get dial tone but when i make an outgoing call i get a busy signal. The phone line works because i have can call out with a buttset. Any suggestions? Here is the config of the 2811. thanks!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.106.1 10.0.106.2

!

ip dhcp pool Voice

network 10.0.106.0 255.255.255.0

default-router 10.0.106.1

option 150 ip 10.0.100.10 10.0.100.11

!

!

no ip domain lookup

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

interface FastEthernet0/0

description Uplink to Extension_3560

ip address 10.0.106.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip route 0.0.0.0 0.0.0.0 10.0.106.1

!

!

no ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip access-list standard telnet

permit 10.0.0.0 0.0.255.255

deny any

!

snmp-server community coweta RO

!

!

!

control-plane

!

!

!

voice-port 0/0/0

timing hookflash-out 50

!

voice-port 0/0/1

!

voice-port 0/1/0

!

voice-port 0/1/1

!

ccm-manager redundant-host 10.0.100.10

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.100.10

ccm-manager config

!

mgcp

mgcp call-agent 10.0.100.11 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

!

!

!

dial-peer voice 100 pots

destination-pattern 9T

incoming called-number .

direct-inward-dial

port 0/0/0

!

dial-peer voice 999010 pots

service mgcpapp

port 0/0/0

!

!

!

!

call-manager-fallback

max-conferences 6 gain -6

transfer-system full-consult

ip source-address 10.0.106.2 port 2000

max-ephones 35

max-dn 100

keepalive 10

!

I have this problem too.
0 votes
Correct Answer by Brandon Buffin about 8 years 2 months ago

OK, so you have to dial 9 even when plugged directly into the line? If so, add the following to dial peer 100:

forward-digits all

Hope this helps.

Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
balitewiczp Fri, 09/26/2008 - 07:11

dont see "ccm-manager fallback-mgcp" in config.

also, where is the voip dial peer.

cowetacoit Fri, 09/26/2008 - 07:16

I added ccm-manager fallback-mgcp, but it is still getting the busy signal. Voip Dial Peer?

I'm actually learning this on the fly. I started here about 6 months ago and right before i started my company had a vendor come in and install CCM system. I am trying to replicate a router config. I have a feeling that SRST isn't working at the sites they configured. I can't test it but i have set up my own lab trying to grasp it.

Brandon Buffin Fri, 09/26/2008 - 07:30

If you do "show ccm-manager", does it show fallback mode as enabled and active? You may have to do "no mgcp" and then "mgcp".

Brandon

cowetacoit Fri, 09/26/2008 - 07:35

Extension_2811#sh ccm-manager fallback-mgcp

Current active Call Manager: None

MGCP Fallback mode: Enabled/ON

Last MGCP Fallback start time: 11:13:28 EST Sep 26 2008

Last MGCP Fallback end time: None

I ran NO MGCP, then ran MGCP. I tried the show ccm-manager command and same reults as well as busy signal when i dialed out. The person that posted before you mentioned a VOIP DIAL PEER?

EDIT: BTW i have the router disconnected from call manager right now. it is plugged into a layer 3 switch and the uplink is down so i can test SRST. The phone has the proper tftp config and show that Call Manager (SRST) is active

Brandon Buffin Fri, 09/26/2008 - 07:38

You don't need a voip dial peer to make a call to the PSTN. Can you turn on "debug voip dialpeer", make the call and post the results?

Brandon

Brandon Buffin Fri, 09/26/2008 - 07:56

So, you can use an analog phone on the line plugged into port 0/0/0 and dial 6788551908 and the call goes through? Is the telco expecting 10 digits on this call?

Brandon

cowetacoit Fri, 09/26/2008 - 08:00

It is a fax line in my office. I have to dial 9 to get out.

Question. what does the "9T" mean? I assume the first digit dialed has to be a 9 and T means anythings else, like a wildcard mask?

!

dial-peer voice 100 pots

destination-pattern 9T

incoming called-number .

direct-inward-dial

port 0/0/0

!

Brandon Buffin Fri, 09/26/2008 - 08:52

The T indicates a variable number of digits. The gateway waits for more digits until the interdigit timeout expires or you enter #. With POTS dial peers, explicitly matched digits are stripped. So, from your debug 6788551908 is being sent to the PSTN. Is this a valid number? Can you dial this number from the fax or another analog device using the same line?

Brandon

cowetacoit Fri, 09/26/2008 - 09:41

I can use a buttset and call that number as well as a few others. This is weird. The company that installed a couple of our original sites have it configure this way and i have no idea if they ever tested the survivability. As far as my router config, does everything look like it is configured correctly? We installed a department yesterday and everything works but SRST. So i decided to set up a lab in my office.

The main concern is 911 of course. But i should be able to call out to any number, correct?

Brandon Buffin Fri, 09/26/2008 - 09:47

Does CCM use this same port to send outbound calls at this location? If so, look at the route pattern and see what it is sending out. When you use the buttset, you are dialing 10 digits, right?

Brandon

cowetacoit Fri, 09/26/2008 - 10:18

yes, i am dialing 9, and then the number to get out. i am also dialing that on my 7941 handset when it is in srst.

As far as the Port, i'm not sure what you mean. In CCM, SRST Reference config i have port 2000 and SIP port 5060. then it says SRST certificate provider port* 2445.

In route pattern i have a list of patterns that the vendor configured.

Correct Answer
Brandon Buffin Fri, 09/26/2008 - 10:20

OK, so you have to dial 9 even when plugged directly into the line? If so, add the following to dial peer 100:

forward-digits all

Hope this helps.

Brandon

Actions

This Discussion