Unity Reports won't queue

Unanswered Question
Sep 26th, 2008
User Badges:

I keep getting an error "The report could not be queued - no reports were queued" error everytime I try to run a report. It doesn't matter what report, System or Subscriber, I get the same error. I tried logging in with different accounts and the same thing. There is nothing in the Reports queue in Status Monitor. This is a Unity 4.2.1 on Win 2003. Any ideas on what might be causing it? Anything else I should check. Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bradford Magnani Fri, 09/26/2008 - 21:49
User Badges:
  • Cisco Employee,

Are there any events that are written to the application log at the time you attempt to run the reports? Also double check to make sure that the AvRepDirSvrSvc service is started.


Brad

d.anthony.hadley_2 Mon, 09/29/2008 - 04:19
User Badges:

There are no events written to the logs when I get the error. And the AvRepDirSvrSvc service is started.

espereir Fri, 09/26/2008 - 22:22
User Badges:
  • Silver, 250 points or more

Hi D. Anthony,


Have you checked if the Reporting service is running? Have you tried to restart it?


Hope this helps!

d.anthony.hadley_2 Mon, 09/29/2008 - 04:26
User Badges:

The AvRepDirSvrSvc service is started. I haven't restarted it but I did reboot the server to see if that would help. I still get the same error:

"The report could not be queued - no report will be generated."

Any other suggestions or something to look for? Thanks.

bobsairam Sun, 09/28/2008 - 17:08
User Badges:
  • Bronze, 100 points or more

also check the disk space there ?

d.anthony.hadley_2 Mon, 09/29/2008 - 04:21
User Badges:

I checked the disk space. There are about 3 gigs left on the C drive and 50 gigs available on the D drive where the commserer folder is located.

espereir Mon, 09/29/2008 - 07:37
User Badges:
  • Silver, 250 points or more

What is the exact Unity version? Have you tried to reset the DCOM permissions?


- Go to Start - > Run - > DCOMCNFG

- Expand out to DCOM Config - > AvRep portion.

- Right click on it. Properties - > Security

- Under Launch and Activation Permissions.

- Click on Customize

- Choose Edit

- Can you find Administrators. Allow Local Activation. Can you uncheck this box, save it.

- Go to a command prompt

- Type iisreset (IIS will reset)

- Go back to the same DCOM page

- Recheck this box

- Reset IIS again


In addition, check this defect CSCsa81987

- http://www.cisco.com/cgi-bin/Support/Bugtool/home.pl


Hope this helps!

d.anthony.hadley_2 Tue, 09/30/2008 - 04:47
User Badges:

Thanks for the info. This is Unity 4.2.1. What effect will the above procedure have on the server?

Can I do this during business hours?

Will it interfere with any other services? And, by the "AvRep portion," do you mean the AvRepDirSvrSvc service?

What are the DCOM warnings to record entries in the registry? Should I just click OK?


As a side note, I did reboot the server to see if that would clear the reports problem, it didn't but when the server came up, the AvDSAD service didnt start. Could that be related to any problem with the Reports not queuing?


The bug is not related to this issue. There are no errors in the log when the reports don't queue. Thanks again.

d.anthony.hadley_2 Thu, 11/13/2008 - 07:32
User Badges:

I wanted to show the resolution here. I had to open a TAC case. It was a permissions issue with a guest account. There was a global guest account but not a local guest account. TAC found and added the local guest account.


Go to Start - > Run - > DCOMCNFG

- Expand out to DCOM Config - >

- Go to AvRepDirSvrSvc portion.

- Right click on it. Properties - >

- Security tab

- Under Launch and Activation Permissions.

- Click on Customize

- Choose Edit

- Click the Add button and find the account you need. Give it Local Activation rights.


I was able to run reports after this.

gonzalezel Thu, 04/30/2009 - 10:16
User Badges:

I don't know much about unity where do you go to view the report after it is queued I've got a couple queued but don't know where to view them?

Rob Huffman Fri, 05/01/2009 - 05:30
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Efrain,


Have you checked;


c:\CommServer\Reports\


Hope this helps!

Rob

espereir Fri, 05/01/2009 - 05:40
User Badges:
  • Silver, 250 points or more

Go to http(s):///Web/SM


Then click the blue folder icon in order to list the report queue; whenever a requeue is completed you can access it from a shared folder (\\\Reports) or from the server folder (\Commserver\Reports)


Hope this helps!

Actions

This Discussion