Inter vlan routing

Answered Question
Sep 26th, 2008

Is it possible to configure intervlan routing on a cisco 871 router ?

I have this problem too.
0 votes
Correct Answer by John Blakley about 8 years 2 months ago

Should be. After you create your vlans in the database, you can create your interface vlan1, vlan2, etc. Then assign the addresses like you want, and assign each switchport to whatever vlan you want.

HTH

--John

Correct Answer by John Blakley about 8 years 2 months ago

It depends. I think there may be a maximum of 2 vlans in the standard license. You can check like this (this is from memory, and I'm getting older :-):

Router# vlan-switch

Router(vlans)# vlan 2

Router(vlans)# vlan 3

At this point you would get an error. You can also possibly do a sh ver to find out how many vlans you're licensed for.

After creating your vlans, you create your interfaces:

fa4: (public)

ip address 5.5.5.5 255.255.255.0

fa0: (private)

no ip address

no shut

fa0.10

encaps dot1q 10

ip address 10.10.1.1 255.255.255.0

fa0.20

encaps dot1q 20

ip address 10.20.1.1 255.255.255.0

If you're going to nat, then you need to insert your ip nat statements inbound (ip nat in) on every subinterface that you want to nat.

HTH

--John

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
John Blakley Fri, 09/26/2008 - 11:16

It depends. I think there may be a maximum of 2 vlans in the standard license. You can check like this (this is from memory, and I'm getting older :-):

Router# vlan-switch

Router(vlans)# vlan 2

Router(vlans)# vlan 3

At this point you would get an error. You can also possibly do a sh ver to find out how many vlans you're licensed for.

After creating your vlans, you create your interfaces:

fa4: (public)

ip address 5.5.5.5 255.255.255.0

fa0: (private)

no ip address

no shut

fa0.10

encaps dot1q 10

ip address 10.10.1.1 255.255.255.0

fa0.20

encaps dot1q 20

ip address 10.20.1.1 255.255.255.0

If you're going to nat, then you need to insert your ip nat statements inbound (ip nat in) on every subinterface that you want to nat.

HTH

--John

kolawole1 Fri, 09/26/2008 - 11:53

Thanks.I was making confusion.

I want to make each switch port of the 871 router as a routed port (like when configuring an hwic 4ESW as a router port) by typing:

int vlan 1

ip address 172.16.1.250 255.255.255.0

no shut

int vlan 2

ip address 192.168.1.254 255.255.255.0

no shut

fa0:

switchport mode access

switchport access vlan 1

fa1:

switchport mode access

switchport access vlan 2

So i could ping the private interface ip address.Is it possible ?

Correct Answer
John Blakley Fri, 09/26/2008 - 11:57

Should be. After you create your vlans in the database, you can create your interface vlan1, vlan2, etc. Then assign the addresses like you want, and assign each switchport to whatever vlan you want.

HTH

--John

Actions

This Discussion