3750G Switch Configuration

Unanswered Question
Sep 27th, 2008

Greetings,

I have a 3750G switch with one port which has been problematic. Directly plugged into the port is a sonos network music device. This device has a switchport into which a windows client machine is plugged. Both are on the same vlan. Periodically the windows client machine loses connectivity to the network and I need to shut/no shut the port to restore connectivity. Here is the output from a show int command:

sw3750#show int Gi1/0/28

GigabitEthernet1/0/28 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0018.7393.4a9c (bia 0018.7393.4a9c)

Description: Patch port 2-13 to Entertainment Deckhouse

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:01:11, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 6000 bits/sec, 4 packets/sec

5 minute output rate 3000 bits/sec, 5 packets/sec

54426018 packets input, 371714906 bytes, 0 no buffer

Received 1018760 broadcasts (0 multicast)

0 runts, 2 giants, 0 throttles

11065 input errors, 5413 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 786806 multicast, 0 pause input

0 input packets with dribble condition detected

102805071 packets output, 3751710977 bytes, 0 underruns

0 output errors, 0 collisions, 17 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

sw3750#

The port is configured as follows:

interface GigabitEthernet1/0/28

description Patch port 2-13 to Entertainment Deckhouse

switchport access vlan 30

switchport mode access

power inline never

no mdix auto

no cdp enable

spanning-tree portfast

My questions are:

-Is this port configuration correct given that I need to have more than 1 device connectd to this port?

-What other commands can I use to troubleshoot the errors on the port?

TIA

Charlie

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Giuseppe Larosa Sat, 09/27/2008 - 08:38

Hello Charlie,

you should look at the logging buffer for log messages about the port.

the configuration is correct: without port security the number of mac addresses is not a problem.

However, the port is set for STP portfast.

try to use

show spanning-tree interface g1/0/28 and look for spanning-tree bpdu guard

With BPDU guard enabled if a BPDU is heard on the interface the interface is placed in errordisable and you need to do sh/ no sh.

It is possible to associate the bdu guard to ports in portfast in global config.

I see that there are input errors:

11065 input errors, 5413 CRC, 0 frame, 0 overrun, 0 ignored

are these errors incrementing over time or not ?

Feel free to post ouput of sh spanning-tree int gi1/0/28 and from log

use for log to filter messages:

sh log | inc 1/0/28

Hope to help

Giuseppe

charlie@im-desi... Sat, 09/27/2008 - 08:48

Hi Guiseppe,

Thanks for the reply.

Here is the output from those 2 commands:

sw3750#show log | inc 1/0/28

16w1d: %LINK-5-CHANGED: Interface GigabitEthernet1/0/28, changed state to administratively down

16w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/28, changed state to down

16w1d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/28, changed state to up

16w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/28, changed state to up

sw3750#show spanning-tree int gi1/0/28

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0030 Desg FWD 19 128.28 P2p

sw3750#

Do I need the spanning-tree portfast on this port? Could it be causing a problem? What would the effect be from removing it with 'no spanning-tree portfast'?

TIA

Giuseppe Larosa Sun, 09/28/2008 - 10:56

Hello Charlie,

if you remove the spanning-tree portfast the port will go through all the STP states blocking to learning to listening to forwarding for up to 50 seconds.

This can be a problem for a DHCP client.

If your devices have fixed ip address you can remove it.

I would suggest you to have more meaning on the logs to use:

conf t

service timestamps log datetime msec

service timestamps debug datetime msec

so you can get the exact date and time of every logged event

Hope to help

Giuseppe

akharmanbiz Sun, 09/28/2008 - 10:12

Hi,

Maybe the windows client NIC is incorrect configuration

or

you must enter the following commands:

speed auto

duplex auto

charlie@im-desi... Wed, 10/08/2008 - 03:59

Hi,

Thanks for the responses thus far.

I am still seeing this problem and now a shut/no shut does not bring the connectivity back up.

The error counters & CRC counters are not incrementing (that was asked earlier in the thread).

Any further ideas/suggestions for this problem?

serenity001 Wed, 10/08/2008 - 04:58

hi

is this problem happening even if you connect your device to another port ??

charlie@im-desi... Wed, 10/08/2008 - 06:04

Have not tried this yet but will do so.

Is there anything I can check via cli that will tell me if there is an unresolvable problem with the port (failure)?

charlie@im-desi... Thu, 10/09/2008 - 02:11

Hi serenity,

I reconfigured another port and connected that device to the new port. It seems to work now.

Do I have a failed port?

How can I check?

TIA

serenity001 Fri, 10/10/2008 - 00:19

could you attach the

show interface, show runn interface

for both ports (the one which is working and the bad one)

charlie@im-desi... Fri, 10/10/2008 - 02:46

Hi,

Here is the output from the show run interface and show interface for the 2 ports (28 is not working, 33 is working at present)

interface GigabitEthernet1/0/28

switchport access vlan 30

switchport mode access

power inline never

no mdix auto

no cdp enable

end

sw3750#show interface Gi1/0/28

GigabitEthernet1/0/28 is administratively down, line protocol is down (disabled)

Hardware is Gigabit Ethernet, address is 0018.7393.4a9c (bia 0018.7393.4a9c)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 6d13h, output 2d20h, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

67899875 packets input, 1342612372 bytes, 0 no buffer

Received 1049949 broadcasts (0 multicast)

0 runts, 2 giants, 0 throttles

11065 input errors, 5413 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 813606 multicast, 0 pause input

0 input packets with dribble condition detected

128619844 packets output, 2279668102 bytes, 0 underruns

0 output errors, 0 collisions, 41 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

sw3750#show run interface Gi1/0/33

Building configuration...

Current configuration : 232 bytes

!

interface GigabitEthernet1/0/33

switchport access vlan 30

switchport mode access

power inline never

spanning-tree portfast

end

sw3750#show interface Gi1/0/33

GigabitEthernet1/0/33 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0018.7393.4aa1 (bia 0018.7393.4aa1)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 1d18h, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 3000 bits/sec, 6 packets/sec

41227870 packets input, 2854567456 bytes, 0 no buffer

Received 3983 broadcasts (0 multicast)

0 runts, 20 giants, 0 throttles

144906 input errors, 74016 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 3451 multicast, 0 pause input

0 input packets with dribble condition detected

79260391 packets output, 656040118 bytes, 0 underruns

0 output errors, 0 collisions, 6 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

FWIW, port 28 was previously configured the same as port 33, but it did not work, so I removed spanning-tree portfast since I have multiple devices connected to this port and have read somewhere that having spanning-tree portfast on the port can cause loops which could bring down the whole network. Also from what I understand the 'no cdp enable' and 'no mdix auto' statements are inconsequential.

Can you spy anything in the show interface output that looks suspicious?

Is port 28 a failed (bad) port?

TIA

serenity001 Sat, 10/11/2008 - 10:14

hi

spanning-tree portfast command is used when you the port is connected to a host (desktop, phone ,access point) as you know each port gos in to five stages till it reach the forwarding stage and this will take around 50 sec.

so portfast will fores the port to go directly into forwarding stage.(this is useful for the DHCP)

--------------------------

cdp ( cisco Discovery Protocol) this can be used to check if you have any cisco equipment connected to your switch/router

you can use show cdp neighbouer will help u

now what is the point from this command

power inline never

--------------

regards

144906 input errors, 74016 CRC, 0 frame, 0 overrun, 0 ignored

Amit Singh Sun, 10/12/2008 - 21:39

It looks like on port 33, you have hardcoded the speed and duplex. While on port 28 it was set on Auto-auto. It seemed to be some spedd/duplex negotiation issue with the NIC and the switchport and hardcoding the same has resolved the issue. Try to switch the PC back to port 28 and hardcode the speed/duplex. I would also suggest upgrading the NIC dirvers to the latest one.

HTH, Please rate if it does.

-amit singh

Amit Singh Sun, 10/12/2008 - 21:41

This is just from the " show interface output " only. The interface configuration doesnot reveal the same.

Actions

Login or Register to take actions

This Discussion

Posted September 27, 2008 at 7:15 AM
Stats:
Replies:13 Avg. Rating:
Views:543 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,732
Rank Username Points
170
79
70
59
55