Giuseppe Larosa Sun, 09/28/2008 - 03:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jerry,

RIPv1 doesn't support VLSM but only FLSM.

the reason is that the subnet is not carried in RIPv1 update.

The subnet mask is guessed as the same as the one of the interface on which the update is received.

For this reason you need to choice a subnet mask that fits for LAN needs and to use it everywhere including serial poin-to-point links.


For this reason RIPv1 is seen as a legacy routing protocol and changed to RIPv2 or other protocol where possible.

Only possible reason could be an old unix workstation not able to support RIPv2.


Hope to help

Giuseppe



Actions

This Discussion