Rightfax SR140

Unanswered Question
Sep 29th, 2008

Does anyone know where I can get full documentation of how to implement the SR140 on a cisco network? I have looked all over the place and cannot find any documentation.

Adam

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mattcalderon Mon, 09/29/2008 - 06:28

Good luck on finding much on anything. The Right Fax solution does not have much on configuration of a new install. I wish their documentation was as detailed as the rest of Cisco's documentation.

Check this link as this is about as good as it gets:

http://www.dialogic.com/support/helpweb/brooktrout/docs.htm

This link is good for other Captaris Right Fax guides:

http://www.captaris.com/support/documentation/rightfax/index.html

Let me know if you need any help as i have done a couple of installs with the Right FAX solution and the SR140 boards.

The basics are to add the fax server as a H323 gateway and utilize a route pattern pointing to it. Configure your Fax server as a H323 gateway.

parallaxtech Mon, 09/29/2008 - 06:32

Thanks for your quick response. I have been to both of those sites and read those docs. I have everything installed but I am trying to figure out how to route the info from the pstn to the RF server. I have a 2811 ISR and CCM 4.2.

mattcalderon Mon, 09/29/2008 - 06:41

You use a route pattern that points to the RF server that you have added as a H323 gateway.

parallaxtech Mon, 09/29/2008 - 07:13

I'm kind of a newbie when it comes to all this. Could you walk me through the setup?

parallaxtech Mon, 09/29/2008 - 07:33

That page isn't available.

HTTP Status 404 - /eforum/servlet/null

type Status report

message /eforum/servlet/null

description The requested resource (/eforum/servlet/null) is not available.

Apache Tomcat/5.5.12

parallaxtech Mon, 09/29/2008 - 07:45

Ok. I created the gateway in my CM for the RF server and I also created a Route Pattern pointing to that server. When I try to call directly to the server it picks up but I dont receive any fax tone. Is there much configuration that I need to do within the SR140 settings?

mattcalderon Mon, 09/29/2008 - 08:05

In the Brooktrout configuration tool add the Gateway and point back to your ccm

parallaxtech Mon, 09/29/2008 - 08:08

Ok. We went under the IP parameters and added our CCM under the h323_default_gateway. We still cannot receive a fax tone when we try to call the RF server. We can see that it picks up the call but it times out.

mattcalderon Mon, 09/29/2008 - 08:13

do you have user set up to receive the incoming fax? Not the default of 100. you need what ever is being sent over from ccm to have that extension in the fax server

Also do you see in the enterprise fax manager that the call is coming?

Is all licensing completed?

parallaxtech Mon, 09/29/2008 - 08:16

The user is all setup in RF. We can see the call in EFM. When we call in we get dead air and then after about 5 seconds it goes to a busy tone. All licensing is completed. If you would like screen shots/logs of what is happening let me know. I appreciate all of your help.

mattcalderon Mon, 09/29/2008 - 08:20

do you see the correct extension coming in on the EFM? you should see dialing (1000) or whatever the number is. you may need to look at the logs and see what it is saying. Look at the admin guide to turn up logging.

parallaxtech Mon, 09/29/2008 - 08:24

Yes we see the correct extension. Do we need to create a dialing rule to append the CCM IP address to the end of the extension? I dont know if it will make a difference since we setup the gateway in SR140 config. We have tried it both ways (with and without the IP address) and its still not working. Everything (to my knowledge) is configured correctly but I still cannot get anything when I try to call/send a fax from RF.

parallaxtech Mon, 09/29/2008 - 08:21

The user is all setup in RF. We can see the call in EFM. When we call in we get dead air and then after about 5 seconds it goes to a busy tone. All licensing is completed. If you would like screen shots/logs of what is happening let me know. I appreciate all of your help.

mattcalderon Mon, 09/29/2008 - 08:28

dial from your ip phone the extension of the user in RF and let me know if you get fax tone. This will test incoming faxes. If you can do that let me know. ARe you only attempting outbound faxes?

parallaxtech Mon, 09/29/2008 - 08:31

I have tried that many times and not received a fax tone. We are trying to send faxes to RF and send them from RF. When we try to send them to RF we dont receive a fax tone, and when we try to send them from RF we receive a "phone line error"

mattcalderon Mon, 09/29/2008 - 08:34

A couple of things you can look at for outgoing faxes is the prefix digits. Look in the doctransport module under global transport settings and look at your prefix digits and set them up how need them. Under SR140 chek number of digits for DID routing.

parallaxtech Mon, 09/29/2008 - 08:45

We have a ',' in our Prefix settings and our DID length is the correct length for the user we are trying to connect to. When I try and send an outbound fax and receive the error "Phone Line Problem" I look into the history for that fax and the detailed error is "Dial tone after dialing"

mattcalderon Mon, 09/29/2008 - 08:52

I would first troubleshoot why you cant get incoming faxes to work. you should get fax tone just by dialing the four digit extension. I would start looking at traces.

maharris Mon, 09/29/2008 - 08:56

One other thing to check is to make sure the codec between the rightfax and gateway is set for G711. I have not been involved in many of these, but did run into trouble this issue - it has to be G711.

Mary Beth

parallaxtech Mon, 09/29/2008 - 09:21

Where would I check to see the codec settings? Would that be on the Call Manager or the RF server?

parallaxtech Mon, 09/29/2008 - 10:21

In reviewing logs the error that we receive is "Misc error: Channel not in a connected state"

Any ideas?

parallaxtech Mon, 09/29/2008 - 10:43

Here's some screenshots of our settings. The first one is the gateway settings, the second is the route pattern settings, and the third is the brooktrout config settings.

Attachment: 
maharris Mon, 09/29/2008 - 10:46

The codec settings would be in the CallManager Regions configuration - the rightfax and the gateway would both be in device pools, assigned to certain regions, and the regions config lets you set codecs between any pair of regions. The default region used to always be included, but now you have to specifically select it and set codec. In H323 IOS gateways, you also have to set the codecs on the dial peers - the default is g729.

Mary BEth

parallaxtech Mon, 09/29/2008 - 10:51

Ok. I just checked and the region codec is set to G.711 and the gateway is assigned to the device pool.

mattcalderon Mon, 09/29/2008 - 14:52

Well the only thing that I see is that on H323 gateway you dont have a CSS assigned but if you see the calls hitting on the EFM then I dont think that is your issue. At this point it may be crucial to open a TAC but all they do is open a Captaris Service Request.

parallaxtech Tue, 09/30/2008 - 08:39

Ok. I opened a Service Request with Captaris. When I try and send a fax from my standard Rightfax installation to the SR140 I get a busy signal.

parallaxtech Thu, 10/02/2008 - 11:37

Captaris says that all of my settings are correct on the RightFax side of things. They looked at a Wireshark packet. "The error that I am seeing being reported from the CCM is 'Rel Cause (41):Temporary failure'."

Anyone have any ideas?

parallaxtech Mon, 09/29/2008 - 07:35

Thanks for your quick response. I have been to both of those sites and read those docs. I have everything installed but I am trying to figure out how to route the info from the pstn to the RF server. I have a 2811 ISR and CCM 4.2.

r.stockton Wed, 10/01/2008 - 11:57

Why is CallManager required in this mix. Can we not simply pin up and H.323 trunk between the 2811 and the SR140?

Why do I ask..well, I have a Customer w/ some inbound fax failing and I'm not sure what the Gateway config should look like.

mattcalderon Wed, 10/01/2008 - 15:10

Yes if you have a H323 gateway then you dont have to go through call manager to make inbound or receive fax calls. just dial peers pointing back to the right fax server extensions will accomplish this for you.

Mc

parallaxtech Thu, 10/02/2008 - 04:54

Does anyone know if the Cisco 2811 is FOIP ready out of the box or do I need to purchase a special module?

r.stockton Thu, 10/02/2008 - 05:53

I have a Customer where this is setup, however, faxes are not completing properly. I am seeing many "fcs-BAD" messages on a wireshark capture.

WARNING: received t38:v29-9600:HDLC:fcs-BAD

gmorrow@emp.com Fri, 01/16/2009 - 07:39

I assume you got this working. If not please let me know. I can assist you with getting this to work.

gmorrow@emp.com Wed, 10/29/2008 - 10:31

Matt, I am attempting to install this same setup that you recommended. I created a new H323 Gateway in CCM and created the H323 default gateway on the RF server. My question is what port should I specify to use on the RF server? Right now it's just set at 1.

Also I set it up as an extension in the route pattern. So when I call that extension from an internal phone, RightFax picks up and i hear silence. Doesn't hang up or anything. Just said connected. But when I try dialing the actual fax number from a phone it rings 3 times then goes to a fast busy. I thought that usually that's a codec issue. But I checked them and they are all using G711.

Any ideas?

sridhar_awari Wed, 11/05/2008 - 05:30

Hi,

I have cisco 2811 as my gateway with 1 PRI E1 out of which i terminated 1 DID line on SR140, i configured as below, but still things wont work..am not able to see any thing on Rightfax utility..i wonder if the call is hitting the Rightfax server , when i dial it says connected and then disconnects after 9 seconds, But when i configure in CCM as a h.323 client in device option..i can see answering call..in rightfax server.Plz help with

voice service voip

allow-connections h323 to h323

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

dial-peer voice 201 voip

description " Right Fax dial-peer with 1 DID Number "

destination-pattern 4477

session target ipv4:10.10.10.10

codec g711alaw

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

gmorrow@emp.com Wed, 11/05/2008 - 05:35

sridhar I have gotten this to work. Please e-mail me and I will let you know what I did to fix this.

chris.warren Mon, 01/19/2009 - 13:50

I am having the same issue. Would you be able to send out some info on how you fixed it? I can get it to work w/o using a ccm, but I get the fast busy when routing through ccm

gmorrow@emp.com Tue, 01/20/2009 - 04:34

1. Add new H323 Gateway to CCM. Please see screenshot of gateway setup.

2. Configure a Route Pattern that associates back to H323 Gateway. Please see screenshot of Route Pattern setup.

3. Make sure you are using G711 as your codec. This can be found under System -> Region.

4. Make sure your partitions are setup correctly so they can talk to each other.

5. I setup the DID as a Directory Number and then put the Route Pattern code in the Call Forward All spot and don't forget to put a CSS for the Call Forward All.

Things to do on RightFax side.

1. Setup your RightFax server as H323 and then point it back to the Publisher. Please see screenshot of config.

2. Setup a test user in RightFax and under inbound routing, their routing code should be the same as what your put in the route pattern in CCM. So for me all my users have extension 9000-9999 associated with them in RightFax.

3. Then from a phone just dial that person's extension and check and see if the RightFax server picks up the call or attempts to. If it does that you know CCM is routing calls to RightFax.

4. Another test you can do is from the RightFax server act like your sending a new fax and for the fax number put in your extension and see if it dials you. When you pick up you should here a fax beep.

If you can't dial into and get a fax tone nor dial your extension from a new fax and have it complete I would install wireshark on RightFax server and attempt the fax again to your phone while running wireshark.

Please post your results. Once you get it working through CCM then we can troubleshoot the gateway if that is still having issues.

chris.warren Tue, 01/20/2009 - 05:53

This is pretty similar to what I have. I can see the RightFax server attempt to answer the call, but then I get a fast busy. Outbound dialing works fine.

gmorrow@emp.com Tue, 01/20/2009 - 05:59

On your H323 gateway under inbound calls do you have enable inbound faststart?

And when you say outbound dialing do you mean outbound to your extension or outbound fax's are transmitting fine?

chris.warren Tue, 01/20/2009 - 06:20

I have tried it with and without inbound faststart. I can dial 10 digit and internally to my number. I receive the fax tone when I answer it.

chris.warren Tue, 01/20/2009 - 06:32

Sure, Here is a snippet:

I am using a H.323 Gateway on a 2811.

!

voice-card 0

no dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

!

!

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

voice class h323 1

!

!

!

!

!

!

voice translation-rule 1

rule 1 /.*/ /55555/

!

!

voice translation-profile INBOUND

translate called 1

!

!

interface FastEthernet0/0

ip address 10.7.30.103 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.7.30.103

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.7.30.50

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

!

voice-port 0/2/0

translation-profile incoming INBOUND

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

!

!

!

!

dial-peer voice 100 voip

destination-pattern .....

session target ipv4:10.7.30.100

dtmf-relay h245-alphanumeric

codec g711ulaw

fax-relay ecm disable

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

no vad

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 10 pots

destination-pattern 8[2-9]......

port 0/2/0

forward-digits 7

!

gmorrow@emp.com Tue, 01/20/2009 - 07:07

For some bonding calls through the H.323/H.320 gateway, the gateway requires a longer time to exchange the H.323 TCS message. If the time required is greater than the timer setting for several Cisco CallManager service parameters, Cisco Unified CallManager will drop the call.

If the default Cisco Unified CallManager gateway timer values appears to be too short, Cisco Unified CallManager drops the call before completion of the call connection. Cisco recommends increasing the following service parameter timers values to avoid call failure.

•H245TCSTimeout=25

clusterwide parameters (Device - H323)

•Media Exchange Interface CapabilityTimer=25 clusterwide parameters (service)

•Media Exchange Timer=25

clusterwide parameters (service)

Actions

Login or Register to take actions

This Discussion

Posted September 29, 2008 at 5:30 AM
Stats:
Replies:58 Avg. Rating:
Views:6800 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
154
95
75
66
55