-= QoS for VoIP... Is this correct or am I doing it wrong =-

Unanswered Question
Sep 29th, 2008
User Badges:

I'd like to know if I'm doing QoS correctly between 2 sites (Lincoln and Raleigh). We are doing VoIP (using SIP and RTP) between both sites with the only other protocol being TCP 2633 (i3CLIENT). The i3CLIENT traffic is the desktop software that runs on each users desktop. It tells the users when a call comes in and information about the customer on the phone before the user actually answers the call.

Our network is a frame-relay network. Each site, Raleigh/Lincoln, has 3 T1 circuits with a PVC talking to the upstream end with a CIR of 1536. I chose to do IP CEF per-packet to aggregate the T1s but would prefer to do MLPoFR. My issue is sometimes the users complain of the i3 client running slow. When I do 'show policy-map int xxx' I see that the Voice has no drops but the Trans policy-map is dropping roughly 26% of traffic. I'd like to tweak the Trans (i3CLIENT) stuff to not drop so much BUT insure that the VOICE gets all the bandwidth it needs. I wasn't sure if I needed to create the service policy for a 1536 shape average or 4608 shape average. The only other protocols that flow between these 2 sites is probably ping and SIP.


Should I attempt MLPoFR to cut down on jitter? How would I do it based on my config? According to our users, call quality sounds great but I'm not sure if I'm doing it efficiently or correctly.

The below attachment is from the Raleigh router (The Lincoln router is mirror-image):



----------------------

!

no ip source-route

!

!

ip nbar port-map i3CLIENT tcp 2633

ip cef

!

!

!

class-map match-any SDMTrans-Serial0/0/0.1

match protocol i3CLIENT

class-map match-any SDMVoice-Serial0/0/0.1

match protocol rtp audio

class-map match-any SDMSignal-Serial0/0/0.1

match protocol h323

match protocol rtcp

!

!

policy-map SDM-Pol-Serial0/0/0.1

class SDMVoice-Serial0/0/0.1

priority percent 50

set dscp ef

class SDMSignal-Serial0/0/0.1

set dscp cs3

bandwidth remaining percent 15

class SDMTrans-Serial0/0/0.1

set dscp af21

bandwidth remaining percent 65

policy-map SDM-Pol-Serial0/0/0.1-FR

class class-default

shape average 1536000

service-policy SDM-Pol-Serial0/0/0.1

!

!

!

!

interface GigabitEthernet0/0

description Raleigh-LAN

ip address 17.6.0.35 255.255.240.0

ip accounting output-packets

ip route-cache flow

load-interval 30

duplex full

speed 100

!

!

interface Serial0/0/0

description DLCI227

bandwidth 1536

encapsulation frame-relay

no fair-queue

!

interface Serial0/0/0.1 point-to-point

description PVC-RALtoLIN-VOIP (DLCI227->126)

ip address 172.17.4.30 255.255.255.252

ip nbar protocol-discovery

ip load-sharing per-packet

snmp trap link-status

frame-relay interface-dlci 126

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

service-policy output SDM-Pol-Serial0/0/0.1-FR

!

interface Serial0/0/1

description (DLCI 228)

bandwidth 1536

encapsulation frame-relay

no fair-queue

!

interface Serial0/0/1.1 point-to-point

description PVC-RALtoLIN-VOIP (DLCI228->222)

ip address 172.17.4.34 255.255.255.252

ip nbar protocol-discovery

ip load-sharing per-packet

snmp trap link-status

frame-relay interface-dlci 222

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

service-policy output SDM-Pol-Serial0/0/0.1-FR

!

interface Serial0/1/0

description (DLCI 229)

bandwidth 1536

encapsulation frame-relay

no fair-queue

!

interface Serial0/1/0.1 point-to-point

description PVC-RALtoLIN-VOIP (DLCI229->223)

ip address 172.17.4.38 255.255.255.252

ip nbar protocol-discovery

ip load-sharing per-packet

snmp trap link-status

frame-relay interface-dlci 223

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

service-policy output SDM-Pol-Serial0/0/0.1-FR

!

!

ip route 0.0.0.0 0.0.0.0 Null0

ip route 17.8.0.0 255.255.240.0 172.17.4.29

ip route 17.8.0.0 255.255.240.0 172.17.4.33

ip route 17.8.0.0 255.255.240.0 172.17.4.37

!

!


!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rkendrick_2 Mon, 09/29/2008 - 10:36
User Badges:


------------------


Below is 'show policy-map' from one of the interfaces:

RAL-VoIP#sh policy-map int s0/0/0.1


Serial0/0/0.1


Service-policy output: SDM-Pol-Serial0/0/0.1-FR


Class-map: class-default (match-any)

4873515 packets, 598900584 bytes

30 second offered rate 595000 bps, drop rate 4000 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

1536000/1536000 9600 38400 38400 25 4800


Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 4852502 562996175 771773 140656035 no


Service-policy : SDM-Pol-Serial0/0/0.1


Class-map: SDMVoice-Serial0/0/0.1 (match-any)

3698423 packets, 236682376 bytes

30 second offered rate 274000 bps, drop rate 0 bps

Match: protocol rtp audio

3698424 packets, 236682440 bytes

30 second rate 274000 bps

Queueing

Strict Priority

Output Queue: Conversation 72

Bandwidth 50 (%)

Bandwidth 768 (kbps) Burst 19200 (Bytes)

(pkts matched/bytes matched) 387964/24828408

(total drops/bytes drops) 0/0

QoS Set

dscp ef

Packets marked 3698424


Class-map: SDMSignal-Serial0/0/0.1 (match-any)

21389 packets, 3955462 bytes

30 second offered rate 3000 bps, drop rate 0 bps

Match: protocol h323

6392 packets, 2415554 bytes

30 second rate 1000 bps

Match: protocol rtcp

14997 packets, 1539908 bytes

30 second rate 1000 bps

QoS Set

dscp cs3

Packets marked 21389

Queueing

Output Queue: Conversation 73

Bandwidth remaining 15 (%)Max Threshold 64 (packets)

(pkts matched/bytes matched) 4058/1030098

(depth/total drops/no-buffer drops) 0/0/0


Class-map: SDMTrans-Serial0/0/0.1 (match-any)

1070381 packets, 348254349 bytes

30 second offered rate 311000 bps, drop rate 4000 bps

Match: protocol secure-telnet

0 packets, 0 bytes

30 second rate 0 bps

Match: protocol ssh

0 packets, 0 bytes

30 second rate 0 bps

Match: protocol telnet

0 packets, 0 bytes

30 second rate 0 bps

Match: protocol custom-01

1070381 packets, 348254349 bytes

30 second rate 311000 bps

QoS Set

dscp af21

Packets marked 1070381

Queueing

Output Queue: Conversation 74

Bandwidth remaining 65 (%)Max Threshold 64 (packets)

(pkts matched/bytes matched) 390412/117535689

(depth/total drops/no-buffer drops) 0/21015/0


Class-map: class-default (match-any)

83323 packets, 10008461 bytes

30 second offered rate 5000 bps, drop rate 0 bps

Match: any

Hi,

I will suggest you specify bandwidth for guaranteed bandwidth statements and not use

"bandwidth remaining percent" command. use specific banwidth value.


e.g to give the application and vocie signalling 128 each the policy-map will be as follows.



policy-map SDM-Pol-Serial0/0/0.1

class SDMVoice-Serial0/0/0.1

priority percent 50

set dscp ef

class SDMSignal-Serial0/0/0.1

set dscp cs3

bandwidth 128

class SDMTrans-Serial0/0/0.1

set dscp af21

bandwidth 128

policy-map SDM-Pol-Serial0/0/0.1-FR

class class-default

shape average 1536000


rkendrick_2 Thu, 10/09/2008 - 12:20
User Badges:

What happens when the Trans traffic exceeds 128kbps? Will it drop the traffic heavily?

Actions

This Discussion