HSRP on a interface with a crypto map

Answered Question
Sep 29th, 2008

Not sure if I am in the right section. But we are trying to run HSRP on an interface with a crypto map assigned to it. Thus, I need to get the tunnel to work with the virtual ip address. The trick with this should just be a few commands. I have done this on other devices.

interface FastEthernet0/1.1111

description VPN

encapsulation dot1Q 1111

ip address 222.222.222.3 255.255.255.224

standby 20 ip 222.222.222.3

standby 20 priority 200

standby 20 preempt delay minimum 180

standby 20 name HOU_VPN

crypto map VPN redundancy HOU_VPN

the two commands that should make this work are:

standby 20 name HOU_VPN

crypto map VPN redundancy HOU_VPN

i know this tunnel is working because it works fine without HSRP and applying the VPN crypto map to the interface.

when i setup the interface like the one above, i get the following error:

%Crypto map already applied and usage inconsistant

anyone know what this may mean.

p.s.

i just notice that cisco spelled INCONSISTENT wrong. :)

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 8 years 3 months ago

Hello Dwayne,

you are trying to use something in the middle between classic crypto map and stateful IPSec I was able too to use it.

I think it can be an issue with the platform and IOS release you are using.

or simply you need to remove all references to the crypto and then appy the command with the additional option

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Mon, 09/29/2008 - 11:51

Hello Dwayne,

you are trying to use something in the middle between classic crypto map and stateful IPSec I was able too to use it.

I think it can be an issue with the platform and IOS release you are using.

or simply you need to remove all references to the crypto and then appy the command with the additional option

Hope to help

Giuseppe

dphills18 Mon, 09/29/2008 - 12:11

i think that might be it. i looked back through the config and saw the crypto map applied to two other interfaces. i am going to try this again and let you know how it came out. thaks for your response.

Actions

This Discussion