config for AT&T ADSL through 1841 with ATM WIC

Answered Question
Sep 29th, 2008
User Badges:

I have a static IP from AT&T for an ADSL connection. My router is an 1841 with an ATM (with ADSL module). I have a username and password and the IP/mask/gw from AT&T but I'm not sure if I have my config correct. All the interfaces that I think are involved show up, up.



Attachment: 
Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello Jason,


here is a config for PPPoE over ATM PVC


http://www.cisco.com/en/US/docs/ios/bbdsl/configuration/guide/bba_pppoe_ddr_it_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1039162



PPPoEoA Client Configuration Example

The following example shows how to configure the PPPoE client DDR idle-timer on an ATM PVC interface:


!

vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface ATM0/1/0

pvc 0/35

pppoe-client dial-pool-number 1 dial-on-demand

!

interface Dialer1

ip address x.x.x.x

! what must be

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer idle-timeout 180 either

dialer hold-queue 100

dialer-group 1

! other ppp auth commands here


!

dialer-list 1 protocol ip permit

!

ip route 0.0.0.0 0.0.0.0 Dialer1


You need to adapt it to your case where the ip address is static and not negotiated and to find out the ppp authentication config under dialer interface


Hope to help

Giuseppe



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
Giuseppe Larosa Mon, 09/29/2008 - 11:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

if AT&T provides a static ip address how can be the ip address negotiated as in your config ?


probably you just need to configure IPv4 over aal5snap


int atm0


ip address x.x.x.x 255.255.255.255


pvc 0/35

encapsulation aal5snap

protocol ip x.x.x.y broadcast


without using a dialer or at least you need to assign the ip address as per specification inside dialer config


Hope to help

Giuseppe


jasonww04 Mon, 09/29/2008 - 14:46
User Badges:

I changed the interface configs but it still doesn't work.

interface ATM0/1/0

ip address 71.x.x.49 255.255.255.248

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

crypto map to_vpn

pvc 0/1

encapsulation aal5autoppp Dialer0

dialer pool-member 1

!

!

interface Virtual-Template2

no ip address

!

interface Dialer0

no ip address

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password xxx

ppp pap sent-username [email protected] password 7

Giuseppe Larosa Sat, 10/04/2008 - 00:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,


two notes:


it is unlikely that the right VPI/VCI is 0/1 because ATM standard reservers for the network values 0/1-31 : the first usable PVC is 0/32.


Check with the provider what values you need to use.


b)

if you assign an IP address to the ATM interface you need to change the pvc encapsulation:


pvc 8/35

enc aal5snap


you probably don't need the dialer and virtual-template sorry if I was unclear in previous post


I'm a little confused : usually ip address is dynamically assigned during ppp negotiation.

When a static ip address is provided the config is different as described above and is classical IPv4 over ATM.


You need to clarify with the provider what type of ADSL service they are giving you.


Hope to help

Giuseppe


jasonww04 Mon, 10/06/2008 - 06:37
User Badges:

I changed the config per your suggestion but it still doesn't seem to be working. AT&T's support is pretty useless when trying to get the information I need. They tell me they are not trained to help configure a Cisco router with ATM WIC.


interface ATM0/1/0

ip address 71.142.18.49 255.255.255.248

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

crypto map to_vpn

pvc 8/35

encapsulation aal5snap


No dialer interface and no virtual interface

jasonww04 Mon, 10/06/2008 - 08:36
User Badges:

I spoke to a level 2 tech at AT&T and he told me I need to use PVC 0/35 and the router must authenticate before it can use the static IP so I believe I need a dialer interface.

Here is my config now but it is still not working. I've attached a show int.


interface ATM0/1/0

no ip address

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

crypto map to_vpn

pvc 0/35

dialer pool-member 1

protocol ppp dialer

!

!

interface Dialer0

no ip address

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password 7 11071C1D0317075D

ppp pap sent-username [email protected] password 7 09424B110D001B43



Giuseppe Larosa Mon, 10/06/2008 - 09:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

this is a step further

I would try the following:


int atm0/1/0

no ip nat outside


! all L3 config under dialer0 and set the ip address to the one provided


int dialer0

ip address 71.142.18.49 255.255.255.248

! use the static address they have provided

ip nat outside

! nat outside here


then

int atm0/1/0

shut


term mon

debug ppp negotiation

debug ppp authentication


int atm0/1/0

no shut


collect the output and post it as a text file


term no mon

undebug all




Hope to help

Giuseppe


Giuseppe Larosa Mon, 10/06/2008 - 14:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

O : output tx frames

I : input rx frames


no one is sending any form of PPP frame to your router. you can never see a I frame in this debug output.

Try to contact again the person that has given you about the right VPI/VCI and ask what form of PPP they want

PPPoA over ATM

PPPoEoA = pppoE over ATM


configurations and ATM encapsulations are different in the two cases


Your current config is the first one.


Hope to help

Giuseppe


Correct Answer
Giuseppe Larosa Tue, 10/07/2008 - 09:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,


here is a config for PPPoE over ATM PVC


http://www.cisco.com/en/US/docs/ios/bbdsl/configuration/guide/bba_pppoe_ddr_it_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1039162



PPPoEoA Client Configuration Example

The following example shows how to configure the PPPoE client DDR idle-timer on an ATM PVC interface:


!

vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface ATM0/1/0

pvc 0/35

pppoe-client dial-pool-number 1 dial-on-demand

!

interface Dialer1

ip address x.x.x.x

! what must be

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer idle-timeout 180 either

dialer hold-queue 100

dialer-group 1

! other ppp auth commands here


!

dialer-list 1 protocol ip permit

!

ip route 0.0.0.0 0.0.0.0 Dialer1


You need to adapt it to your case where the ip address is static and not negotiated and to find out the ppp authentication config under dialer interface


Hope to help

Giuseppe



jasonww04 Tue, 10/07/2008 - 09:42
User Badges:

I will try that config and let you know. AT&T did say that the IP is "sticky static," meaning the IP is reserved for my router but it will be negotiated based on the credentials I have. For other AT&T connections I've configured I had to put username/password in but leave the address as negotiated.

jasonww04 Tue, 10/07/2008 - 11:03
User Badges:

I tried the config and I think we are almost there. Attached is the current config along with the debug output.


When I put the static IP on the dialer interface nothing happened but when I made the dialer negotiate it worked, mostly. I'm not getting the static IP I was told was assigned to me and after a few minutes I lose the IP and have to shut/no shut the ATM interface to get an IP again.


Does it have to be demand dial? Can't I have the router just make the connection and keep it up all the time?



Attachment: 
Giuseppe Larosa Tue, 10/07/2008 - 11:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

things look like far better now


notes

a) I would move ip nat outside on dialer interface


b) to avoid DDR

try to configure the pppoe client on the pvc without the last option



c) to have the DDR to restart is just enough to make an extended ping you don't need anymore to do shut/no shut on the atm interface


Hope to help

Giuseppe


jasonww04 Tue, 10/07/2008 - 12:09
User Badges:

Made the changes and it looks like it is working. I just have to call AT&T to find out why I'm not getting the static IP that was reserved for me.


Anytime you are in Denver I owe you a case (or 5) of beer.

Giuseppe Larosa Tue, 10/07/2008 - 12:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

>> Anytime you are in Denver I owe you a case (or 5) of beer


I live and work in Europe but who knows ... an holiday


Thanks for your kind remarks but to be correct I have to say that it wasn't necessary to remark all the posts


Best Regards

Giuseppe


Jon Marshall Tue, 10/07/2008 - 12:24
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Guiseppe


"but to be correct I have to say that it wasn't necessary to remark all the posts"


nothing wrong with that at all, even though it means i am now looking up at you :-).


You deserved the points as i'm sure Jason would agree.


Jon

Actions

This Discussion