Anyone knows what this message/error means?

Unanswered Question
Sep 30th, 2008

C3640#

Sep 30 14:33:18.269: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=649388EC, count=0

-Traceback= 6039EC38 60423D08 605EF4F4 605EF720 625438D8 62544C64 6255F0A0 625509C4 625500B4

Sep 30 14:33:18.293: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=64938C18, count=0

-Traceback= 6039EC38 60423D08 605EF4F4 605EF720 625438D8 62544C64 6255F0A0 625509C4 625500B4

Sep 30 14:33:18.393: %SYS-2-BADSHARE: Bad

refcount in datagram_done, ptr=64938F44, count=0

-Traceback= 6039EC38 60423D08 605EF4F4 605EF720 625438D8 62544C64 6255F0A0 625509C4 625500B4

I keep seeing these messages on my Cisco 3640 router running IOS version c3640-jk9o3s-mz.123-8.T11.bin.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Danilo Dy Tue, 09/30/2008 - 07:05

Are you running IGMP? Turn it off "no ip igmp snooping" in global coonfiguration mode.

If that doesn't fix it, update your IOS image.

cisco24x7 Tue, 09/30/2008 - 07:10

Hi,

How do you know that it is igmp related?

The image is the latest 12.3(T) I can fit on a

Cisco 3640 router. I don't think I can upgrade

to a later IOS image.

Any more ideas? Thanks.

Danilo Dy Tue, 09/30/2008 - 07:14

Have you tried the commands yet?

According to Cisco, this error is cosmetic (or informational only) and should not affect the performance.

cisco24x7 Tue, 09/30/2008 - 07:33

I have a L2L VPN between this router and another Cisco 3845 router. When I do this:

ping 129.174.100.1 source lo0 repeat 99999999 size 2048 (129.174.100.1 is the IP address

of the network behind the other VPN router),

I start seeing A LOT of this:

Sep 30 15:26:16.600: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=64939F20, count=0

-Traceback= 6039EC38 60423D08 605EF4F4 605EF720 625438D8 62544C64 6255F0A0 625509C4 625500B4

Sep 30 15:26:16.688: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=6493A24C, count=0

-Traceback= 6039EC38 60423D08 605EF4F4 605EF720 625438D8 62544C64 6255F0A0 625509C4 625500B4

C3640#

CPU on the router goes from 0% to almost 90%.

Must be an IOS bug.

Danilo Dy Tue, 09/30/2008 - 07:40

A lot of caveats similar to this message but not specifically for 3640 and IOS and exact message.

Here are the lists of possible problems

- IGMP

- MLPPP

- GRE

- VoIP

- DMVPN

- ADSL

- IOS

Most of them no workaround (specially DMVPN). All of them are known bugs, but you mentioned that you can't update your IOS image.

[EDIT] If you want to search them, search "%SYS-2-BADSHARE: Bad refcount in datagram_done" and also look for "Traceback" in the results. Without "datagram_done" the search may direct you to hardware problem.

Actions

This Discussion