Possible NAT issue

Unanswered Question
Sep 30th, 2008
User Badges:

Hello All,


I use a 2611XM to route voice traffic. I use two ISPs for failover. I use IP SLA to track the interface and do a failover. Here's the configuration.


track timer interface 5


track 123 rtr 1 reachability

delay down 15 up 10

!

track 345 rtr 2 reachability

delay down 15 up 10


interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside


interface FastEthernet0/1

ip address 182.65.23.52 255.255.252.0

ip nat outside


interface Dialer1

ip address negotiated

ip nat outside


ip route 0.0.0.0 0.0.0.0 182.65.23.1 track 123

ip route 0.0.0.0 0.0.0.0 Dialer1 5


ip access-list extended NAT

permit ip 192.168.0.0 0.0.0.255 any


ip nat inside source route-map CABLE interface FastEthernet0/1 overload oer

ip nat inside source route-map DSL interface Dialer1 overload oer


ip sla 1

icmp-echo 182.65.23.1 source-interface FastEthernet0/1

timeout 1000

threshold 40

frequency 3

ip sla schedule 1 life forever start-time now

ip sla 2

icmp-echo 4.2.2.2 source-interface Dialer1

timeout 1000

threshold 40

frequency 3

ip sla schedule 2 life forever start-time now


route-map CABLE permit 10

match ip address NAT

match interface FastEthernet0/1

!

route-map DSL permit 10

match ip address NAT

match interface Dialer1


The problem is that any time an ISP goes down and the other ISP become primary path, I have to clear NAT statement from the router and reboot the phone. I am using an Asterisk based IP PBX as Call Manager and Linksys phones.


Any help on this would be highly appreciated.


Thanks and Regards

OJ

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rais Tue, 09/30/2008 - 10:25
User Badges:
  • Silver, 250 points or more

Have you tried setting timeout seconds for NAT to a lower value?


Thanks.

rais Fri, 10/03/2008 - 11:25
User Badges:
  • Silver, 250 points or more

Can't think of anything else. May be bringing up the other interface after same amount of time that NAT expires in would help.


Rais.

Actions

This Discussion