Verizon Bonded T1 Internet Lines (Cisco 2811)

Unanswered Question
kcgeorge1218 Wed, 10/01/2008 - 10:33
User Badges:

Try this...

!

interface Multilink1

ip address

peer default ip address

ppp chap hostname <> ---> optional

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!


bond the two serial interfaces via the ML-PPP bundle.

!

interface Serialx/x/x

description ML-PPP

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

no cdp enable

ppp chap hostname <>

ppp multilink

ppp multilink group 1

frame-relay interface-dlci

!

interface Serialx/x/x

description ML-PPP

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

no cdp enable

ppp chap hostname <>

ppp multilink

ppp multilink group 1

frame-relay interface-dlci

!


Giuseppe Larosa Wed, 10/01/2008 - 11:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matt,

use the following doc


http://www.cisco.com/en/US/docs/ios/wan/configuration/guide/wan_ml_fr_frf161_ps6350_TSD_Products_Configuration_Guide_Chapter.html


explains multilink frame-relay FRF16


note:

do not disable frame-relay inverse-arp on member links this created a problem in another thread


Hope to help

Giuseppe


Here is the config I currently have that does not work. Are you saying "no arp frame-relay" command in the Serial interfaces I should enable?



interface MFR1

mtu 4470

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay IETF

no ip route-cache cef

no ip mroute-cache

load-interval 30

no arp frame-relay

frame-relay multilink bid to gw

frame-relay lmi-type ansi

!

interface MFR1.500 point-to-point

ip address 255.255.255.252

no ip redirects

no ip proxy-arp

no cdp enable

no arp frame-relay

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip vrf forwarding FE00

ip address 255.255.255.192

duplex full

speed auto

!


interface Serial0/0/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay MFR1

load-interval 30

service-module t1 timeslots 1-24

no arp frame-relay

!

interface Serial0/1/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay MFR1

load-interval 30

service-module t1 timeslots 1-24

no arp frame-relay

Giuseppe Larosa Wed, 10/01/2008 - 12:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matt,


on each serial interface


int ser0/x/y

arp frame-relay


int MFR1

arp frame-rel



Hope to help

Giuseppe


I tried that using the above config and all interfaces came up OK and no alarm lights, but no traffic was passing. Verizon has not been any help. They send me the below config, but it is not setup for bonding 2 T1's. Can you help manipulate this for bonding?


!

version 12.1 ! IOS Version

service timestamps debug uptime ! Requests timestamp of logs

no service password-encryption ! No password encryption

! ! Off by default

hostname ROUTER

!

ip subnet-zero ! Allows the router to use the first subnet of a block

ip cef ! Enables Cisco express forwarding

no ip finger ! Disables finger on the router (UNIX Comand)

!

interface FastEthernet0/0 ! Customer Interior Interface

ip address XX.XX.XX.XX 255.255.255.0 ! Interior IP Address

no ip mroute-cache ! Disables multicast fast

switching

no keepalive ! Disables Ethernet keepalives

speed 100 ! Locks down port speed

full-duplex ! Locks down duplex mode

no cdp enable ! Disable Cisco Discovery Protocol

!

interface Serial0/0 ! Customer WAN interface

no ip address

encapsulation frame-relay IETF ! Sets interface encapsulation

service-module t1 timeslots 1-24 ! Sets timeslots (channels of T1)

service-module t1 framing esf ! Sets T1 Framing

service-module t1 linecode b8zs ! Sets T1 Linecode

service-module t1 clock source internal ! Sets clocking to Internal

frame-relay lmi-type ansi ! Set LMI type

load-interval 30 ! Sets length of time load

calculations

no fair-queue ! Enable Fair Queuing on an Interface

bandwidth ! Bandwidth. Just a description

!

interface Serial0/0.1 point-to-point ! Enables sub-interface

ip addresss XX.XX.XX.XX 255.255.255.252 ! IP address of WAN interface

frame-relay interface-dlci 500 IETF ! Sets DLCI and Encapsulation

no ip redirects ! Disables redirect messages from WAN INT.

no ip proxy-arp ! Disables ARP per RFC1027

no arp frame-relay ! Disables ARP for the interface

no cdp enable ! Disable Cisco Discovery Protocol

bandwidth ! Bandwidth. Just a description

!

ip route 0.0.0.0 0.0.0.0 Serial0/0.1 ! Sets default gateway of last esort

ip classless ! Enable classless routing behavior

no cdp run ! Disable Cisco Discovery Protocol

no ip http server ! Disables HTTP server feature (for security)

!

ip domain-name ALTER.NET ! Sets domain-name

ip name-server 198.6.1.1 ! DNS server router uses

ip name-server 198.6.1.2 ! Secondary DNS server router uses

snmp-server community 6f270ca640 RO ! SNMP community string

snmp-server trap-authentication

!


Giuseppe Larosa Fri, 10/03/2008 - 12:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matt,

for the specific type of serial interfaces you have you need to configure some layer1 parameters.


so on each serial you need to add the following commands:


service-module t1 timeslots 1-24 ! Sets timeslots (channels of T1)

service-module t1 framing esf ! Sets T1 Framing

service-module t1 linecode b8zs ! Sets T1 Linecode

service-module t1 clock line



see


http://www.cisco.com/en/US/docs/ios/interface/configuration/guide/ir_dsu_rtrs.html#wp1025039




However, as Edison has correctly noted the multilink FR bundle will work only if configured on both sides yours and the router on the other side.

So check if Verizon has given you just a second T1 or actually they are ready for multilink FR FRF.16 bundle


Hope to help

Giuseppe


I have confirmed that this circuit is configured for bonding on Verizon's end. Below is the config that I have, but I am not sure where the MLPPP comes into place.


interface MFR1

mtu 4470

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay IETF

no ip route-cache cef

no ip mroute-cache

load-interval 30

no arp frame-relay

frame-relay multilink bid to gw

frame-relay lmi-type ansi

!

interface MFR1.500 point-to-point

ip address x.x.x.x 255.255.255.252

no ip redirects

no ip proxy-arp

no cdp enable

no arp frame-relay

!


!

interface Serial0/0/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay MFR1

load-interval 30

service-module t1 timeslots 1-24

service-module t1 framing esf

service-module t1 linecode b8zs

frame-relay lmi-type ansi

no fair-queue

no arp frame-relay

!

interface Serial0/1/0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay MFR1

load-interval 30

service-module t1 timeslots 1-24

service-module t1 framing esf

service-module t1 linecode b8zs

frame-relay lmi-type ansi

no fair-queue

no arp frame-relay


Giuseppe Larosa Fri, 10/03/2008 - 13:03
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matt,

MLPPP is a different matter and here you have FRF.16 multilink FR.


I see you still have the arp frame-rel disabled I had suggested to enable it in previous post in another thread this was the problem and the collegue had the same symptom : everything looks like well but no traffic flows


so enable it on all interfaces


int serx/y

arp frame-rel


int mfr1

arp frame-rel


int mfr1.500

arp frame-rel



Why you should need it: the bundle has its own signaling that need to be able to flow on the links


see


http://www.cisco.com/en/US/docs/ios/wan/configuration/guide/wan_ml_fr_frf161_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1054108


see section link integrity protocol control messages


By the way in the config examples in the document the arp frame-rel is not disabled and the default should be to be enabled




if Verizon did a MLPPP bundle a similar but different configuration is needed


Hope to help

Giuseppe


Edison Ortiz Fri, 10/03/2008 - 15:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

They can't configure MLPPP in their end while you are running the non-MLPPP way.


Any time I've have migrated configurations from non-MLPPP to MLPPP, we have to schedule with the ISP so they can change their configuration at the same time I'm changing my side.


You really need to talk to your provider to get this going. MLPPP needs the directly attached routers to be talking the same protocol, else it won't work.


HTH,


__


Edison.

Edison Ortiz Wed, 10/01/2008 - 14:11
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

One thing to keep in mind, for bonding, both sides need to be configured for MLPPP.


You need to work w/ your provider so they can configure their internet routers. The provider internet router must be the same holding both T1s, else this configuration won't work.



HTH,


__


Edison.

Actions

This Discussion