RIP routing update not showing up

Unanswered Question
Oct 1st, 2008
User Badges:

Hello,

From an ABR, i have RIP and OSPF running but unfortunately my "show ip route" could not give either of routes to other paths as required. Not showing up at all. Yet, my debug ip rip and debug ip ospf adj and event reveals no indications for this, even though all concerned IP ADD are up and running.

Any help to resolve this shall be highly appreciated.

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sybren.Apiecionek_2 Wed, 10/01/2008 - 03:10
User Badges:

So i I understand you correctly:

You have an ABR which runs RIP & OSPF. But they are not displayed if you do a "show ip route"?


Could you show us your config for "router rip" & "router ospf"?


as also you show ip route?

I have an idea but I am not sure what yuou mean.

newnetman Wed, 10/01/2008 - 03:32
User Badges:

Hello,

Here is the output and i hope it will help to help me further?.


This is the output of sh ip rou on the ABR

Gateway of last resort is not set


172.16.0.0/24 is subnetted, 2 subnets

C 172.16.5.0 is directly connected, FastEthernet0/0

C 172.16.1.0 is directly connected, Serial1/0

Router3-Mark#

The Serial int is a member of an ospf area, while the Fa0/0 connect to a RIP NET.

interface FastEthernet0/0

ip address 172.16.5.5 255.255.255.0

duplex auto

speed auto


interface Serial1/0

ip address 172.16.1.6 255.255.255.0

encapsulation frame-relay

frame-relay map ip 172.16.1.5 302 broadcast

no frame-relay inverse-arp



The output from RIP neighbor to the ABR

interface FastEthernet0/0

ip address 172.16.5.8 255.255.255.0

sh ip route

Gateway of last resort is not set


172.16.0.0/24 is subnetted, 2 subnets

C 172.16.5.0 is directly connected, FastEthernet0/0

R 172.16.1.0 [120/1] via 172.16.5.5, 00:00:10, FastEthernet0/0

Router-Peter#




This is the output of the Serial neighbor to the ABR, though yet connected to other neighbors. Only its relationship with the ABR could not be seen.

Gateway of last resort is not set


172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

C 172.16.9.0/24 is directly connected, Ethernet0/0

C 172.16.2.4/30 is directly connected, Serial0/0.2

C 172.16.1.0/24 is directly connected, Serial0/0.1

128.100.0.0/24 is subnetted, 2 subnets

O E2 128.100.1.0 [110/20] via 172.16.9.9, 01:08:42, Ethernet0/0

O E2 128.100.2.0 [110/20] via 172.16.9.9, 01:08:42, Ethernet0/0

Router2-John#

singhsaju Wed, 10/01/2008 - 05:34
User Badges:
  • Silver, 250 points or more

Can you also post results of " show ip ospf neighbor " and "show ip protocol" on ABR.

ozzyosbu1 Wed, 10/01/2008 - 11:03
User Badges:

Router-Peter <---Ethernet-----> Router3-Mark(ASBR) <------ FR -------> Router2-John



are you able to ping the serial interface IP of ASBR from Router2-John

you seem to be using a subinterface there, you might need to recheck your framerelay map configuration there


Giuseppe Larosa Wed, 10/01/2008 - 11:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello New,

be aware that connecting a main FR serial interface and a subinterface can cause problems if the subif is point-to-point on one side you have an OSPF network type mismatch that can cause strange problems.


post

Router2-John# sh run int s0/0.1


sh ip ospf int se0/0.1


Router-Peter# sh ip ospf int ser1/0


check for the OSPF network type


Hope to help

Giuseppe


Sybren.Apiecionek_2 Wed, 10/01/2008 - 09:24
User Badges:

Can you also do a

on ABR:

- show run | section router rip

- show run | section router ospf

on RIP only router:

- show run | section router rip

on OSPF only router:

- show run | section router ospf


if the IOS does not support the command section, it is your ospf and rip config.


This way we can see how you configured things.

newnetman Wed, 10/01/2008 - 10:16
User Badges:

Here are requested outputs. Thanks in advance


Router3-Mark#show run | section router ospf

router ospf 1

router-id 250.250.3.3

log-adjacency-changes

network 172.16.1.6 0.0.0.0 area 10

Router3-Mark#


On the ABR

sh ip ospf nei returns nothing

sh run | section router rip returns nothing


Show ip protocol on the ABR

Router3-Mark#sip

Routing Protocol is "ospf 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 250.250.3.3

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

172.16.1.6 0.0.0.0 area 10

Reference bandwidth unit is 100 mbps

Routing Information Sources:

Gateway Distance Last Update

Distance: (default is 110)


Routing Protocol is "rip"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Sending updates every 30 seconds, next due in 28 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Redistributing: rip

Default version control: send version 2, receive version 2

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 2 2

Automatic network summarization is not in effect

Interface Send Recv Triggered RIP Key-chain

Maximum path: 4

Routing for Networks:

172.16.0.0

Passive Interface(s):

Serial1/0

Routing Information Sources:

Gateway Distance Last Update

Distance: (default is 120)

Router3-Mark#


On the RIP only router

Router-Peter#sir rip

172.16.0.0/24 is subnetted, 2 subnets

R 172.16.1.0 [120/1] via 172.16.5.5, 00:00:13, FastEthernet0/0

ozzyosbu1 Wed, 10/01/2008 - 11:06
User Badges:

Router-Peter <---Ethernet-----> Router3-Mark(ASBR) <------ FR -------> Router2-John



are you able to ping the serial interface IP of ASBR from Router2-John

you seem to be using a subinterface there, you might need to recheck your framerelay map configuration there


Actions

This Discussion