Need assistance configuring 3560 for Cisco 7940 ip phone and PC on single c

Unanswered Question
Oct 1st, 2008
User Badges:

I currently have a setup where we are using a Cisco Catalyst 3650 POE switch to support Cisco 7940 phones and PC's. Currently they are sharing a data T1. The PC is plugged into the the phone as there is only 1 network conection at each desk. I have configured the 3560 using the Smartports and things are working fine.


Soon we will be getting a direct T1 from our hosted IP phone providor and we will need to create seperate vlans for voice and data?


Can anyone help me in configuring this setup? Can I do it through the GUI or do I need to use command line interface?


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 10/01/2008 - 08:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Harlan,

when you will add a specific WAN link for the VoIP traffic you will need to have two separate vlans for voice and data: this will help you using for example PBR to perform source based routing.


I don't know if you can do it with the GUI I use the CLI.


However, the logical steps are the following:


on the switch:

you need to create the L2 Vlans for voice and data.


vlan 10


vlan 20


let's suppose the first is for data the second is for voice


on each switch port


interface fasx/y

switchport

switchport mode access

switchport access vlan 10

switchport voice vlan 20


b) DHCP

if the C3650 POE is also performing the role of DHCP server you should do the following


!

ip dhcp pool DATI

network 10.110.224.128 255.255.255.240

default-router 10.110.224.129

dns-server 10.98.112.32 10.55.0.32

netbios-name-server 10.52.64.37 10.24.128.151

lease 0 1

!

ip dhcp pool VOICE

network 10.110.224.144 255.255.255.248

default-router 10.110.224.145

dns-server 10.98.112.32 10.55.0.32

netbios-name-server 10.52.64.37 10.24.128.151

option 150 ip 10.98.67.5 10.55.61.4

lease 0 1

!


option 150 is used to provide the ip addresses of the TFTP servers to the phone


you may need to exclude switch ip addresses


ip dhcp excluded-address 10.110.224.129 10.110.224.132

ip dhcp excluded-address 10.110.224.145



you need to define the L3 interfaces associated to the two vlans


int vlan 10

description VLAN DATA

ip address 10.110.224.129 255.255.255.240

no shut


int vlan 20

description VLAN VOICE

ip address 10.110.224.145 255.255.255.248

no shut


Hope to help

Giuseppe


Actions

This Discussion