Cisco 870 / SDM from scratch

Unanswered Question
Oct 1st, 2008
User Badges:

Hi Folks,


I just re-install the IOS on my router (via XMODEM) - I now want to put SDM back on the box, but I can't connect to the router with the SDM installer? I can connect via HTTP/HTTPS to the router via it's default IP address (although the page it displays is just basic info) but when I try and connect via SDM installer it's not connecting?


What do I need to do?


Cheers,


M

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mdujardin Wed, 10/01/2008 - 13:13
User Badges:

Good document, looks like what I needed accept I missed a vital step and when I hot reload my router went back to ROMMON. I guess the image I copied up didn't copy in to FLASH. What do I need to do to make sure it does?


M

Jon Marshall Wed, 10/01/2008 - 13:16
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Do you know why it went to ROMMON. It may be that your image is in flash but your configuration register is wrong - it should be 0x2102.


Try boot the router from flash ie.


boot system flash flash:


Jon

mdujardin Wed, 10/01/2008 - 13:23
User Badges:

I'm not sure why (sorry), I am now at ROMMOM 7, if I do DIR I get:-


flash[0]: (read-write)


The show flash command won't work?


Jon Marshall Wed, 10/01/2008 - 13:25
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

try "dir flash"


Do you know the image name that you loaded onto the router ?


Jon



mdujardin Wed, 10/01/2008 - 13:27
User Badges:

Yes, I have the image name.


c870-advipservicesk9-mz.124-20.T1.bin


When I do dir flash I get:-


unable to stat flash/: permission denied

Jon Marshall Wed, 10/01/2008 - 13:32
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

try


rommom> boot


if nothing


rommon> boot system flash flash:c870-advipservicesk9-mz.124-20.T1


Let me know


Jon

Jon Marshall Wed, 10/01/2008 - 13:40
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Where did you upload image to ??


Try this


rommon> confreg 2101


then try pervious boot commands in last post.


Jon

mdujardin Wed, 10/01/2008 - 13:45
User Badges:

Well, when I copied the image I used this:-


xmodem -c c870-advipservicesk9-mz.124-20.T1.bin


The image copied up OK and then I was able to configure the IOS and that's what I started to install SDM. At one point I rebooted it (power cycle) and then the image was no longer there.


Tried the 2101 it says "No bootable image file"


M

Jon Marshall Wed, 10/01/2008 - 13:55
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Okay, you said you missed an important step - what was that.


Also can you post the output of


rommon> list


Jon

mdujardin Wed, 10/01/2008 - 14:01
User Badges:

Well, I'm not 100% sure the image was copied to FLASH, hence why when I power cycled the image was not there so it wouldn't boot. But I think doing confreg 0x2102 tells it to boot from FLASH ... No?


list does nothing, but ls gives me:-


List of filesystems currently registered:


flash[01]: (read/write)


Thanks for helping Jon - I'm learning a lot here :)


M


Jon Marshall Wed, 10/01/2008 - 14:07
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Yes - confreg 0x2102 tells it to boot from flash.


No bootable image sounds like we need to load another one. If you have a tftp server you can do this a lot quicker than xmodem. Here is a link to yes another doc :) for using tftp. Do you have a tftp server that you can use ?. If not i can zip a small one that will run on XP and post it here.


http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/rommon.html#wp1020649


Jon

mdujardin Wed, 10/01/2008 - 14:12
User Badges:

I have the SolarWinds TFTP Server on the same machine as I'm using to console in to the 870. I had some problems trying to connect to the server though, you have a better server?


Cheer,


M

Jon Marshall Wed, 10/01/2008 - 14:15
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Never used Solarwinds tftp but here is one that has always worked for me. Have to zip it as Cisco site will not allow uploads of .exe files.


Jon



Attachment: 
mdujardin Wed, 10/01/2008 - 14:20
User Badges:

OK, silly question but how do I get that link to work?

Jon Marshall Wed, 10/01/2008 - 14:21
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Click on the middle icon - the one with the down arrow. This will allow you to download the winzip file. Unzip it and then double-click on tftpd32.exe.


Jon

mdujardin Wed, 10/01/2008 - 14:37
User Badges:

OK, getting there Jon, image started to copy via TFTP and then it stopped :(


TFTP flash copy: Invalid file header, copy terminated.

Reason: Wrong target platform OR corrupt file.


It can't be corrupt surely? I used it before and it was fine :-/


M

Jon Marshall Wed, 10/01/2008 - 14:30
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

M


Need to go to bed now :). I'll pick this up tomorrow morning or hopefully someone else can step in.


If you get the stage where you have the router up and running with your image make sure you set the configuration register before you reload it.


Jon

mdujardin Wed, 10/01/2008 - 14:40
User Badges:

OK, gonna go to bed as well. Late now and early start tomorrow. Thanks for the help Jon, hopefully we can have another go tomorrow.


M

mdujardin Thu, 10/02/2008 - 09:11
User Badges:

Hi Jon,


Hope you had a good day at work mate! I hope we can get this problem fixed today (I owe you a beer). I'm trying to do the xmodem upload now but I get "Image size exceeds free flash space" - I checked flash and there is 23M free and my image is 21M. Any ideas?


Cheers,


M

mdujardin Thu, 10/02/2008 - 09:50
User Badges:

Making a little progress. I've upgraded ROMMOM to the latest version. I'm now copying the latest IOS using XMODEM. I used this command:-


XMODEM -R


What next?

Jon Marshall Thu, 10/02/2008 - 10:16
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Have you managed to copy an image via Xmodem or are you still getting an error ?


If you only have 21M free sounds like you still have an image in flash. How big is your advanced services image ?


Jon

kmccourt Thu, 10/02/2008 - 10:32
User Badges:
  • Bronze, 100 points or more

Sorry to interrupt here but what size of flash do you have? The IOS you're trying to load (12.4(20)T1) is large. Once you have it installed you will not be able to install SDM on the router if you only have 24MB flash. Even 28MB will be tight. Of course you'll still be able to run SDM from a PC.


You might want to consider installing a smaller footprint IOS such as 12.4(15)T7 if you don't need any of the new features of 12.4(20)T.

mdujardin Thu, 10/02/2008 - 11:00
User Badges:

Hi Jon,


No, there were no other images in FLASH. It's copying up now (20 mins to go) had to use XMODEM again (kinda slow but it works).


To KMCCOURT it's no interruption, your input is appreciated. I had it running with 12.4 and SDM originally so it does fit (that was the default when I received the unit) - unfortunately I reset the unit and now we are having this fun and games :)


M

Jon Marshall Thu, 10/02/2008 - 11:10
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

M


Okay shout when it is done :)


kmccourt - no problem, please feel free to help out, that's the beauty of NetPro.


Jon

kmccourt Thu, 10/02/2008 - 11:16
User Badges:
  • Bronze, 100 points or more

But are you sure it was running with 12.4(20)T1? - that was only released a couple of days ago ;)

mdujardin Thu, 10/02/2008 - 12:25
User Badges:

ok so I'm now in to the IOS. How can I copy over that IOS to flash?


"But are you sure it was running with 12.4(20)T1? - that was only released a couple of days ago ;) "


Yep, I'm sure, 2 days ago I installed it myself :) (with the help of Jon ;))

Jon Marshall Thu, 10/02/2008 - 12:27
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

M


What is the output of a "sh flash"


Jon

Jon Marshall Thu, 10/02/2008 - 12:39
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

M


I have never used xmodem -r. That copies the image into dram and i don't know if there is a command to copy dram to flash. If anybody else knows please step in.


However you should be able to now copy the image from tftp into flash ie.


router# copy tftp flash


and then you will be prompted for ip address of tftp server, image name etc.


If that works then you need to make sure you set the configuration to 0x2102. A "sh run" should show you what the current setting is.


Jon

mdujardin Thu, 10/02/2008 - 12:45
User Badges:

Great stuff mate, copying over image now with TFTP to FLASH. I'll be sure to make sure I set the 0x2102 command :)

mdujardin Thu, 10/02/2008 - 12:51
User Badges:

OK, can I just double check the command to set it to 0x2102 I'm not in ROMMOM anymore so the command to set it in there no longer works.

Jon Marshall Thu, 10/02/2008 - 12:56
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

router# config-register 0x 2102


then do a "sh run" and verify that this is the config register.


Then do a write mem. Cross fingers and reload :)


Jon

mdujardin Thu, 10/02/2008 - 13:32
User Badges:

Great stuff! All working nicely and SDM has been installed as well :)


THANK YOU VERY MUCH FOR YOUR HELP!!!!

Jon Marshall Thu, 10/02/2008 - 13:35
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

No problem, glad we got there in the end :)

Jon Marshall Thu, 10/02/2008 - 14:13
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Matt


Forgot to ask - when do i get my beer :-)


Jon

mdujardin Sun, 10/05/2008 - 06:06
User Badges:

Hi Folks,


I have a quick question. I'm using 12.5 version of SDM. However, when I go to the Firewall / ACL tab the interface has changed massively to what it was before I built my firewall. I'm still using the same version of IOS. The interface now looks really basic as if it's an old version. Anyone come across this before or no how to get back the familiar interface?


Cheers,


M

Jon Marshall Sun, 10/05/2008 - 10:05
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Matt


Can't help you with the above unfortunately. Just wanted to suggest you may be better off posting this question in a new thread as this one has become rather long and many people might not bother reading to the end.


Just a suggestion.


Jon

Actions

This Discussion