CCX5.0(2) - Troubleshooting Welcome Prompts

Unanswered Question
Oct 2nd, 2008
User Badges:

Hi!


I have configured an application that uses the icd.aef script and is associated to a CM Telephony Trigger. When I test it calling to the trigger number the phone rings immediately without passing the script prompts.

What could be going wrong?

I have the same numbers for CTI ports and agent phones.


Thanks in advanced,

Ana


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Thu, 10/02/2008 - 07:58
User Badges:
  • Purple, 4500 points or more

Make sure the prompt names in the script match the actual file names and that the prompts are available if you go to Prompt Management. You can also use Reactive Debuggin in the CRS Editor (Debug > Reactive Script) to view the script as it is being executed.


Hope this helps.


Brandon

abartolomeu Fri, 10/03/2008 - 02:52
User Badges:

Hi!


When I try reactive debug I have the following output:


"

Error Debugging teste_icd.aef

Reactive Debugging Timer timed out

"


The timer was set to 10sec. It times out before the triggering event. What could be the issue?


Ana


Jonathan Schulenberg Fri, 10/03/2008 - 03:53
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

The triggering event would be a call to the CTI Route Point assigned to an application that uses the icd.aef script. Did you call it within 10 seconds?


Second, what do you mean by "I have the same numbers for CTI ports and agent phones."? Just checking that you've assigned the CTI Route Points, CTI Ports, and Agent Extensions unique values...


Lastly, you need to make sure that the prompt is formatted properly. It should be in a P[greeting.wav] format if it exists within the root of the en_US directory. If you're not sure click the ... button to open the expression editor. Then click the Prompts tab and select the Browse button. Select Prompt Repository from the left and find the prompt you want to call.


PS. Make sure your prompt is in g.7111 mu-law format. You can't just pull in any WAV file off the street. :)

abartolomeu Fri, 10/03/2008 - 07:51
User Badges:

I had assigned the same CTI ports and agent extensions values!!! Not unique values. I've already correct that.


The situation has improved. The BasicQ.aef and VisibleQ.aef work fine. But when I try the icd.aef it goes straight to the default script. I don't know why.


I still can't do the Reactive Debug and I do the call within the chosen time.

Any clue of what am I doing wrong?


Thanks,

Ana


Actions

This Discussion