SSL Anyconnect client with 881 router

Unanswered Question
Oct 2nd, 2008

I got a brand new 881 router with IOS 12.4(20)T and advanced security license. Is anyconnect client supported for IOS? I am able to connect using the old SSL client with no problem, but when trying to use anyconnect (pre installed on machine already) it gives me the error, "anyconnect package unavailable on the peer."

I uninstalled the current sslvpn client in the router (no webvpn install svc), uploaded the latest version with anyconnect (sslclient-win-, but when I tried to install using webvpn install svc flash:<filename>, it gives me the error, "SSLVPN Package SSL-VPN-Client (seq:1): installed Error: Invalid Archive." I am able to reinstall the sslclient package that came preloaded in the route with no problem. Anybody have any ideas or am I missing a step somewhere? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
vmoopeung Wed, 10/08/2008 - 07:40

You may try updating the flash with latest cisco anyconnect.

Version on router flash may be older than currently installed version on client. Upgraded version on flash to 2.x

Also you may try deleting and reloading the anyconnect

brianjpisa Sat, 10/11/2008 - 05:59

I already tried uploading the latest anyconnect package (anyconnect-win-2.2.0140-k9.pkg) to the router, uninstalling the sslclient, and installing the anyconnect package, but get the same error, "SSLVPN Package SSL-VPN-Client (seq:1): installed Error: Invalid Archive." The version I able to successfully install is sslclient-win- I even tried upgrading it to sslclient-win-, but get the invalid archive error.

brianjpisa Tue, 10/21/2008 - 03:16

Nevermind I got it working. Upgraded to 12.4.22T. When trying to transfer the new IOS image to upgrade the router via TFTP, it would complete 75% of the upload, then timeout. I had FTP the new IOS to the router. I tried installing the anyconnect package it gave me the invalid archive error again, but this time it automatically deleted it from the flash. I used FTP to upload the anyconnect package to the flash instead of TFTP. I was then able to install the package on the router. It seems their may be a problem with TFTP on this router platform, I never had any problems with TFTP before.


This Discussion