RME Software Distribution Issue

Unanswered Question
Oct 2nd, 2008

I'm using RME 4.1.1 to upgrade 3560's and 3750's. The job fails everytime, flash gets erase and the new image installed but the config.txt and vlan.dat files never get replaced. I end up with a blank switch.....any ideas? Output from the job log is below.


Processing Device : x.x.x.253

Start Time : Thu Oct 02 10:48:48 CDT 2008

Device is locked for exclusive access.

The supported protocols for image transfer are: TFTP

Connecting to the device using SSH...

Connected successfully.

Require Flash Erase to load the new image...

Trying to backup flash:vlan.dat from the device using TFTP

Copying flash:vlan.dat to C:/PROGRA~1/CSCOpx/tftpboot/rep_sw_3066641279921579996 using TFTP.

Copying vlan.dat from flash to tftp://x.x.x.75/C:/PROGRA~1/CSCOpx/tftpboot/rep_sw_3066641279921579996

Successfully imported the image from device.

Total time for copying the image - 3 Seconds

Trying to backup flash:config.text from the device using TFTP

Copying flash:config.text to C:/PROGRA~1/CSCOpx/tftpboot/rep_sw_4928420134226978514 using TFTP.

Copying config.text from flash to tftp://x.x.x.75/C:/PROGRA~1/CSCOpx/tftpboot/rep_sw_4928420134226978514

Successfully imported the image from device.

Total time for copying the image - 3 Seconds

Erased flash partition successfully.

Retrieving configuration file from the device...

Current device config is copied to C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\1073\x.x.x.253_Config

Checking if HTTP server is enabled on the device...

Http Server is not enabled, will continue with Software Upgrade Operation.

Copying c3560-ipservicesk9-tar.122-46.SE.tar from Software Repository to tftp-specific directory.

Copied successfully to C:/PROGRA~1/CSCOpx/tftpboot/rep_sw_4733313998130715934

Loading image file to flash device : rep_sw_4733313998130715934 --> flash:c3560-ipservicesk9-tar.122-46.SE.tar using TFTP

Error loading image to Flash. See C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\1073\x.x.x.253_telnet.log for the output from the device on which the image transfer failed.

Moving the files which are backed up during flash erase to job directory...

Moving vlan.dat from C:\PROGRA~1\CSCOpx\tftpboot\rep_sw_3066641279921579996 to job directory.

Successfully moved to C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\1073\vlan.dat

Moving config.text from C:\PROGRA~1\CSCOpx\tftpboot\rep_sw_4928420134226978514 to job directory.

Successfully moved to C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\1073\config.text

Image Copy Operation Failed

Device is unlocked.

Device Upgrade Result : Failed

End Time:Thu Oct 02 11:09:18 CDT 2008


Job Ended At : Thu Oct 02 11:10:58 CDT 2008


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Thu, 10/02/2008 - 08:26

There is a bug, CSCsl58585, in which RME deletes all files in flash, but only restores config.text and vlan.dat once the job completes. The bug is fixed in RME 4.2.

You should not be seeing vlan.dat deleted after the job finishes. This file should be backed up and restored by SWIM. If that's not happening, the job may be failing, or you may have bug.

jms112080 Thu, 10/02/2008 - 08:32

Job fails every time, when it gets to the point of restoring the config.txt and vlan.dat files.

Joe Clarke Thu, 10/02/2008 - 08:33

Yes, your job failed. The backed up files can be found in C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\1073 along with the logs related to this job. Those files can be restored to the switch.

jms112080 Thu, 10/02/2008 - 08:40

I know I can do it manually, but RME is useless if I have to go behind and restore all my configurations.

Joe Clarke Thu, 10/02/2008 - 08:43

The job failed. That shouldn't happen. If the problem causing the failure is solved, then the config files will be restored automatically. If you can, post the contents of the job directory. If the information is too sensitive, then open a service request with TAC with the job directory files.


This Discussion