Why wont the 3750 work where a 2950 does?

Unanswered Question
Oct 2nd, 2008

I have terminals that boot up from a disk and obtain IP from server via DHCP. Had 2950 switches and works a treat. Replaced switch with 3750 not in stack and cannot get this to work. IP address appears as incomplete in ARP on router momentarily.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cpubob Thu, 10/02/2008 - 10:30

Is portfast turned on for the ports that connect to the terminals? By default spanning tree goes through 30 seconds worth of learning modes before the port goes into forwarding state.

cable-wireless Thu, 10/09/2008 - 10:53

Yes tried that thanks. The IP address appears to be allocated form the DHCP server and appears on the list, but with no name next to it. Then the terminal hangs. When connected with an old 2950 it goes through no problem.

glen.grant Thu, 10/02/2008 - 11:42

On any user ports use the "switchport host" command , this turns on portfast and shuts off trunking and etherchannel negotiation.

glen.grant Thu, 10/09/2008 - 14:35

Does the 3750 have routing turned off ? If you want to use it as a l2 switch turn off routing and it should be the equivalent of a 2940 switch.

Richard Burts Thu, 10/09/2008 - 15:40

I believe that we might come closer to a good answer if we had some additional information about the situation. Can the original poster tell us:

- where is the DHCP server? (is it in the same VLAN with the clients or in a different VLAN? What is the traffic flow from the switch to the server? If the server is in a remote subnet are there ip helper-address configured to point to the server?)

- if you hard code an IP address (and subnet mask and gateway) on a client, can the client then ping the DHCP server?

- are there any config differences between the 2950 and the 3750? If the 2950 was configured with a trunk, is the same trunk configured on the 3750? Are the VLAN assignments on the 3750 exactly like the VLAN assignments on the 2950?

HTH

Rick

cable-wireless Fri, 10/10/2008 - 00:46

DHCP on same VLAN. Only using VLAN1.ip helper on router even though same subnet. Have tried with and without.Not tried to hard code yet. Would the trunk config make a difference if the trunk was not being used. The client and server are on the same switch?

cable-wireless Fri, 10/10/2008 - 00:34

Hi, thanks for the reply.

I have routing OFF.I have portfast on. Its as if there is something that is on by default on the 3750 that wasnt on the 2950. (or indeed off).

glen.grant Fri, 10/10/2008 - 03:38

Shouldn't be if routing is turned off, it is the equivalent of a layer 2 switch at that point and you have portfast on . I assume you have L1 , link lights on both ends of the user connections . Don't know what the problem would be if the dhcp server is on the same box . The trunk config to the upstream router should make no difference if the dhcp server is on the 3560 along with the clients and no other vlans are defined beside default vlan 1. Maybe you can post the 3560 config and indicate what ports the user and dhcp serve is connected to .

naveen_b81 Fri, 10/10/2008 - 04:53

Please check if you have DHCP snooping enabled globally, if yes, then trust the port connected to the DHCP server.

Cheers,

Naveen B

cable-wireless Thu, 11/06/2008 - 03:33

Hi all thanks for your suggestions.

I have now got the terminals / tills to boot across the 3750. I have a flat vlan 1. When you set a port to switchport and switchport access vlan 1 on a 2950, it shows on the sh run as switcport mode access and when you put in switchport mode access it defaults to vlan1.

The 3750 looks like it does the same, but you have to actually type in switchport access vlan 1 for it to work.

cable-wireless Thu, 11/06/2008 - 03:36

Now I have another problem, in that there are two types of NIC cards in the tills.

One type is 3com, the other is realtek. The 3com dont work on the 3750, but the realtek does. How can i find out if there is a compatibility issue with the 3com one?

Actions

This Discussion