LMS 2.6 upgrade to the D: partition.

Unanswered Question
Oct 2nd, 2008
User Badges:

Running LMS 2.5 on a Windows 2003 server integrated with ACS 3.3

I am forced to unistall LMS 2.5 from the C: and reinstall to D: for space reasons


I also wanted to upgrade to 2.6 at the same time.


I uninstalled IPM, then CiscoWorks followed by a reboot, then deleted the directories.


I then installed:


2.6 bundle single file

3.0.6 common services patch

common services URL patch

common services SNMP patch

common services JRE patch

MDF 1.23 device update common services 4.0.6 RME patch

Campus 4.0.10

Campus 4.0.11

DFM 2.0.10

DFM 2.0.11


reregisted the apps with ACS integration


Everything (devices in other apps selectable) works fine except that almost all device in RME only are unselectable.


job attempts yeild device not supported


After reviewing posts I found

"The way you will know the device package installation is successful is that the .zip files in NMSROOT\MDC\tomcat\webapps\rme\WEB-INF\lib\pkgs and NMSROOT\www\classpath\com\cisco\nm\xms\psu\pkgs\rme are exactly the same."


I shortened the TMP and TEMP variables and disabled virus scanning and repeated the above process


The two directories above remain identical until I load the RME 4.0.6 patch at which time they differ 277 to 258......

Hoping there is something obvious and simple that I am missing...

I won't get funding for CiscoWorks 3.x until next quarter


any help appreciated !!!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 10/02/2008 - 12:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

When you say you repeated the steps above, you started from a clean system, and reinstalled everything? What were your values for TEMP and TMP? Did you shorten both the per-user and the global values?

john.caterino Thu, 10/02/2008 - 16:01
User Badges:

Yes, I uninstalled everything and started over with TMP and TEMP set to C:\Windows\temp

and disabled virus scanning.

Joe Clarke Thu, 10/02/2008 - 18:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

But did you set both the global and per-user variables to C:\WINDOWS\TEMP? It sounds like you may have just set the global values.

john.caterino Fri, 10/03/2008 - 02:20
User Badges:

The system variables for both TEMP and TMP were already set to C:\windows\temp. Is there somewhere else i need to change them other than in "environment variables" from the advanced tab of "system properties".


also If there is something else to change, will I have to reinstall LMS 2.5 and the rest or can I just reinstall the RME 4.0.6 update. The second time I reinstalled everything I stopped at RME 4.0.6 when the directories did not match.

john.caterino Fri, 10/03/2008 - 02:52
User Badges:

I don't know if these help but


the number of files before the patch in both directories were 274. After the patch they stand at

WEB-INF\lib\pkgs = 258

psu\pkgs\rme = 277



also the RMEPSUCLI.log shows

warnings for the first 216 files for versions already installed, then it has "java.util.zip.ZipException: the system cannot find the file specified" for the next 8 followed by : "Error package installation failed for (XXXX) d:\cisco\temp\rme_cids_pkgs\xxxx.zip(the system cannot find the file specified)" for the the next 42.


again thanks for your help....

john.caterino Fri, 10/03/2008 - 03:29
User Badges:

grasping at straws but trying to give you as much info as possible, would the fact that I ran the update remotely using a remote desktop connection have had any affect?

Joe Clarke Fri, 10/03/2008 - 07:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the entire log.

Joe Clarke Fri, 10/03/2008 - 07:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

In the Environment variables section, there are two panes. The TEMP and TMP environment variables are in both. You must change both locations. The installation log will indicate if the correct locations were changed as you will see references to C:\WINDOWS\TEMP.


After making the changes and rebooting, you can try reinstalling RME 4.0.6 alone. However, we have seen many instances where it is necessary to reinstall all of LMS.

john.caterino Fri, 10/03/2008 - 07:54
User Badges:

Is the installation log that should show

C:\windows\temp the RMEPSUCli.log all references in there seem to go to D:\cisco\temp "D:\cisco" being the NMSROOT.


the network this box is on is isolated and I may not be able to post the file.. but I'm working on it.

Joe Clarke Fri, 10/03/2008 - 08:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I mean the RME 4.0.6 installation log in C:\.

john.caterino Fri, 10/03/2008 - 08:45
User Badges:

My bad....

the install file shows TMP and TEMP both set to C:\windows\temp\2 and all other references in the log use C:\windows\temp\2 as well. I am not sure where the \2 came from.




Joe Clarke Fri, 10/03/2008 - 08:52
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

That is fine. The PSU log may have more of a clue why the package installation failed.

john.caterino Fri, 10/03/2008 - 09:19
User Badges:

again I appologize for not being able to post the log yet.


The PSU.log processes most packages as already installed then has the following entries for the next packages:


XXX represents the pkg name


ERROR [PackageInstaller: LogandUpdateEvent: ]:Package Installation Failed for (XXX) : d:\cisco\temp\rme_cids_pkgs\xxx.zip ( the system cannot find the file specified )


INFO [SIMPLEPROGRESS: ProgressInfo] : Progress : Package Installation Failed:d:\cisco\temp\rme_cids_pkgs\xxx.zip ( the system cannot find the file specified )


INFO [PackageInstaller: InstallStep_InstallAndCommit]: Attempting to undoinstall...


Joe Clarke Fri, 10/03/2008 - 09:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I need the list of failed packages which is why the log would be helpful. Additionally, the RME 4.0.6 installation log would also be helpful.

Joe Clarke Fri, 10/03/2008 - 15:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I can't see why the packages were not copied properly. However, the first thing I would do is copy the missing .zip files from pkgs\rme to WEB-INF\lib\pkgs, then restart dmgtd. 277 seems light to me. I seem to recall a base RME 4.0.6 installation should have 282. If you still have problems, after syncing the two directories, please post the list of .zip files in both.

john.caterino Tue, 10/14/2008 - 06:26
User Badges:

apparently just adding the files that were missing helped but not 100% as some devices are still greyed out. Apparently not only did some packages not get added others were were not upgraded, I have found several packages so far that have versions older than what should be there for 4.0.6. I will post a list as soon as I am able of the zip files in both however I was wondering if I could just copy the packages from another identical server ( currently being reinstalled and upgraded ) and replace all 281 packages and restart the deamons?

Joe Clarke Tue, 10/14/2008 - 08:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes, technically you can do this, but other problems may have occurred during the installation. You may see other issues in the future. It might be beneficial to open a TAC service request, and reinstall over WebEx to make sure everything is being done correctly.

john.caterino Mon, 11/24/2008 - 04:11
User Badges:

jclarke,

I know it has been forever on this but I had several unrelated issues with upgrading a second server. I am still not sure why the copy of device pkgs does not complete during the 4.0.6 RME update successfully however i was able to get one directory with all 281 pkgs and I copied them over. So far everything appears to be running

fine.


Thanks again for all the help!

Actions

This Discussion