Frame-relay traffic-shaping

Unanswered Question
Oct 2nd, 2008
User Badges:

Hi all,


We have 2 sites connected to the main office via FR.


We've configured QoS on the frame-relay interface (it's a WIC-1T).


- When a "service-policy output" is applied on each serial interface, and the qos is tested only between one site and the main office, it works well.


- When there's a traffic from 2 sites to the main office, the policy-map is no more respected.


- We tried to use map-class and apply "frame-relay traffic-shaping" with class on serial interfaces, we can see the policy-map respected but the bandwidth is reduced, speed of transfert is really low.



We did the test with FTP and File copy between sites.


here's our config



- on main office


interface Serial0/1

description Liaison FR

ip address 10.10.10.1 255.255.255.248

encapsulation frame-relay IETF

no fair-queue

frame-relay traffic-shaping

frame-relay interface-dlci 16

class QOS_FR

frame-relay interface-dlci 17

class QOS_FR



- on site 1


interface Serial0/1/0

description Liaison FR

ip address 10.10.10.2 255.255.255.248

encapsulation frame-relay

ip route-cache flow

load-interval 30

no fair-queue

frame-relay traffic-shaping

frame-relay interface-dlci 16

class QOS_FR






- on site 2


interface Serial0/1/0

description Liaison FR

ip address 10.10.10.3 255.255.255.248

encapsulation frame-relay IETF

no fair-queue

clock rate 2000000

frame-relay traffic-shaping

frame-relay interface-dlci 16

class QOS_FR

frame-relay lmi-type cisco



The config of the policy-map is the same on all router



class-map match-all CL_COPIE

match access-group name PRT_COPIE

class-map match-all CL_FTP

match access-group name PRT_FTP

!

!

policy-map PL_FTP

class CL_COPIE

bandwidth percent 50

class CL_FTP

bandwidth percent 20



ip access-list extended PRT_COPIE

permit tcp any any eq 445

permit tcp any eq 445 any

ip access-list extended PRT_FTP

permit tcp any any eq ftp-data

permit tcp any any eq ftp

permit tcp any eq ftp-data any

permit tcp any eq ftp any



map-class frame-relay QOS_FR

service-policy output PL_FTP






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Giuseppe Larosa Fri, 10/03/2008 - 01:44
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Harinirina,


>> We tried to use map-class and apply "frame-relay traffic-shaping" with class on serial interfaces, we can see the policy-map respected but the bandwidth is reduced, speed of transfert is really low.


a default bandwidth of 56 kbps is used when you enable classi traffic shaping you need to provide some info about CIR inside the map-class


map-class frame-relay QOS_FR

frame-relay cir {in | out} bps


see the link below


http://www.cisco.com/en/US/docs/ios/wan/configuration/guide/wan_afrt_shp_ic_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1015363


you need to shape on both branch routers to less then the access link speed at central site: they cannot know if the other remote is sending traffic or not.



Hope to help

Giuseppe





harinirina Mon, 10/06/2008 - 00:17
User Badges:

Hi all,


thanks both for the reply.


Giuseppe,


is there a way to do the same thing on ethernet interface?

we do another test using FastEthernet, we used banwidth to change it but there's no impact.



Joseph,


would you to give more information about "Fix", which you mentionned on :


>> The "fix" is to traffic shape the sending sites such that their transmissions don't oversubscribe the receiver's link. <<



Joseph W. Doherty Mon, 10/06/2008 - 02:32
User Badges:
  • Super Bronze, 10000 points or more

For example, if you had 3 sites, HQ and 2 branches, and all has 1 Mbps links to the FR cloud, snd both remotes might fill their 1 Mbps link sending traffic to the HQ, 2 Mbps traffic trying to egress the FR cloud to the HQ site will cause congestion. The fix would be to insure the transmission sum of the 2 brances to the HQ site doesn't exceed 1 Mbps. You could configure both branches with shapers that restrict them to 500 Kbps each, or branch 1 to 750 Kbps and brance 2 to 250 Kbps, etc.


PS:

Another fix would be to upgrade the HQ site to 2 Mbps (although with shapers to insure it doesn't send more than 1 Mbps to each branch).

Giuseppe Larosa Mon, 10/06/2008 - 13:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Harinirina,

>> is there a way to do the same thing on ethernet interface?

we do another test using FastEthernet, we used banwidth to change it but there's no impact


the bandwidth command provides the reference bandwidth for the interface and for the modular QoS but it is not enough by itself.

On an FE you can use Class Based Shaping.

You need to define traffic classes and policy-map that specify what to do for traffic that is classified on each class in your case the desired action is shaping


The simpler shaper you can think of is


policy-map shape-all-512kbps

class class-default

shape peak 512000


int f0/0

service-policy output shape-all-512kbps



here you can take advantage of the built-in class-default that collects whatever doesn't match previous classes : here everything goes in class-default


as a reference use:


http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/reg_pkt_flow_per_cls.html


I used 512 kbps thinking of a remote site in a scenario with two remote sites and an head quarter.


Hope to help

Giuseppe


harinirina Tue, 10/07/2008 - 22:16
User Badges:

Hi all,


We'd like to ask more question



Joseph,


Can we applied the first fix (insure the transmission sum doesn't exceed 1Mbps) on whatever link (VSAT, ADSL, ...) and on whatever interface (FastEthernet, WIC ADSL, Serial, ...)?


what about the command to use, is it the "shape peak" applied on each class?



Giuseppe,


let's say we have a VSAT connection of 128 Kbps. The IDU is connected to a FastEthernet interface.

We'd like to use 50% of bandwidth for the port 445 and 20% for FTP.


So, do we need the configure 2 policy-map, one for limiting the total bandwidth and the other for specifying bandwidth per protocol? is it that or not?



in case we have an ADSL connection, can we do the same thing?

Joseph W. Doherty Wed, 10/08/2008 - 04:05
User Badges:
  • Super Bronze, 10000 points or more

"Can we applied the first fix (insure the transmission sum doesn't exceed 1Mbps) on whatever link (VSAT, ADSL, ...) and on whatever interface (FastEthernet, WIC ADSL, Serial, ...)?"


If you're using a Cisco router, you should be able to shape on most interface types. (Actual WAN technology, other than actual bandwidth, not too important, it has more to do with interace type on router.)


"what about the command to use, is it the "shape peak" applied on each class? "


No, you would not shape each class, you would shape a parent class that in turn would have a subordinate policy.


e.g.


policy-map aChild

class realtime

priority percent 30

class gold

bandwidth remaining percent 60

class silver

bandwidth remaining percent 30

class scavenger

bandwidth remaining percent 1

class class-default

bandwidth remaining percent 9


policy-map aParent

class class-default

shape average ###

service-policy aChild


interface serial #

service-policy output aParent


(You could use either peak or average shaping, which to chose depends on whether you want to allow additional traffic bursts.)

Giuseppe Larosa Wed, 10/08/2008 - 05:59
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Harinirina,


>> let's say we have a VSAT connection of 128 Kbps. The IDU is connected to a FastEthernet interface.

We'd like to use 50% of bandwidth for the port 445 and 20% for FTP.


different solutions are possible you can use a single policy-map with multiple traffic classes our you could use hierarchical policy-maps.

You can shape or use schedulers (queueing) as in Joseph's example.


You can apply modular QoS out an ATM (ADSL) interface.Depending on IOS versions and platforms you can apply the QoS to an atm subinterface or not in almost all cases you can apply it to the main interface even if a subif is defined.

see :

RT-TGR-AQUILA#sh run int atm0

Building configuration...


Current configuration : 137 bytes

!

interface ATM0

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

service-policy output llq_voice

end


RT-TGR-AQUILA#


RT-TGR-AQUILA#sh policy-map llq_voice

Policy Map llq_voice

Class llq_voice

Strict Priority

Bandwidth 200 (kbps) Burst 5000 (Bytes)

Class class-default

RT-TGR-AQUILA#


RT-TGR-AQUILA#sh policy-map int atm0


ATM0


Service-policy output: llq_voice


Class-map: llq_voice (match-all)

9100240 packets, 1336196836 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 5

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 200 (kbps) Burst 5000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0


Class-map: class-default (match-any)

85776090 packets, 46749841402 bytes

30 second offered rate 394000 bps, drop rate 0 bps

Match: any

RT-TGR-AQUILA#



Hope to help

Giuseppe


harinirina Fri, 10/10/2008 - 06:19
User Badges:

Hi,



Thanks indeed for all your reply. They are extremelly helpful.


We'll use it.

Joseph W. Doherty Fri, 10/03/2008 - 04:17
User Badges:
  • Super Bronze, 10000 points or more

"When there's a traffic from 2 sites to the main office, the policy-map is no more respected. "


When you have multiple sites that can send traffic to one site, it can be easy to oversubcribe the one receiving site's bandwidth (from a cloud to it).


The "fix" is to traffic shape the sending sites such that their transmissions don't oversubscribe the receiver's link. The disadvantage of this, when only one site is sending, it can not take advanatage of bandwidth not being used by the other sending site(s).


If you do shape multiple sending sites, they don't have to be all in the same proportion. Also, although no oversubscription guarantees there won't be cloud egress congestion, you can configure shaping to allow some oversubscription.


PS:

One of the feature of MPLS vs. frame-relay is MPLS often can provide QoS so you can better manage congestion as traffic exits the cloud.

Actions

This Discussion