Could not find network adapter needed for registration

Unanswered Question
Oct 3rd, 2008

Cisco IP Communicator has worked well for a month now. One morning I go to launch the app and I get the error message: Could not find network adapter needed for registration. I rebooted my pc and I got the same result. I reinstalled the app and got the same results. I don't know what if anything changed, but I know I can't even get the application to load to look at any settings. PLEASE HELP!!!

Brian C

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
IChatzikon Mon, 10/06/2008 - 02:31

There is a known bug with vista and wireless adapters which as noted in bug tool is fixed in CIPC v2.1(5) which is not yet published.

Till then, null the value of the key NetworkCurrentAdapter both in HKCU and HKLM, and cipc will ask you again to register an adapter. For a little automation, make a batch using reg commands which will do the job and assosiate it with cipc shortcut.

Hope this helps.



This Discussion