CDR Errors CCM 4.2(3)

Unanswered Question
Oct 3rd, 2008
User Badges:

When attempting to pull a report in CDR>System Reports>Traffic>Summary by Extension, I am receiving the following error message:


30023: Data is not available for the date range selected. Data is available only from Mar 23,2007 to Jul 26, 2008.


So, I am assuming something changed in how the system was collecting data after Jul 26. What I don't have any idea about is why, and how to fix it.


Any insight would be greatly appreciated!


Tony

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jbayuka Thu, 10/09/2008 - 08:35
User Badges:
  • Bronze, 100 points or more

This error can result from these situations:

CDR is not enabled properly.

Data is not synchronized between the CDR and ART databases.

The Comments column of the CallDetailRecord table has data that exceeds 256 characters.


Refer the URL: CallManager Issue Resolution with CDR and ART FAQ:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_qanda_item09186a008020650a.shtml


jbarcena Thu, 10/09/2008 - 12:15
User Badges:
  • Red, 2250 points or more

>>>Verify that "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" services are running ONLY in the Publisher Call Manager:


in your publisher callmanager server, go to start > programs > administration tools > services > verify the status for services "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler". If they are not "started", please restart them (just right-click on the service and select "restart").


If "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" are running also in the subscriber servers, please stop them.


-------------------


>>>Verify service parameters in callmanager servers (publisher and subscriber).


--go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco CallManager" > click on "advanced" > verify that the following parameters are set to the correct values:


CDR Enabled Flag = True

CDR Log Calls with Zero Duration Flag = True

Call Diagnostics Enabled = True


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco Data Base Layer Monitor" > verify that the following parameter is set to the correct value:


Max CDR Records = 1500000


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > system > enterprise parameters > verify that the following parameters are set to the correct values:


CDR File Time Interval (min) = 1

CDR Format = CDRs will be inserted into database

CDR UNC Path = \\\CDR

Local CDR Path = C:\Program Files\Cisco\CallDetail


***Repeat the same procedure for all callmanager servers in your cluster***


-------------------


>>>Please go to start > programs > administration tools > services and restart the following services after hours:


1) Restart service "Cisco database Layer Monitor" on publisher and subscriber servers.


2) Restart service "Cisco CDR Insert" on the publisher server.


3) Restart service "Cisco CDR Analysis and Reporting Scheduler" on the publisher server.


-------------------


>>>Run SQL querys:


In your publisher server, go to start > programs > SQL Server > Query Analyzer > SQL Server: (local) ; Select "windows authentication"; click on "OK" > select the "ART" database from the drop-down menu. Run the following queries (just copy and paste the following in the main window, then click on the "execute query" icon):


delete from Tbl_Load_History

delete from Tbl_Dump_PkID

delete from Tbl_Error_Id_Map

delete from Tbl_Billing_Data

delete from Tbl_Billing_Error

delete from Tbl_Dump_CallDetailRecord

delete from Tbl_Dump_CallDetailRecordDiagnostic


-------------------


Login into the CAR tool > go to the "system" menu > scheduler > CDR Load > Load CDR & CMR > by default, Time will be set at 00 Hr, 00 Min; Loading Interval = Every 24 hours; please change the "Duration" parameter to 120 min.


-------------------------


Restart the services one more time.

Actions

This Discussion