auto qos

Unanswered Question
Oct 4th, 2008


I enable the auto qos on the WAN link. When I enable the SDM to monitor it. There is "default class data" only. I select the "nuber of packet tx". The result is the same. below is default "auto qos" config. I change the bandwidth setting only. Any missing in the config?

BTW, why there is "rmon" is enabled automatically. what is it? what happen if I remove it?


! R1 config

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 50

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default


interface Serial1/0

no cdp enable

service-policy output AutoQoS-Policy-Trust

rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
anitachoi3 Sun, 10/05/2008 - 05:21


1. the b/w is 20M

2. It seems that I haven't marked the voip traffic

3. class-default is for data, not for voip

I have 3 x AS54 router Voip gateway. All of them are standard config for dial-peer (pots and voip).

how do I mark the voip packet?

Base on the config (no mark the voip packet), can voip go to pri-q? any QoS service can be provide by the WAN link only?


Did you read the URL I posted previously??

If your outgoing interface is the serial interface - then a good place to mark the traffic is as close to the source as possible i.e the switch port.

If you are unable to mark that close, then I suggest you mark on the LAN interface if your router.

One more thing - if you have a 20mbs circuit, why are you trying to apply QoS? Remember priority queuing for QoS will only work when "congestion" occurs - does your 20mbs circuit ever reach 100%???

You need to look into Policing and shapping of traffic in the interface if you are having VoIP quality issues.


anitachoi3 Sun, 10/05/2008 - 09:24


I read the doc, some of them I understand what it address. It does not mention how to mark the voip packet on AS54 router. It mentions to enable the "auto qos voip" on LAN switch. Does it mean that the packet should be marked on layer 2 to be more effectively?

I enable the QoS on AS54, below is the command I work on. Does it work? any missing?

! R2 AS5400

class map VOIP

match ip access-group 10

set dscp ef

policy map QOS

class VOIP

priority 80

access-list 10 permit

interface GE 0/0

ip address

serice-policy output QOS

dial-peer voice 8601 voip


dial-peer voice 8602 voip


BTW, anything I need to aware after I enable the "auto qos voip" on switch? (e.g. in router, we may tune the b/w setting after auto qos voip is enable)



anitachoi3 Sun, 10/05/2008 - 21:03


the default gateway of AS54 is there is no WAN link on AS54. the source ip of voip traffic is

Is the QoS working?


So just let me get this straight....

The router with the QoS configure on it - does NOT have a WAN link attached. You are placing QoS on a gig ethernet interface - when your 20mbs circuit does no actually connect to the router where you want to apply QoS...... that is NOT possible.

You need to get a better understanding of QoS - I suggest you re-read the link I posted, and read teh below:-

NO - the QoS is not working.


anitachoi3 Mon, 10/06/2008 - 05:23


that doc is related the queue design and QoS.

May I ask a question directly?

1. It is not necessary to config QoS on AS54, is it? If not, any sample config for me to reference


OK to answer you question - what interfaces are connected on the AS54 device? Do you have a WAN connection? Or is it just a LAN connection? if it is just a LAN connection - what is the speed 100mbs or 1gbs??

QoS is used for congestion management and priority of specific traffic. Are you really seeing congestion on your LAN?

Please read the QoS SRND guide - this tells you everything you need to know about QoS, what it is desgined for, where you should deploy - network designs etc.

You cannot just turn QoS on - expect it to work and fix issues, if you don't even know if you need it.


anitachoi3 Mon, 10/06/2008 - 08:16


The GE is connected to AS54 and there is no WAN. The WAN is connected to 76 router. They (76 and AS54) are on the same segment. There is no congestion in LAN. the speed is 1G.

Base on the cisco suggestion, the marking should be near to source. Why config the QoS on LAN switch, not on the AS54? Is it related to performance issue?

If I use another model of switch (e.g. 3COM or Dlink) as core switch, do router support the QoS which 3Com marking?

I am not expert on QoS, that's why I seek for someone help to solve my concern and question.



This Discussion