HSRP no working (both showing active)

Unanswered Question
Oct 5th, 2008
User Badges:

Hi,


I have configured two sub interface inorder to setup 2 DHCP in a router and HSRP between two routers, HSRP is working for .10 and but not the .71, Config is pasted below for further reference.


Current B1 router config

------------------------------------


interface FastEthernet0/0

description #### DATA ####

ip address 172.24.3.7 255.255.255.0

ip route-cache flow

duplex auto

speed auto

no standby redirect

standby ip 172.24.3.1

standby priority 150

standby preempt

!


============================================


Proposed config on B1 router

--------------------------------------------

Clean up of current config



interface FastEthernet0/0

description #### DATA ####

No ip accounting output-packets

No ip nbar protocol-discovery

No ip address

No ip route-cache flow

duplex auto

speed auto

No standby redirect

No standby 0 ip 172.24.3.1

No standby priority 150

No standby 0 preempt



!


-----------------------------------------------


New config for LAN - Data and WIFI

===================================


interface FastEthernet0/0.10

description #### DATA ####

encapsulation dot1Q 10 native

ip address 172.24.3.7 255.255.255.0

standby 0 ip 172.24.3.1

standby 0 preempt

standby 0 priority 150

!

interface FastEthernet0/0.71

description #### WIFI ####

encapsulation dot1Q 71

ip address 172.24.71.7 255.255.255.0

standby 1 ip 172.24.71.1

standby 1 preempt

standby 1 priority 150

====================================



Current B2 router config

----------------------------------------------


interface GigabitEthernet0/0

description #### DATA ####

ip address 172.24.3.5 255.255.255.0

ip route-cache same-interface

duplex auto

speed auto

standby 0 ip 172.24.3.1

standby 0 priority 75

!








========================================


Proposed config on B2 router

--------------------------------------------

Clean up of current config



interface GigabitEthernet0/0

description #### DATA ####

no ip address 172.24.3.5 255.255.255.0

ip route-cache same-interface

duplex auto

speed auto

no standby ip 172.24.3.1

no standby priority 75






New config for LAN - Data and WIFI

===================================


interface FastEthernet0/0.10

description #### DATA ####

encapsulation dot1Q 10 native

ip address 172.24.3.5 255.255.255.0

standby 0 ip 172.24.3.1

standby 0 priority 75


!

interface FastEthernet0/0.71

description #### WIFI ####

encapsulation dot1Q 71

ip address 172.24.71.5 255.255.255.0

standby 1 ip 172.24.71.1

standby 1 priority 75






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish_zanjurne Sun, 10/05/2008 - 23:45
User Badges:
  • Silver, 250 points or more



hi,


Can you paste the output of "show standby"

of both routers ?

dipumj Mon, 10/06/2008 - 00:06
User Badges:

B1#sh standby

FastEthernet0/0.10 - Group 0

State is Active

1 state change, last state change 2d16h

Virtual IP address is 172.24.3.1

Active virtual MAC address is 0000.0c07.ac00

Local virtual MAC address is 0000.0c07.ac00 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.336 secs

Preemption enabled

Active router is local

Standby router is 172.24.3.5, priority 75 (expires in 9.420 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Fa0/0.10-0" (default)

FastEthernet0/0.71 - Group 1

State is Active

11 state changes, last state change 14:31:22

Virtual IP address is 172.24.71.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.336 secs

Preemption enabled

Active router is local

Standby router is unknown

Priority 150 (configured 150)

IP redundancy name is "hsrp-Fa0/0.71-1" (default)

HSRP ICMP redirects disabled

-----------------------------


B2#sh stand

GigabitEthernet0/0.10 - Group 0

State is Standby

1 state change, last state change 2d15h

Virtual IP address is 172.24.3.1

Active virtual MAC address is 0000.0c07.ac00

Local virtual MAC address is 0000.0c07.ac00 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.716 secs

Preemption disabled

Active router is 172.24.3.7, priority 150 (expires in 7.632 sec)

Standby router is local

Priority 75 (configured 75)

Group name is "hsrp-Gi0/0.10-0" (default)

GigabitEthernet0/0.71 - Group 1

State is Active

1 state change, last state change 14:38:50

Virtual IP address is 172.24.71.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.708 secs

Preemption disabled

Active router is local

Standby router is unknown

Priority 75 (configured 75)

Group name is "hsrp-Gi0/0.71-1" (default)


Jon Marshall Mon, 10/06/2008 - 02:06
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Have you configured the router to switch connections as 802.1q trunks and vlan 71 does exist on the switch(es) ?


Jon

Actions

This Discussion