Duplex mismatch on link betw. 2950 and 6500

Unanswered Question
Oct 6th, 2008

I am having a duplex mismatch on faste trunk uplink between a 2950 and 6500. The 2950 auto neg at full/100, the 6500 auto neg at half/100. I tried adding the command "duplex full" on the 6500 interface and drop connection.

This is my interface config:

2950# interface FastEthernet0/25

switchport mode trunk

6500#interface FastEthernet2/1


switchport trunk encapsulation dot1q

switchport mode trunk

What am I missing? and why will this not auto neg at full duplex?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Mon, 10/06/2008 - 08:08

Try to set both ends explicitly if auto-negotiation is not working for you.

int fa0/25

speed 100

duplex full

int fa2/1

speed 100

duplex full


kris55s Mon, 10/06/2008 - 10:11

I set the 6500 end to duplex full and waited. Link then came back up and was at full duplex. Cleared counters on both interfaces and they now seem to be error free and duplex is now matched.

I could not set speed or duplex on the 2950. Was not an option on that interface.


glen.grant Mon, 10/06/2008 - 10:49

Is F0/25 a fiber interface on the 2950 ? That would be 100/full by default. What is on the 6500 end ? If you can't set the speed on the 2950 then it must be fiber . If the 6500 end has a media converter on it that may be why it came up as half duplex.

kris55s Mon, 10/06/2008 - 11:01

f0/25 on the 2950 is a fiber interface.

On the 6500 it's a 100FX MM blade so that is fiber as well.

orsonjoon Thu, 01/21/2010 - 05:41

We have the exact same error in CM LMS3.2

This link has ports with mismatching duplex.
Port GigabitEthernet0/26 on device switch1 with mode auto-duplex

Device type and OS version of switch1:
Cisco IOS Software, C3560 Software (C3560-IPBASEK9-M), Version 12.2(52)SE, RELEASE SOFTWARE (fc3)

Port GigabitEthernet2/3/10 on device switch2 with mode full-duplex

Device type and OS version of switch2:
Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-M), Version 12.2(33)SXI, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport

False Link Duplex Mismatch messages, with the option to fix this:

Recommended Fix:

interface Gi0/26
speed auto

interface Gi2/3/10
speed auto

The only problem is that you can't see this command back in the configuration of the switch, because it is allready in auto mode.

There are no errors whatsoever on the interfaces of both switches.

I don't think I want to change any of the settings on the switch, just because Ciscoworks can't handle this correctly.

Does anyone know how to fix this, or is this jet another bug?


This Discussion