3825 sending DSCP in one direction, not the other.

Unanswered Question
Oct 6th, 2008

The topology: (hopefully my ASCII drawing formats correctly)

-------------

[IPTube1]-<vlan11>-[2970]-<vlan11>-[3825]-<vlan42>-[1811]-<vlan31>-[IPTube2]

The IPTubes are from Engage and are TDM to IP devices that have been configured to mark packets with ToS 0x08 (DSCP 2).

The problem:

------------

The 3825 either isn't receiving DSCP 2 from IPTube2 or isn't sending DSCP 2 from IPTube 2 on to IPTube 1:

1811#show policy-map interface vlan42

Vlan42

Service-policy output: IPTube

Class-map: IPTube (match-all)

111036374 packets, 68953588269 bytes

5 minute offered rate 1656000 bps, drop rate 0 bps

Match: dscp 2

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

1584 packets, 224640 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

3825#show policy-map interface vlan11 output

Vlan11

Service-policy output: IPTube

Class-map: IPTube (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp 2

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

565011 packets, 31043926 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

In the other direction, everything is fine. The 1811 is seeing DSCP 2 from IPTube 1 all the way through the network without a problem:

3825#show policy-map int vlan42 output

Vlan42

Service-policy output: IPTube

Class-map: IPTube (match-all)

256763715 packets, 159450264603 bytes

5 minute offered rate 1655000 bps, drop rate 0 bps

Match: dscp 2

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

554345 packets, 319306444 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

1811#show policy-map interface vlan31

Vlan31

Service-policy output: IPTube

Class-map: IPTube (match-all)

111002338 packets, 68932451910 bytes

5 minute offered rate 1655000 bps, drop rate 0 bps

Match: dscp 2

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

10599 packets, 635940 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Anyone see anything fishy in the configs or in the software versions that might explain this? Only the non-working bits are included below, but in both the working and non-working cases, the same class-map and policy-map are used.

SW versions:

----------

3825: 12.4(10) (Advanced IP Services)

1811: 12.4(6)T11 (Advanced IP Services)

Configs:

-------

! 1811

!

interface FastEthernet9

description ** TLS to 3825

switchport access vlan 42

!

interface Vlan42

ip address 10.79.253.6 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip tcp adjust-mss 1412

service-policy output IPTube

!

class-map match-all IPTube

match dscp 2

!

!

policy-map IPTube

class IPTube

priority 2000

!

! 3825

!

interface FastEthernet0/1/0

description ** 2970

switchport mode trunk

!

interface Vlan11

ip address 10.79.11.250 255.255.255.0

service-policy output IPTube

!

class-map match-all IPTube

match dscp 2

!

policy-map IPTube

class IPTube

priority 2000

!

Thanks in advance for any insight folks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
owillins Fri, 10/10/2008 - 13:24

Please verify your interfaces towards IPTube2 and 3825 using command

show mls qos interface.

Verify your DSCP marking also.

Verify your VLAN port configuration between 1811-3825 have some problem.

jlixfeld Thu, 10/16/2008 - 05:55

The interfaces are fine. The 3825 sees DSCP from IPTube1 and sends it off towards the 1811 where it can be seen heading towards IPTube2. The 1811 sees DSCP from IPTube2 heading towards the 3825 and appears to be sending it towards the 3825, but the 3825 isn't seeing it.

Since it works one way and not the other, I don't think it's a VLAN issue between the 1811 and the 3825.

Marwan ALshawi Fri, 10/10/2008 - 17:05

the first thing is on the switchport level u need to trust COS or DSCP based on ur device

the same thing on the uplink port to other switch along the way to get end-toend qos marking

if helpful Rate

jlixfeld Thu, 10/16/2008 - 05:52

The ports on the switches are fine. If they weren't, I wouldn't be able to see DSCP on either router, which I do. The problem is the 3825 isn't seeing the DSCP markings from IPTube2, but the 1811 does see the DSCP markings from IPTube2, so something is blocking them between the 1811 and the 3825 (but the 1811 can see DSCP markings from IPTube1 via the 3825 in the other direction, no problem).

Actions

This Discussion