T1 Controller Down

Unanswered Question
Oct 6th, 2008

Good evening everyone. Hope someone can help me figure this one out. This past weekend I converted a client from a Nortel Option 81 to a Cisco system running 6.1(2). The local PRI's came up just fine but the long disatance T1 never came up. I get "Carrier Detect" but I'm seeing a lot of "Line Code Violations". Their DMARC and SmartJack is just out side their suite and extended into their suite via Cat5 and terminated on a patch panel. I can place a loopback plug in the port on the patch panel where the T1 is patched and my controller comes up. When I place the circuit inline, I get the errors and the controller goes down. The weird thing is I can plug the T1 back into the CSU/DSU that goes to the Nortel system and it will come up and I can make long distance calls. Any help is greately appreciated.

T1 0/0/1 is down.

Applique type is Channelized T1

Cablelength is short 133

Transmitter is sending remote alarm.

Receiver has loss of frame.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20040802, FPGA: 13, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (890 seconds elapsed):

7289990 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 890 Unavail Secs

Total Data (last 23 15 minute intervals):

163647851 Line Code Violations, 69747 Path Code Violations,

102 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

6 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 20551 Unavail Secs

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chad Stachowicz Mon, 10/06/2008 - 17:59

would you mind pasting the full config of the router 'sh run' and a 'sh isdn status'.... lastly are u using the original cable from the old T1 to the nortel or a new cable?

Chad

keith-williams Mon, 10/06/2008 - 18:23

Hey Chad thanks for the quick reply. Below is a sh run command. I did not do a sh isdn status because this is a T1 so there isn't an ISDN status. I am using the original cabling that extends into the suite but I have a T1 Crossover cable running from the patch panel to the T1 card. I took out the crypto to save space.

Godwin_Dallas_3825#sh run

Building configuration...

Current configuration : 9885 bytes

!

! Last configuration change at 20:42:04 DST Mon Oct 6 2008 by admin

! NVRAM config last updated at 14:06:23 DST Mon Oct 6 2008 by admin

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Godwin_Dallas_3825

!

boot-start-marker

boot-end-marker

!

card type t1 0 0

card type t1 0 2

card type t1 0 3

logging buffered 4096 informational

enable secret 5 $1$rzPS$DTmPZGi/ry6fZZB1uDvYm/

!

no aaa new-model

!

resource policy

!

clock summer-time DST recurring 2 Sun Mar 2:00 1 Sun Nov 2:00

network-clock-participate wic 0

network-clock-participate wic 2

network-clock-participate wic 3

network-clock-select 1 T1 0/0/1

ip subnet-zero

ip cef

!

ip domain name legaleagles.law

ip name-server 10.10.10.55

isdn switch-type primary-ni

voice-card 0

no dspfarm

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

supplementary-service h450.12

h323

!

voice translation-rule 1

rule 1 /5\(.........011\)/ //

!

!

voice translation-profile InternationalCall

translate called 1

!

controller T1 0/0/0

framing esf

linecode b8zs

ds0-group 0 timeslots 1-24 type e&m-wink-start

!

controller T1 0/0/1

framing esf

linecode b8zs

cablelength short 133

ds0-group 0 timeslots 1-24 type e&m-wink-start

!

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

controller T1 0/2/1

framing esf

linecode b8zs

pri-group timeslots 1-24

!

controller T1 0/3/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

class-map match-any VOIP

match ip dscp ef

match ip dscp cs5

class-map match-all ALLOTHER

match input-interface GigabitEthernet0/1

class-map match-all VIDEOOUT

match ip dscp af41

class-map match-all VIDEOCONFERENCING

match source-address mac 0050.6001.A98A

class-map match-all other

class-map match-any VOIP-SIGNALING

match ip dscp af31

match ip dscp cs3

!

!

policy-map VOICEPOLICYOUT

class VOIP

priority percent 30

class VIDEOOUT

bandwidth percent 10

class VOIP-SIGNALING

bandwidth percent 5

class class-default

fair-queue

policy-map UNTRUSTED

class ALLOTHER

set ip dscp default

policy-map VIDEOIN

class VIDEOCONFERENCING

set ip dscp af41

!

!

!

!

interface Loopback64

ip address 10.254.228.254 255.255.255.255

!

interface GigabitEthernet0/0

description Dallas connection to Cogent to Houston

ip address 10.133.13.21 255.255.255.0

shutdown

duplex full

speed 100

media-type rj45

no negotiation auto

service-policy output VOICEPOLICYOUT

!

interface GigabitEthernet0/1

description 3825_to_Core

ip address 10.10.77.4 255.255.255.0

duplex full

speed 100

media-type rj45

negotiation auto

!

interface FastEthernet0/1/0

description Gateway for Videoconferencing in Dallas

switchport access vlan 100

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

keith-williams Mon, 10/06/2008 - 18:24

interface Serial0/2/0:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/2/1:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/0:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Vlan1

no ip address

!

interface Vlan100

ip address 10.10.30.2 255.255.255.0

service-policy input VIDEOIN

!

router rip

version 2

network 10.0.0.0

network 198.168.1.0

network 198.168.10.0

network 198.168.17.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.77.2

ip route 10.11.25.0 255.255.255.0 10.133.13.6

ip route 10.11.27.0 255.255.255.0 10.133.13.6

ip route 10.11.29.0 255.255.255.0 10.133.13.6

ip route 10.11.30.0 255.255.255.0 10.133.13.6

ip route 172.31.240.0 255.255.255.0 10.10.26.254

!

!

ip http server

no ip http secure-server

!

control-plane

!

!

!

voice-port 0/2/0:23

input gain 3

output attenuation -3

echo-cancel coverage 24

!

voice-port 0/3/0:23

input gain 3

output attenuation -3

echo-cancel coverage 24

!

voice-port 0/0/0:0

!

voice-port 0/0/1:0

!

voice-port 0/2/1:23

input gain 3

output attenuation -3

echo-cancel coverage 24

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/2/0:23

!

dial-peer voice 2 pots

incoming called-number .

direct-inward-dial

port 0/2/1:23

!

dial-peer voice 3 pots

incoming called-number .

direct-inward-dial

port 0/3/0:23

!

dial-peer voice 4 pots

destination-pattern 9[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/2/0:23

forward-digits 10

!

dial-peer voice 5 pots

destination-pattern 9[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/2/1:23

forward-digits 10

!

dial-peer voice 6 pots

destination-pattern 9[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/3/0:23

forward-digits 10

!

dial-peer voice 7 pots

destination-pattern 5.........1[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/2/0:23

forward-digits 11

!

dial-peer voice 9 pots

destination-pattern 911

port 0/2/0:23

forward-digits all

!

dial-peer voice 10 pots

destination-pattern 911

port 0/2/1:23

forward-digits all

!

dial-peer voice 11 pots

destination-pattern 911

port 0/3/0:23

forward-digits all

!

dial-peer voice 1000 voip

preference 1

destination-pattern 939[48]...

progress_ind setup enable 3

progress_ind progress enable 8

session target ipv4:10.10.9.11

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 2000 voip

destination-pattern 939[48]...

progress_ind setup enable 3

progress_ind progress enable 8

session target ipv4:10.10.9.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 2010 voip

preference 1

destination-pattern 7433...

progress_ind setup enable 3

progress_ind progress enable 8

session target ipv4:10.10.9.11

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 2020 voip

destination-pattern 74335...

progress_ind setup enable 3

progress_ind progress enable 8

session target ipv4:10.10.9.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 13 pots

preference 1

destination-pattern 91[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/3/0:23

forward-digits 11

!

dial-peer voice 12 pots

preference 2

destination-pattern 91[2-9].........

progress_ind setup enable 3

progress_ind progress enable 8

port 0/0/1:0

forward-digits 11

!

dial-peer voice 8 pots

translation-profile outgoing InternationalCall

destination-pattern 5.........011T

port 0/2/0:23

forward-digits all

!

Md. Mijanur Rahman Mon, 10/06/2008 - 21:38

Are you sure about the linecode (b8zs) is same as the line? You can check it at Nortel switch config or with the provider. This issue is common where linecode doesn't match.

keith-williams Tue, 10/07/2008 - 10:46

I just talked to the carrier and they confirmed linecode b8zs is what they have configured for this line.

tpolimine Tue, 10/07/2008 - 17:22

i had a similar issue, carrier told me they wer wink start, but had to set my H323 gateway to these settings to work

controller T1 0/3/1

framing esf

linecode b8zs

ds0-group 1 timeslots 1-24 type fxo-loop-start

Md. Mijanur Rahman Tue, 10/07/2008 - 21:00

Hi,

What the status of layer 1 you see with the command 'sh isdn status'? 'Deactivated' or 'Activating'? Try to collect the same after applying shut/no shut on the controller. If layer 1 stays 'Deactivated', conclusion should be problem at controller card. If the status is 'Activating' then the problem is your connectivity, look for layer 2 status. 'MULTIPLE_FRAME_ESTABLISHED' or 'TEI_ASSIGNED'? Issue the command 'sh int S0/2/0:23', do you see 'Serial0/2/0:23 is reset'?

Also try to reload the router after a 'copy run start', sometimes it brings up layer 2.

keith-williams Thu, 10/09/2008 - 07:38

Hello everyone. Wanted to thank all that replied and let everyone know that the problem has been resolved. Turned out to be an infrastructure problem (bad cable) in the DMARC extention. UGH!!!

Thanks again NetPro's!!

Actions

This Discussion